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1 About This Guide 

Welcome to the Magento Community Edition User Guide, which provides an overview of 

the Magento Community Edition (CE) eCommerce platform developed by Magento, Inc. 

This guide is intended for web storeowners and first-time users of Magento CE. It provides 

a quick guide through the most important steps for getting your web store up and running 

and ready for selling online. The options described in this user guide enable you to 

generate a feature-rich and attractive eCommerce interface without the need for advanced  

technical expertise. 

This guide first introduces Magento CE and its key concepts, and then describes how to 

install Magento CE. The following two chapters introduce the daily experience that a 

customer can have in a Magento web store and the daily management tasks that a 

storeowner would perform.  

The rest of the chapters walk you through the process of setting up your Magento CE web  

store; customizing its behavior to your requirements; entering products; managing orders, 

invoices and shipments; and achieving the best turnover and profits from your web store. 

2 Support and Contact Information 

We at Magento are dedicated to providing our customers with the best possible service.  

We would love to hear from you.  

For feedback on this book and all other inquiries, please use our contact form at: 

http://www.magentocommerce.com/company/contact  -  us/     

 1 

http://www.magentocommerce.com/company/contact-us/
http://www.magentocommerce.com/company/contact-us/
http://www.magentocommerce.com/company/contact-us/


3 Conventions Used in this Guide 

The following style conventions are used in this document: 

Note: This is a note. 

 

Tip: This is a tip providing useful suggestions and information. 
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4 Introducing Magento Community 

Edition 

This chapter introduces Magento Community Edition (CE), its basic components, and the 

workflow for using it. 

What is Magento CE? 

Magento CE is a feature-rich eCommerce platform, built on open-source technology 

that provides online merchants with unprecedented flexibility and control over the 

look, content, and functionality of their eCommerce store. Magento CE’s intuitive 

administration interface features powerful marketing, search engine optimization, 

and catalog management tools to give merchants the power to create sites that are 

tailored to their unique business needs. Designed to be completely scalable, 

Magento CE offers companies a stable, secure, customizable eCommerce solution. 

Magento CE License 

Magento CE is licensed under the Open Software License (OSL) v3.0, an open source 

certified license. More information about Magento’s licenses can be found at http://

www.magentocommerce.com/license/      
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Magento CE Frontend and Backend 

The following sections provide an overview of the two visible interfaces of Magento 

CE: the frontend and the backend. 

Frontend (The Web Store Front) 

The frontend is the public view of your web store with which your customers can 

interact through a standard web browser. It presents your products, product  

categories, and promotions, and provides your customers with ordering, payment, 

and purchase tracking features. 

An example is shown in Figure 1. 

 

Figure 1. Magento CE Frontend 

Introducing Magento Community Edition 

Backend (The Back Office) 

The backend is the password-protected view of the back office features that enable 

a web store administrator to setup the products and purchasing options and to 
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manage orders and all other store functionalities. You can navigate the Admin Panel 

using the menu on the top of the page (Magento top menu). A view of the backend 

is shown in Figure 2. 

 

Figure 2. Magento CE Backend 

Magento CE Concepts 

To use Magento CE effectively, you should be familiar with the following terms and 

concepts. 

Attribute: A characteristic of a product. For example, an attribute of a digital camera 

could be “resolution,” and the value of this attribute for a particular digital camera 
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could be “10 megapixels.” Customers can filter a list of products by values of one or 

more attributes. 

Attribute Group: A logical grouping of attributes within an attribute set. 

Attribute Set: A collection of attributes, customized to fit a certain type of product. 

For example, if you sell several different kinds of T-shirts on your website, you can 

create the T-shirts attribute set which will include the simple attributes commonly 

shared by all of your T-shirts. This may include color, size, gender, and brand. 

Bundle product: This product is composed of components that are presented in 

different ways and are made from existing products. A good example of a bundle is 

a complete computer. For this computer, you can configure how much RAM or what 

kind of monitor is included with this computer in your store. 

Category: A user-defined product classification. A category can have any number of 

levels of subcategories. 

Configurable product: This product enables your customers to select the variant that 

they want by choosing options. For example, you can sell T-shirts in two colors and 

three sizes. You would have to create six variants as individual products (each with 

its own SKU) and then add these six to a configurable product where customers can 

choose the size and color, and then add it to their cart.  

Credit memo: A credit memo is a statement of credits; for example, a credit for 

returned merchandise generates a credit memo. According to your store policy, you  

can apply the credit to future orders or refund the customer’s payment method. 

Cross-sell: Cross-sell products appear next to the shopping cart. When a customer 

navigates to the shopping cart page, these products are displayed as cross-sells to 

the items already in the shopping cart. They are similar to impulse buys, like 

magazines and candy at the cash registers in grocery stores. 
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Downloadable product: A product, such as a media file, that the customer 

downloads from the store after purchase. These downloadable files can reside on 

your server or be provided as URLs to any other server. 

Grouped product: This option enables you to display several similar products on a 

single page. For example, if you are selling chefs’ knives and you have the same 

knife in four sizes, you can make a grouped product to display all four of these sizes. 

Customers can select the size(s) that they want and add them to the cart from this 

page.  

Invoice: An invoice in Magento CE represents a confirmation of payment. More than 

one invoice can be associated with a single order. If the products in an order are 

shipped in multiple shipments, then an invoice is generated for each shipment for 

the products in that shipment. 

Order: An order is a request for goods. 

Order status: The order status indicates where it is in the order cycle. In Magento CE, 

the system order status values are the following: 

 Pending - Pending orders are brand new orders that have not been processed. Typically, 

these orders need to be invoiced and shipped. 

Introducing Magento Community Edition 

 On Hold - The user cannot proceed to order processing if the order is in this state. This is  

convenient if, for example, some data must be verified.  

 Pending PayPal (possible for PayPal orders only) - Pending PayPal orders are brand new 

orders that have not been cleared by PayPal. When using PayPal as a payment method, 

customers are redirected to the PayPal website. If they have not paid for the order, orders 

will be marked as Pending PayPal. It is not recommended to process these orders without 

referencing PayPal first to see if payment has been made.  

8 



 Payment Review - As long as an external payment gateway is verifying the payment 

information from a sales order, the order is assigned the Payment Review status both in the 

payment system and in Magento CE.  

 Processing - Processing means that the order has been either invoiced or shipped, but not 

both.  

 Suspected Fraud (possible for PayPal orders only) – The order transaction did not pass one or 

more of the PayPal fraud filters and the system receives the response from PayPal that the 

transaction is under review by Fraud Service 

 Complete - Orders marked as complete have fully been invoiced and have shipped.  

 Canceled - The order can be of this status if the customer calls your web store and asks to 

cancel an order if the order has not been paid for. 

The store administrator can create custom order statuses, assign them to order 

states and set default status values for order states. 

Product type: Magento CE classifies products as one of several predefined product 

types: Simple Product, Virtual Product, Downloadable Product, Grouped Product, 

Configurable Product, Bundle Product. 

Related product: Related products are offered to the customer for purchase in 

addition to the item that the customer is viewing. 

Scope: Scope describes the extent of your store hierarchy to which a given setting is 

effective. A setting can have a scope of Global (all websites, stores, and store views), 

Website (the selected website and all stores and store views under it), Store (the 

selected store and all store views under it), and Store View (the selected store view). 

Some settings that are set at a higher level can be overridden at a lower level. 
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Search Engine Optimization (SEO): The set of techniques and strategies that ensure 

that your site is listed prominently in search engine results, thereby increasing the 

likelihood that customers will find your site. 

Simple product: This is the most basic product type. It is suitable for all kinds of 

physical (shipped) products. 

Shipment: A shipment is a record of the products in an order that have been 

shipped. 

More than one shipment can be associated with a single order. 

Shopping cart: The set of products that a customer has selected to purchase, but has 

not yet purchased. 

Store: The second level of your store hierarchy. A website can have multiple stores 

(each, potentially, with its own root category), and a store can have multiple store 

views. 

Store View: The lowest level of your store hierarchy. Typically, a store view is created 

for each locale or language. All store views under a given store share the same 

catalog. Customers use a drop-down list on the frontend to switch from one store 

view to another. 

Tax rule: A combination of a product tax class, customer tax class, and tax rate. This 

rule defines which tax calculation is applied. 

Up-sell: An up-sell item is one that is offered to the customer as an alternative to the 

product the customer is viewing. These products may be more expensive, of higher 

quality, or more popular, or produce a higher profit margin. 

Virtual Product: This is a product that does not require shipping or inventory. It is 

generally used for warranties or services. 
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Website: The highest level of your store hierarchy. You can have multiple websites, 

and each website can have a different domain name. Websites can be set up to 

share customer data, or to not share data. Typically, each website has different lines 

of products and may have different customer bases. 
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5 Basic Configuration 

This chapter describes how to configure the basic information for your web store. The other 

aspects of your web store to be configured are described in the subsequent chapters of this 

guide. 

Accessing the Backend 

All of the basic configuration tasks are performed in the Magento CE backend. The 

following describes how to access and log in to the Magento CE backend.  

Tip: Immediately after you install Magento CE, you can easily open the backend 

by clicking the Go to Backend button on the last page of the Magento 

Installation 

Wizard. We recommend that you bookmark the backend page for easy 

access. 

To access the Magento backend administration environment: 

1. Use a standard web browser to navigate to the backend by entering the URL that you 

specified in the Magento Installation Wizard with the addition of the suffix /admin (or the 

one that you specified during installation). For example, if you 

specified mywebstore.com as the base URL, then use 

http://www.mywebstore.com/admin to access your backend. 

Note: The Magento CE Demo Store backend can be accessed at: 

http://demo  -  admin.magentocommerce.com/admin     

The Log in to Admin Panel page is displayed, as shown in Figure 12. 
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 Basic Configuration 

 

Figure 12. Backend Login Page 

2. Log in using the user name and password that you created during the installation process.  

3. Click the Login button to display the administration panel, as shown in. Figure 13. 

Basic Configuration 

 13 



 

Figure 13. Magento CE Backend 

4. After you log in, the Magento messages that you have not yet read are displayed, such as the  

one shown in Figure 14. 

 

Figure 14. Incoming Message Notice 
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Additionally, information about other messages is shown in a bar just under the 

menu (see Figure 15). See “Managing Administrator Messages,” page 60, for more  

information about managing these messages. 

 

Figure 15. Message Bar 

Store Hierarchy 

Among the first things you will want to do is plan your store hierarchy, that 

is, the arrangement of websites, stores, and store views. When Magento CE 

is installed, a “Main Website,” a default store, and a default store view are 

created. You will want to create additional websites, stores, and store views, 

depending on the breadth of the items you are selling and the composition 

of your target markets. 

To be able to create these entities, you need to create at least one root 

category first. See “Managing Categories,” page 77, for more information 

about creating root categories. For now, determine how you want your store 

hierarchy set up. 

Websites 

Suppose you want to sell machine shop equipment online, and your spouse wants 

to sell handmade baskets. It is unlikely that you would sell both of these product 

lines in a single store, but in a single Magento CE installation, you can do both by 

setting up separate websites. Each website can have its own domain name. The 

websites can be set up to share customer data, or not to share any data. 

Stores 
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For your handmade baskets website, you might want to set up two stores, one  

specializing in wicker and one for other materials. You can set up two root categories 

(one for wicker items and one for other items) and assign one to each store. (See 

“Managing Categories,” page 77, for more information about setting up root 

categories). Several stores of one website can have different independent domain 

names as well, but it should be configured on the store view level of each store. 

Store Views 

Your market research indicates that about half of your potential customer base 

speaks English, and the other half speaks Spanish. Within each store, you can create 

separate store views, one for English and one for Spanish. The store views share the 

same catalog, but each is presented in its respective language. Customers use a drop-

down list on the frontend to switch from one store view to another. 

Store Pages General Configuration 

This section describes how to configure general aspects of your frontend 

pages. These configurations are performed in the Configuration area of the 

Admin Panel. 
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 Basic Configuration 

To access the Configuration section, select System > Configuration. The tabs 

in the left column provide access to configuration options for different 

aspects of your Magento CE instance. The Current Configuration Scope 

drop-down list in the upper left corner of the page enables you to select the 

hierarch level (website, store, store view) to which the configuration will be 

applied. To apply configuration settings at the global level (that is, for all 

your websites, stores, and store views), leave Default Config selected. 

To open the options for configuring your store pages design click the Design 

tab in the left column. The Design page opens with a number of field sets. 

 

Figure 16. Design Configuration Page 

HTML Head Field Set 

The settings in the HTML Head field set on the Design tab are used to define general 

information about your store’s pages. These settings may not be visible to your 

customers, but they are important for things such as traffic analytics and search 

engine optimization. 

To define general page features: 

1. Click the HTML Head heading to expand the field set as shown in Figure 17. 
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Basic Configuration 

 

Figure 17. HTML Head Field Set 

Note: The words in square brackets (for example, [STORE VIEW]) indicate the 

scope of the associated option. 
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2. Click the Browse button and select an icon file (on your local computer) to use as a “favicon.” 

This small icon appears in the address bar of your customers’ browsers. 

3. In the Default Title field, specify the page title to be displayed in browsers for those pages that 

do not have their own title. This information is also used to improve search engine visibility 

and performance.  

4. In the Title Prefix and Title Suffix fields, specify a prefix and a suffix to be appended to the 

pages of your web store that have their own title, such as a prefix of My Web Store. 

5. In the Default Description and Default Keywords fields specify words that describe your web 

store to be used by search engines when page-specific information is not provided. Keywords 

must be separated by commas. 

6. Optional. Select Display Demo Store Notice to display a notice at the top of every page that 

indicates that this is a demo store and that no transactions will be processed. This option is 

useful while you are setting up your store prior to opening for business. 

7. Click the Save Config button on the top right of the page. 

Header Field Set 

The options on the Header field set define the look of the top of each page in your 

store. 

To define the header of each web store page: 

1. Click the Header tab to expand the section as shown in Figure 18. 

 

Figure 18. Header Field Set 
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Logo Image Welcome Message 

Basic Configuration 

2. In the Logo Image Src field, specify the logo graphic file to appear on the top left of each page  

of your web store, as shown in Figure 19 for the Magento Demo Store. Make sure that you  

name your logo something other than logo.gif, so it does not get overwritten in future 

upgrades. 

Figure 19. Page Header Section 

Note: You will need to upload the image file using an FTP client to the 

skin/frontend/default/default/images/ directory or to your own skin folder in 

your Magento CE installation. 

3. In the Logo Image Alt field, specify the alternative text to be displayed when your customers 

hover their mouse cursors over the logo image in your web store. 

4. In the Welcome Text field, specify the welcome message to be displayed on the top right of 

your web store for customers that are not logged in, as shown in Figure 19. 

5. Click Save Config to save your changes. 

Footer Field Set 

The options in the Footer field set define what is displayed at the bottom of each web  

page in your store. 

To define the footer of your web store pages: 

1. Select the Footer option to expand the page to display the footer options, as shown in Figure  

20. 
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 Basic Configuration 

 

Figure 20. Footer Field Set 

2. In the Copyright field, specify your web store’s copyright information. 

3. In the Miscellaneous HTML field, specify the custom HTML code to be added to the end of the 

page code that is generated by Magento CE. This area is usually used for adding tracking 

scripts that track your customers’ activity on the site. 

4. Click Save Config to save your changes. 

Store Contacts Configuration 

This section describes how to configure store email addresses that are used for 

internal and external email communications and the Contact Us feature. 

Web Store Emails  

The Store Email Address page of the system configuration enables you to specify 

email addresses and contact names to be used when sending email to customers 
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upon registration and at all steps of the order lifecycle. These email address are also 

used for sending error reports to the store administrator. 

To define web store email addresses: 

1. In the Admin panel, select System > Configuration > GENERAL >Store Email Address. Here 

you can configure the various email addresses used for sending emails from your web store 

to your customers. 

 

Figure 21. Store Email Addresses Page 

2. In the Current Configuration Scope drop-down list in the left upper left corner, select the 

scope for which you want these configurations to apply. All fields on this page can have 

different values for each store view. 

3. In each Sender Name field, specify the name of the sender or department from which the 

emails are sent. 

4. In the Sender Email field specify the email address used for sending the emails. 

5. Click Save Config to save your changes. 
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Note: See “Customizing Transactional Emails,” page 177, for more information 

about emails. 

Contacts 

These options define the email to which customers send requests when using the 

Contact Us option at the bottom of the pages of your web store. 

To define your web store contact information: 

1. In the Admin Panel, select System > Configuration > GENERAL >Contacts to display the 

Contacts page, as shown in Figure 22. 

 

Figure 22. Contacts Page 

2. In the Current Configuration Scope drop-down list in the left upper left corner, select the 

scope for which you want these configurations to apply.  

3. In the Enable Contact Us drop-down list, select Yes to enable customers to contact you by 

email with the Contact Us link, or select No to disable this communication method. 

4. In the Send Emails To field, specify the email that is used for receiving feedback when a 

customer uses the Contact Us option in the store. 

5. In the Email Sender drop-down list, select the email address from which feedback messages 

are sent. 
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6. In the Email Template drop-down list, select the template to be used for the Contact Us form 

displayed on the frontend. You can create custom email templates. For more information, see 

“Customizing Transactional Emails,” page 177. 

7. Click Save Config to save your changes. 

Sales Emails 

You can configure Magento CE to send emails that confirm an order, invoice, 

shipment, or credit memo to both registered customers and store guests. 

To configure sales emails sent to customers: 

1. In the Admin Panel, select System > Configuration > SALES > Sales Emails. 

2. In the Current Configuration Scope drop-down list in the left upper left corner, select the 

scope for which you want these configurations to apply. 

3. Click the Order heading to expand the Order field set, as shown in Figure 23. 

 

Figure 23. Sales Emails Page 

24 



 Basic Configuration 

4. In the Order field set, configure the following options: 

 In the Enabled drop-down list, select Yes to enable new order confirmation emails to be sent. 

 In the New Order Confirmation Email Sender drop-down list, select the email address to be  

used for sending the new order confirmation. 

 In the New Order Confirmation Template drop-down list, select the template to be used for 

the for the order confirmation emails sent to registered customers. 

 In the New Order Confirmation Template for Guest drop down- list, select the template to be 

used for the for the order confirmation emails sent to guest customers. 

 In the Send Order Email Copy To field, specify the email address to which a copy of the new 

order confirmation email is sent. This feature helps you to keep track of the new orders that 

come in. 

2. Configure the options on the other field sets on this page. 

3. Click Save Config to save your changes. 

Shipping Settings 

This section describes how to specify shipping options, such as the origin used for 

shipping rate calculations and whether to enable the multiple shipping destinations 

feature. 

Configuring shipping settings and shipping methods enables you to provide 

customers a selection of shipping methods with shipping rates during checkout. 

Magento CE includes extensive integration with major shipping carriers; for USPS,  

DHL, FedEx, and UPS you can create shipment orders and print shipping labels right 

from the Magento CE Admin Panel. See “Shipping,” page147, for details about 

shipping system integration. 
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To define general shipping options: 

1. In the Admin Panel, select System > Configuration > SALES > Shipping Settings. 

2. In the Current Configuration Scope drop-down list in the left upper left corner, select the 

scope for which you want these configurations to apply. 

3. Click the Origin and Options tabs to expand the page to display the shipping options, as 

shown in Figure 24. 

 

Figure 24. Shipping Settings Page 

4. Configure the options to match your store. 

5. Click Save Config to save your changes. 

See “General Shipping Settings,” page 147, for details about configuring shipping 

methods. 

Cookie Restriction Mode 
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Magento can notify store customers about cookies that are being used by a. The 

feature is called Cookie Restriction Mode. It is aimed at helping store owners to 

comply with the European Union Privacy and Electronic Communications Directive 

and its amendment. According to these documents, websites cannot use cookies 

until a user consents.  

Enabling and Configuring Cookie Restriction Mode 

To enable the cookie restriction mode: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Configuration > GENERAL > Web. 

3. In the Current Configuration Scope in the upper-left corner of the page select the desired 

website. 

4. Expand the Session Cookie Management filed set.  

5. In the Cookie Restriction Mode field select Yes. 

6. To save the changes click the Save Config button. 

Cookie Restriction Mode: Implementation Details 

After the cookie restriction mode is enabled, a message is displayed on the top of 

each page in the store front. The message informs customers that the website 

requires cookies to provide all of its features and requests users to confirm that they 

are informed and consent. See Figure 25. 
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Figure 25. A warning message is displayed in the frontend when 

the cookie restriction mode is enabled 

The message contains a link to the Privacy Policy page, which provides a list of cookies 

being collected and explains on how they are used. The default content of this page 

can be changed under CMS > Pages > Manage Content > Privacy Policy. 

After a customer clicks Allow, the message disappears.  

If a customer does not click Allow, the message persists, but the store functionality is 

available as usual. However, Google Analytics cookies are not stored in this case, 

even if the Google Analytics functionality is enabled.  

Cookies Used in Magento 
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The following table lists cookies, which are always stored by Magento on the 

customer’s side. 

Cookie Name Cookie Description 

USER_ALLOWED_SAVE_COOKIE Indicates whether a customer is allowed to use cookies 

external_no_cache A flag which indicates whether caching is disabled 

persistent_shopping_cart Session key 

Stf If links to a product were sent to friends, this cookie stores the 

timestamps in the '$timeStamp1, $timestamp2, ..., $timestampN' 

format. 

pollN A poll ID to indicate that the poll has been already voted. 

frontend Session ID 

guest-view Allows guests to edit their orders. 

 

The following table contains a list of cookies, which Magento additionally stores on 

customers side if the Full Page Cache functionality is enabled.  

Cookie Name Cookie Description 

CUSTOMER Hashed value of a customer ID in the 'customer_$customerId' format 

CUSTOMER_INFO Hashed value of a customer group ID in the 

'customer_group_$customerGroupId' format 

NEWMESSAGE Indicates whether a new message has been received  

CART Hashed value of a quote ID in the '$quoteId' format 

COMPARE List of product IDs added by customer to compare list in the 

'$productId 

1, $productId 2, ..., productId N' format 

POLL ID of a recently voted poll 

RECENTLYCOMPARED A customer's list of recently compared product IDs in the '$productId 

1, 

$productId 2, ..., productId N' format 
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WISHLIST Hashed list of products added to wishlist in the '$productId 

1_$productId 

2_..._productId N' format 

WISHLIST_CNT Hashed number of items in the customer's wishlist in the 

'wishlist_item_count_$productCount' format 

CUSTOMER_AUTH Indicates whether a customer is logged in. A hashed value of 

'customer_logged_in_0|1' 

CATEGORY_INFO Stores the category info on the page. This allows displaying pages 

more quickly. 

LAST_CATEGORY Recently visited category ID in the '$categoryID' format 

VIEWED_PRODUCT_IDS Recently viewed product IDs in '$productId 1, $productId 2, ..., 

productId N' format 

currency Code of the currency selected by a customer ('USD', 'UAH', 'GBP', etc.) 

store Store view code 

NO_CACHE Indicates whether it is allowed to use cache 

LAST_PRODUCT Last viewed product ID 

 

If the Google Analytics module is enabled and using cookies is allowed by a 

customer, Magento stores the following Google Analytics cookies: 

• _utma 

• _utmb_ 

• _utmc 

• _utmz. 
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For a description of the Google Analytics cookies refer the official Google 

documentation. 

 

6 Introducing the Frontend 

In order to familiarize you with the features of the frontend, this chapter describes the 

basic browsing and purchasing features provided for your customers by a web store 

created using 

Magento CE. This knowledge will help you make better decisions when setting up your 

store. 

Overview 

The frontend provides the view of your web store that is publicly available to 

customers using the Internet. The frontend shows your product catalog and 

provides your customers with ordering, payment, and tracking features.  

You can access the Magento demo web stores by navigating to 

http://demo.magentocommerce.com  .   The Single Store Demo is a sample Magento 

store that uses Magento’s default theme and sample data. This sample store is 

referenced throughout this user guide. 

You can access your own store by browsing to the address that you defined for it 

during installation. 
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Introducing the Frontend 

The illustration in Figure 26 shows the first page of a default Magento CE store with 

sample data. 

 

Figure 26. Magento CE Store Frontend 

Finding the Right Products  

The Magento CE frontend is also referred to in this guide as your web store. It 

provides a variety of options for browsing through the products offered and then 

drilling down to view detailed information about each product. Magento CE 

enables you to define the default appearance of how multiple products are 
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presented, such as whether they are shown as a list or grid (table), their sort order,  

and the filter that is used. 

Categories 

The products in the web store are grouped into categories, which are displayed in 

a bar near the top of the web store page. Each product can be assigned to one or 

more categories. 
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Categories can have multiple levels of subcategories. A customer can navigate to a 

subcategory using a category’s dropdown menu. Figure 27 shows the five 

categories on the Magento CE demo store and the subcategories under Electronics: 

Cell Phones, Cameras and Computers: 

 

Figure 27. Categories and Subcategories 

A category or a subcategory can each have a product list or show a landing page 

that features some products. Figure 28 shows a category that has products: 

 

Figure 28. Category Page with Products 
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Filtering the Display of Products 

Typically, the first step of a customer when browsing through the web store may be 

to select the category or subcategory of the products of interest. The customer can  

then filter the products in that category according to the various attributes of these 

products.  

The SHOP BY area on the left side of the frontend page provides a variety of 

product attributes that can be used to access the products in that category. The 

attributes in a category appear in groups, each with its own title. In the frontend 

page shown above, the groups that appear are PRICE (which shows ranges of  

prices), COLOR, MANUFACTURER and SHOE TYPE. Next to each attribute is the 

number of products that have that attribute.  

For example: The Apparel category has three green products, as shown in Figure 

29. 

Figure 29. Category Product Counts 

After a customer clicks on the Green attribute, all the green products are displayed  

in the web store for browsing and the SHOP BY area indicates that the products in 

this category have been filtered by the Color: Green attribute, as shown in Figure 

30. 
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Figure 30. Filter Indication 

To clear the filter and thus redisplay all the products in the currently selected 

category, click the Clear icon ( ) next to the filter, or click the Clear All Items 

option. 

Note: The third product is shown because it contains two variants inside: a 

green and a red version. 

Popular Tags 

Another option that Magento CE provides to help customers find the right product 

is called Popular Tags. Popular Tags provide another property that can be assigned 

to products that customers can select in order to view the products to which this 

tag has been assigned (see Figure 31).  
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Figure 31. Popular Tags 

Popular tags can be assigned by customers in the product page (see Figure 32) and 

can be approved and edited from the backend, if required. 

 

Figure 32. Adding a Tag to a Product 

Searching 

The top right of your web store page provides a search field in which a customer 

can type all or part of the name of a product, or its attributes, in order to find it, as 

shown in Figure 33. 

Figure 33. Search Tool 

Comparing Products 
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Introducing the Frontend 

Magento CE enables customers to compare two or more selected products, as 

follows: 

1. A customer first clicks the Add to Compare link provided for each product that he/she 

wants to compare, as shown in Figure 34. 

Figure 34. Add to Compare Link 

2. After selecting all the products to be compared, the customer then clicks the 

Compare Items button in the COMPARE PRODUCTS area, as shown in Figure 35. 

 

Figure 35. Compare Products Area 

The Compare Products page is then displayed in a pop-up window, as shown in 

Figure 36. 
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Figure 36. Compare Products Page 

Note: A row also appears for each comparable attribute defined for these 

products, such as Color. See “Managing Product Attributes,” page 88, for 

more information about defining attributes. 

Sorting Products 

A customer can sort the products that are displayed by selecting the relevant 

option in the Sort by drop-down list, as shown in Figure 37. 
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 Sort By Drop-down list Figure 37.

Introducing the Frontend 

Grid/List View 

By selecting the Grid or List links at the top of the page, a customer can choose to 

view products displayed in a grid (table), as shown in Figure 37, or as a list, as 

shown in Figure 38.  
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Recently Viewed 

The RECENTLY VIEWED PRODUCTS area (see Figure 39) lists the products that were 

recently viewed by the customer, whether they were purchased or not, and 

enables the customer to easily link back to them. 

 

Figure 39. Recently Viewed Products Area 
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 Product List Banner Figure 40.

Introducing the Frontend 

Promotional Information 

Magento CE provides a variety of aspects of product presentation that you can 

control and that enable you to promote and up-sell products to your customers.  

Product List Banners 

You can define the banner that appears at the top of each category landing page 

with a static block (see Figure 40). This feature adds a graphical element to your 

category pages that can be used for special promotions, or to highlight certain 

products. Banners can be defined per category. More information about how to 

create and add static blocks on your site can be found in “Managing CMS Pages,” 

page 174. 

Promotional Pages 

Another way to feature products and promotions in your web store is a customized 

category landing page, which is a static HTML page that may be displayed while 

the user browsing a category, instead of showing a list of products. See Figure 41. 
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Figure 41. Promotional Page 
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Up-sell Products  

Up-sell products are items that your customer could buy instead of the product that 

is being viewed. These products may be more expensive, of higher quality, or more 

popular, or produce a higher profit margin. 

The example in Figure 42 presents a more expensive keyboard and other products as 

up-sells to the less expensive keyboard. 
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Figure 42. Up-Sell Products 

Related Products 

Related products are meant to be purchased in addition to the item the customer is 

viewing. Related products are shown in the right column of your web store in a 

separate block. The example in Figure 43 shows various mobile phones promoted as 

related products.  
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Figure 43. Related Products 

Cross-sell Products 

Cross-sell products appear next to the shopping cart. When a customer navigates to the 

shopping cart page (whether automatically after adding a product or otherwise), these 

products are displayed as cross-sells to the items already in the shopping cart. They are 

similar to impulse buys, like magazines and candy at the cash registers in grocery stores. 

See Figure 44. 

 

Figure 44. Cross-Sell Item 
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Product Pages 

The backend enables you to define the type of information and functionality that is 

provided in a product’s page. Figure 45 shows a typical product page. 

 

Figure 45. Product Page 
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Most of the features provided to present a product in your web store are 

selfexplanatory. The following describes a few of these features: 

 Image: The customer can use the slider to zoom in and out of the image, click on it to enlarge  

it, or pan it to see different parts of it. 

 Description: The top of the page shows a short description in the Quick 

Overview area, and farther down you can see a more detailed Product 

Description area. Also, Additional Information details are provided about the 

product in the form of a table. 

 Product Tags: Shows the tags assigned to this product. Customers can navigate to other 

products by clicking on one of these tags. You can also define whether customers can add 

tags.  

 Reviews: Your customers can rate and review your products. The store administrator can 

approve or remove reviews. 

 Product Options: Magento provides a variety of controls that enable you to configure the 

product options that appear for a customer to select, such as check boxes, drop-down lists, 

and so on. For example, customers are able to select the size of a shoe, as shown in Figure 46. 

 

Figure 46. Product Options 
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Web Store Page Header and Footer 

Every web store has a header that appears at the top of each page and a footer that 

appears at the bottom of each page. These features enable you to control the look 

and feel of your web store and provide the customer with various functions, as 

described in this section. 

The Header 

The default header of each of your web store pages shows your web store logo and 

banner. An example is shown in Figure 47. 

Figure 47. Web Store Header 

This header also provides a variety of functions on the right, as follows:  

 My Account: Enables registered customers to access their order history, track their shipments, 

download products, and change address information. 

 My Wish List: Enables customers to define a list of items that they may want to purchase in the 

future. They can also share their wish list with their friends. 

 My Cart: Enables customers to see the products that they have selected to purchase. 

 Checkout: Enables customers to start the checkout process in order to specify payment, billing, 

and shipping information. 

 Log In: Enables customers to identify themselves. 

 Log Out: Enables customers to log out of their accounts. 
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The Footer 

The bottom of each of your web store pages includes a footer (see Figure 48). 

 

Figure 48. Web Store Footer 

This footer generally provides links to various informational and functional pages in 

the site, such as Contact Us and the Site Map. 

Purchasing Functionality  

Wishlist 

The Wishlist feature enables customers to pick out products which they are 

interested in, but not ready to order yet. Products can be moved from the 

wishlist to the shopping cart with one click. Customers can also share the 

Wishlist their friends right from the Wishlist section of the My Account page. 

The Wishlist feature is available for registered customers only. 

My Cart 

To add a product to your shopping cart, click on the Add to Cart button for that 

product, as shown in Figure 49. 
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Figure 49. Add to Cart Button 

The My Cart area shown in Figure 49 displays a brief list of the products in your 

shopping cart. The Recently Added items(s) area shows a list of the last three items 

added to your shopping cart. 

Clearing My Cart 

A customer who wants to remove all items from the shopping cart can do so 

by clicking the Clear Shipping Cart button on the Shopping Cart page (see 

Figure 50). 
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Figure 50. Clearing the Shopping Cart 

Checking Out 

The My Cart area also provides a Checkout button (see Figure 51) that takes a 

customer to the first step of the one-page checkout process (see Figure 52). 

 

Figure 51. My Cart Area 

 

Figure 52. Checking Out 
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Most of the functionality of the checkout process is available by default. In addition, 

the backend provides a variety of options to customize the customer checkout  

process, such as various payment and shipping methods that can be offered to your 

customers. 

A customer can make a one-time purchase as a guest or can register and create an 

account. Customers that have created an account can later track the status of their 

orders.  

Tip: Magento CE also provides multi-shipping functionality that enables 

customers to ship items to more than one address at the same time. This is a 

very useful feature for sending gifts, for example. This feature can be 

configured under System > Configuration > SALES > Shipping Settings > 

Options. 

 

Tip: Customers can also register and create an account by using the My Account or 

Log In link on the top right of each page. 

Figure 53 shows an example of checking out as a guest by selecting the Checkout as 

Guest option in the step above 

Click Continue to see the next step in which the customer can enter the billing and 

identification information. 
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Figure 53. Checkout as Guest 

Click Continue to specify the Shipping Address, select the Shipping Method, and 

select the Payment Method. 

The last step of the checkout process enables the customer to review the entire order, as 

shown in Figure 54. 

 

Figure 54. Order Review 
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Note: The right column shows the summary of information entered during the 

previous checkout steps and enables you to change any of the information 

that is incorrect. 

Customers then confirm the order and receive an order number, or they can change 

their minds and edit their carts using the Edit Your Cart link. If they proceed with the 

order and the payment is processed successfully, then a “Thank You” page is 

displayed, as shown in Figure 55. 

 

Figure 55. “Thank You” Page 

A confirmation email can be sent to the customer. An example is shown in Figure 56. 

The confirmation email can be configured by under System > Configuration > Sales 

Emails. 
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Figure 56. Confirmation Email 

Managing Customer Relations 

Customer Emails 

Magento CE can send a variety of automatically generated customer emails (such as 

when a customer places an order or opens an account) and enables you to customize 

them as you require. For more information about customizing the emails sent from 

the store to customers see “Customizing Transactional Emails,” page 177. 
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Ratings and Reviews 

Rating and review functionality is provided by Magento CE to enable customers and 

web store owners to give their opinions, feedback, and comments about products.  

They appear in the frontend, as shown in Figure 57. 

Figure 57. Ratings and Reviews 

The number of stars indicates the satisfaction rating. You can click on the Review(s) 

link to display the actual textual reviews provided by customers. For more details, see 

“Managing Ratings and Reviews”, page 235. 

Community Polls 

Each web store can provide a Community Poll, as shown in Figure 58. For more details, 

see “Managing Polls,” page 240. 
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Figure 58. Community Poll 
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7 Introducing the Backend 

In order to familiarize you with the features of the backend, this chapter describes the 

ongoing management tasks that you can perform in the backend while running your 

Magento web store on a day-to-day basis.  

See “Accessing the Backend,” page 23, for details on logging in to your store’s backend. 

See “Setting Up Your Catalog,” page 69, for a full description of how to set up your catalog. 

Each of the subsequent chapters features a description of the other aspects of customizing 

your backend. 

Understanding Scope 

Magento CE enables you to organize your operations into multiple websites, 

stores, and store views. (See “Store Hierarchy,” page 25, for descriptions of 

these terms.) Many of the configuration pages in the backend enable you to 

select the website, store, or store view that you want your configuration 

changes to apply to. Selecting the website, store, or store view is known as 

selecting the 

scope of your changes. 

To select the scope for configuration changes, use the Current Configuration 

Scope drop-down list in the upper left corner of the configuration page, as 

shown in Figure 59. 
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Figure 59. Selecting Configuration Scope 

If you select Default Config, the option choices you make are applied as default 

values for all websites, stores, and store views. 

On the configuration pages, you will see scope indicators to the right of each 

option. These indicate the lowest level of the hierarchy at which you can set the 

value of these options. For example, the value of the Default Display Currency 

option may be set at the default (global) level, but can be overridden at the store 

view level, as indicated by the “[STORE VIEW]” indicator for that option (see Figure  

60). 

 

Figure 60. Scope Indicators 
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Managing Administrator Messages 

When you log in to the backend, any new messages are displayed in a pop-up box. 

Typically, these messages are notifications of new Magento CE or extension 

releases. 

You can manage these messages much like you would manage your email. 

To display all the messages in your inbox: 

Click the Go to messages inbox on the top right of the page. The Messages Inbox 

page is displayed, which provides standard message handling features (see Figure 

61). 

 

Figure 61. Messages Inbox Page 

You can mark selected messages as Read so that they do not appear again when 

you log in. You can also Remove marked messages so that they are permanently 

deleted. 
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Supervising Web Store Activities 

The Dashboard (Figure 62) is the first page to be displayed by default after you log  

in. It can also be accessed by clicking Dashboard on the Admin Panel top menu.  

 

Figure 62. Dashboard 

This page shows you basic information and statistics for managing your web store. 

The following describes the options in this page: 

Chart 

Orders tab: The Orders tab in the center of the page shows a graph that indicates 

the quantity of orders being processed in your web store for each point on the time 

scale within the specified range. The range is selected in the Select Range drop-

down list at the top of the chart. Underneath you can see the revenue, tax and 

shipping amounts of your orders and the total quantity of the orders. Only orders 

for which at least one invoice, shipment, or credit memo has been created or which 
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have been created from external gateways (for example, PayPal Express) are 

included in the reports. 

Amounts tab: The Amounts tab in the center of the page shows a graph indicating 

the revenue for each point on the time scale within the specified range. The range 

is selected in the Select Range drop-down list at the top of the chart. 

Revenue, Tax, Shipping, and Quantity: These statistics are calculated as follows: 

 Revenue = Total Invoiced Amount - Tax Invoiced Amount - Shipping Invoiced 

Amount - (Total Refunded Amount - Tax Refunded Amount - Shipping 

Refunded Amount) 

 Tax = Tax Invoiced Amount - Tax Refunded Amount 

 Shipping = Shipping Invoiced Amount - Shipping Refunded Amount 

Note: Charts can be enabled or disabled under System > Configuration > 

ADVANCED > Admin > Dashboard. 

Left Information Panel 

The panel on the left shows you the total amount of orders handled in your 

Magento CE web store, the average amount of each order, information about your 

last five orders, and the last five and top five search terms. 

Bottom Information Tabs 

The bottom of the Dashboard (Figure 63) provides additional information about 

your web store, as follows: 
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Figure 63. Additional Dashboard Information 

 Bestsellers Tab: Shows a list of the best-selling products in your web store, their price, and 

the quantity ordered.  

 Most Viewed Products Tab: Shows a list of the most recently viewed products and the 

number of times they were viewed. 

 New Customers: Shows a list of the most recently registered customers. 

 Customers: Shows a list of your top customers, meaning the customers that have ordered 

the most items from your web store in the last year. 

Managing Orders 

This section first describes how to view and manage orders, as well as how to create 

orders from the backend. 

Viewing the Orders in Your Web Store 

To view the orders in your web store: 

In the Admin Panel, select Sales > Orders to display the Orders page, as shown in 

Figure 64. 
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Figure 64. Orders Page 

This page displays a list of the orders placed in your web store.  

The following describes some of the options for managing orders in this page: 

 Quantity of Orders Displayed: The top part of the page enables you to control how many 

orders are displayed in the page, as shown in Figure 65. 

 

Figure 65. Order Display Controls 

 Selecting Orders: The area under the order display controls enables you to select/unselect 

all the orders in your web store or to select/unselect all the orders currently visible, 

meaning those that are currently displayed in this page. 

 

Figure 66. Order Selection Controls 

Note: You can also select individual orders by selecting the check box on the 

left of each order.  

 Filtering Orders: The area under the order selection controls enables you to filter the orders  

that are displayed by specifying values in one or more of the fields and then clicking Search. 

To display all orders, click Reset Filter. 
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Figure 67. Filtering Controls 

Note: The list displays only those orders that meet all the criteria that you specified. 

 Sorting orders: Click on the header of a column to sort the orders by the value of that 

column. Each click toggles between an ascending sort and a descending sort. 

 Order actions: The Actions drop-down list provides a list of actions that may be performed 

on the selected orders. The actions that can be performed include the following: 

 

o Cancel: Sets the order status to Canceled and disables any further processing. 

o Hold: Puts the order on hold. The order is not affected in any way, but no further action may  

be performed unless you release it from Hold status. o Unhold: Releases the order from 

Hold status.  

o Printing options: These options enable you to print various documents related to the order. 

 Viewing an order: To view and/or edit an existing order, click row for the 

desired order or click the View option in the order’s row in the Action 

column. The Order View page opens, showing details about the order. 

Viewing an Order’s Details 
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Magento CE provides a large variety of information for each order. This section 

provides a quick review of some of the information provided for an existing order. 

The navigation bar at the top of the Order View page enables you to access the 

various sections: 

Information, Invoices, Credit Memos, Shipments, Comments History, and 

Transactions. 

Information Page 

This page provides an overview of the most important information about the order, 

such as the current status of the order, the products ordered, customer 

information, billing, shipping, and payment information. 

 

Figure 68. Order Information Page 
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Note: The SKU (Stock Keeping Unit) specifies the product code that is used to 

keep track of the actual inventory. SKUs are defined during product 

creation. For details about managing your product catalog, see “Setting Up 

Your Catalog,” page 69. 

The Comments History area of this page provides information about the lifecycle of 

the order. Every time that an invoice, shipment, or credit memo document is 

created, a record with each document’s identification is added on this tab. Also, 

here you can find out whether the customer was notified about the creation of  

each order document. For each partial refund, the system provides the order  

amount to be returned to the customer. You can change order status in the Status  

drop-down list.  

To add a comment to the order:  

1. Specify the comment text in the Comment text box. 

2. If you want to send the comment to the customer by email, select the Notify Customer by  

Email check box. 

3. If you want to make the comment visible in the order view on the frontend, select the  

Visible on Frontend check-box to specify that the customer is sent a copy of the comments 

that you add in the Comment box. 

4. Click Submit Comment.  

All comments are stored on the Comments History page. To open it, click the 

Comments History tab on the left. 

Invoices Page 
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An invoice represents a confirmation of payment. The Invoices page enables you to 

view the list of invoices generated for an order.  

You can generate an invoice individually or together with a shipment. If the 

products in an order are shipped in multiple shipments, then an invoice is 

generated for each shipment for the products in that shipment.  

Credit Memos 

The Credit Memos page displays a list of the refunds given for products in this 

order. 

You can click on a credit memo in the list to display the refund details. 

Shipments Page 

A shipment is a record of the products in an order that have been shipped. As with 

invoices, multiple shipments can be created per order. 

The Shipment page displays a list of the shipments sent for products in this order. 

You can click on a shipment in the list to display the shipment details.  

On the Shipment page, you can also add tracking numbers that were received from 

shipping service providers. The tracking number enables customers to learn the 

status of the shipments in their orders using the My Account option that appears in 

the header of the frontend. For the supported shipping service providers you can 

create and print shipping labels form the Shipment page. 

Comment History Page 

The Comment History page enables you to view a list of comments that have been 

added to the order record over the course of its life cycle. It is a good practice to 

add comments at every stage of the order, especially if problems come up. 
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Transactions Page 

The Transactions page enables you to view a list of transactions that are associated 

with this order. 

Creating New Orders 

You may want to create an order using the backend, for example when an order is 

received over the phone. 

Tip: Typically, orders are placed by customers in the frontend. In addition, you 

can create orders in the backend. This enables you to take orders by phone, 

mail or fax and then enter them into your web store to be managed and 

tracked. This feature is useful for call center operators to take orders directly 

from your customers. The ordering process in the backend is not much 

different from the one your customers experience. The backend provides all 

the same functions that your customers have when creating an order from 

your web store, including the ability to move products between the 

shopping cart and wishlist. 

It also enables you to give customers special prices and discounts. 

To create a new order from the backend: 

1. Select Sales > Orders.  

2. Click the Create New Order button on the top right. 

A full description of this procedure is provided in “Managing Orders,” page 227.  

Managing Ratings and Reviews 

Rating and review functionality is provided by Magento CE to enable customers 

and web store owners to submit their opinions, feedback, and comments about 

 71 



Introducing the Backend 

products. Product reviews and ratings can also be added using the backend. To 

access the ratings and reviews management features, select Catalog > Reviews and 

Ratings. 

For more information about ratings and reviews, see “Managing Customer-

Generated Content,” page 235. 

Generating Reports 

Magento CE provides a variety of reports that you can access at any time. These 

reports are available under the Reports menu at the top of the Admin Panel. 

Some of the most important reports are described in “Reports,” page 243.  
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8 Setting Up Your Catalog 

This chapter describes how to create a catalog for your Magento CE web store, how to add 

products, and how to define their attributes.  

Overview 

The best workflow for creating your products is as follows: 

The following describes the process depicted above:  

 Step 1: “Setting Up Catalog Defaults,” page 70. This step describes how to set basic catalog 

default configurations that define its behavior.  

 Step 2: “Creating Categories,” page 79. The next step is to create the categories that will 

contain your products. Each product can be assigned to one or more categories. 

A Magento CE store with Sample Data provides three such categories: 

Furniture, Electronics, and Apparel. Categories can have multiple levels of 

subcategories. A customer can click on a category to see a drop-down list of 
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subcategories, such as Cell Phones, Cameras, and Computers, as shown in 

Figure 69. 

 

Figure 69. Categories and Subcategories 

Setting Up Your Catalog 

 Step 3: Creating Attributes, page 89. Next, you can create the attributes that represent a 

product’s characteristics. Attributes are a powerful Magento CE concept to make finding 

and comparing products easier. 

 Step 4: Creating Attribute Sets, page 92. Attribute sets are logical groups of attributes that  

simplify the process of assigning attributes to a product. They do not appear in the front-

end user interface. 

o Creating a New Attribute Group, page 94. Part of the process of 

creating an attribute set is to create attribute groups. These groups 

determine how attributes appear in the backend when defining a 

product. 

 Step 5: Creating a New Product, page 96. This step shows how to fill in product information 

in order to maximize conversion and how to assign Categories to help customers navigate 

to the products of interest to them. Attribute sets and attributes are assigned to products to 

describe them, provide multiple options and help the customer search through the product 

list.  


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The first step to creating your catalog is to configure the catalog system default 

settings. In many cases, these settings can be overridden at lower levels (such as in 

individual categories and products).  

To configure catalog defaults: 

In the Admin Panel, select System > Configuration > CATALOG > Catalog. In the 

Current Configuration Scope drop-down, select the scope of this configuration. The 

following describes some of the more important sections in the page. 

Frontend 

This section determines how your products are shown on the frontend catalog 

pages.  

 

Figure 70. Catalog Frontend Configuration 
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 List Mode o Grid Only: The products are displayed only in a grid structure. o List Only: The 

products are displayed only in a list. 

o Grid (Default)/List: The products are displayed in a grid structure by default, but your 

customers are able to switch to list. 

o List (Default)/Grid: The products are displayed in a list structure by default, but your 

customers are able to switch to grid.  

 Products per Page: For each display type (List and Grid), specify the following: 

o Specify, in a comma-separated list, what the options are for the number of products to 

display on a product page. These options will be listed in a drop-down list on the frontend. 

o Specify how many products are displayed on a page by default.  

 Allow All Products per Page: Select whether the customers are allowed to display all 

products on a single category page. 

 Product Listing Sort By: The products are sorted, by default, by the selected attribute. The 

Best Value products are featured products as determined by the store administrator; for 

more information, see “Creating Categories,” page 79. The customer can select from the 

other options on a per-page basis. 

You can configure attributes to be used for sorting using the Used for 

Sorting in Product Listing setting of an attribute. For details, see “Managing 

Product Attributes,” page 88. 
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 Use Flat Catalog Category: Selecting Yes “flattens” multiple category database tables into a 

single table for increased performance on the frontend. Magento recommends selecting 

Yes for any size catalog. 

 Use Flat Catalog Product: Selecting Yes “flattens” multiple product database tables into a 

single table for increased performance on the frontend. Magento recommends selecting 

Yes if your catalog contains more than 1,000 SKUs 

 Allow Dynamic Media URLs in Products and Categories: Selecting No can improve 

performance 

Sitemap 

This section determines how your site map is displayed to customers. 

• Use Tree Like Category Sitemap: Selecting Yes displays the site map as a 

tree, showing all categories and subcategories as branches. Selecting No 

displays the categories and subcategories in a single column. 

• Minimum Lines per Page: Determines the number of lines on each page 

when the site map is distributed among several pages. 

Product Reviews 

This section enables unregistered guests in your store to write product reviews.  

Product Alerts 

You can enable your customers to subscribe to two types of customer alerts by 

email: price change alerts and in-stock alerts. For each alert type, choose whether 

to enable users to subscribe to it, and select the email template to use. Also, select a 

sender display name, which applies to both alert types. For more information on 
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how to configure email templates and email sender addresses, see “Customizing 

Transactional Emails,” page 177. 

 

The price change alert creates a Sign up for price alert link in every product page. 

Clicking this link subscribes your customers to this alert for that particular product 

so that they receive an email each time the product price is changed. This includes 

adding or changing Special Prices in addition to the regular Price field.  

The in-stock alert creates a link called Sign up to get notified when this product is 

back in stock in every Out of Stock product. Clicking this link subscribes your 

customer to this alert so that they receive an email when the product status 

changes to In Stock.  

For each product, there is a tab listing all the customers subscribed to either of 

these alerts.  

Product Alerts Run Settings 

These settings enable you to select how often Magento CE checks for changes that 

require alerts to be sent. Additionally, you can select the recipient, sender, and 

template for emails that are sent if the sending of alerts fails. 

 Frequency: Choose how often product alerts are sent out: Daily, Weekly, or Monthly. 

 Start Time: Choose what time of day the product alert process starts. This time should be 

after any price or inventory updates are performed. 

 79 



Setting Up Your Catalog 

 Error Email Recipient: Identify the email address of the person (normally a store 

administrator) who should receive an email notification when there is an error in the 

product alert process. 

 Error Email Sender: Select the role that the email will be “from.” 

 Error Email Template: Select the email template to use for product alert error notifications.  

For more information, see “Customizing Transactional Emails,” page 177. 

Product Image Placeholders 

This section enables you to specify an image for each of the sizes that are used 

instead of the product image, if it is missing. 

Recently Viewed/Compared Products 

This feature is described in detail in “Recently Viewed,” page 45. The configuration 

section enables you to specify how many products are shown by default in each list. 

 

Figure 71. Recently Viewed/Compared Products Settings 

Price 

The Price section contains only the Catalog Price Scope drop-down list, in which 

you can select the scope of the base currency (Global or Website). 

Layered Navigation 
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The Layered Navigation section enables you to choose whether the price ranges 

that are displayed in the layered navigation tool are calculated automatically or 

manually. If you select Manual, the Default Price Navigation Step field becomes 

visible, enabling you to specify the default size of the price ranges. 

Category Top Navigation 

The Category Top Navigation section enables you to define how many levels of 

subcategories are displayed by clicking on a category in the top navigation bar on 

the frontend. Setting this value to 0 (zero) enables all levels to be displayed. If you 

have a large number of subcategory levels, this can potentially make it difficult for 

the user to navigate. 

Search Engine Optimizations 

In order to make your site more search engine friendly, configure the following:  

 

Figure 72. Search Engine Optimization Settings 
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 Auto generated Site Map: Enable this feature to display a Site Map link in the footer of the 

frontend pages. This enables a customer to view an automatically generated site map 

including a list of all of your existing categories. In addition to the auto-generated site map, 

Magento CE enables integration with Google Sitemap. More information is provided on the 

following pages. 

 Popular Search Terms: Enable this feature to display a Search Terms link in the footer of the  

frontend pages. This enables customers to link to a list of all search terms. This is an SEO 

feature because each of these search terms counts as a link to your site and is explored by 

search engines to discover content on your site. 

 Product URL Suffix and Category URL Suffix: These options determine which suffix is  

displayed on each product and category page. Typically this value will be .html or .htm. 

When you change this value (and click Save Config), you must perform a cache refresh by 

selecting System > Cache Management and clicking Flush Magento Cache. 

 Use Categories Path for Product URLs: This option determines how the URL is composed. 

Select Yes to specify that the URL links for products include the associated category and a 

separate link is generated for each associated category. Select No to specify that the URL  

rewrites include only the product name and that there is only one link for each product, 

regardless of how many categories the product is associated with. 

 Create Permanent Redirect for old URLs if URL key changed: Selecting Yes automatically 

creates a redirect for the old URL that points to the new URL if a page is moved. Doing so 

eliminates the “404 Not Found” error message that customers see if a page they had  

bookmarked is moved. 

 Page Title Separator: Specify a character to replace the space character ( ) with when the 

system uses the page title to construct the page’s URL. Typically you would use an 

underscore (_) or hyphen (-). 

 Use Canonical Link Meta Tag For Categories and Use Canonical Link Meta Tag For Products: 

Select whether to add a tag to each category or product page that points to a “preferred” 

URL for search engines to index when encountering pages that contain the same content  

(but which may be sorted differently, for instance). 
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Catalog Search 

The options in this section define how the catalog search feature behaves. 

 Minimal Query Length: Defines the minimum number of characters that the customer must  

specify in the Search field on the frontend. 

 Maximum Query Length: Defines the maximum number of characters that the customer 

may specify in the Search field.  

 Maximum Query Words Count: Define the maximum number of terms that can 

be specified in the Search field. This limit applies to the “Like" search type only.   

 Search Type: Define the type of search that is performed: 

o Like: Includes only results that are close in spelling to the specified search terms. 

o Fulltext: Includes only results that exactly match the specified search terms. 

o Combine (Like and Fulltext): Includes both exact matches and close matches.  

 Apply Layered Navigation if Search Results are Less Than: Defines the maximum number of 

results for which layered navigation can be applied. If the number of results is more than 

this number, then the results are presented as a simple list. If you specify 0, then layered 

navigation is always applied. Limiting the number of results can increase performance. 

Downloadable Products Options 

This section controls the settings for products of Downloadable type. The most 

important settings are: 
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Figure 73. Downloadable Products Options 

 Order Item Status to Enable Downloads: Controls whether customers can access their  

downloadable product links immediately after the order is placed or only after the invoice is 

created for the order.  

 Default Maximum Number of Downloads: Controls how many times a downloadable 

product may be downloaded by the customer after it has been purchased. 

 Shareable: Setting this option to Yes enables non-registered customers (guest customers) 

to access their downloads. This is the only option for customers to access their products if 

you want to offer guest checkout or quick checkout methods, such as PayPal Express or 

Google Checkout. This setting can be overridden at the product level. 

 Default Sample Title and Default Link Title: These settings control what is displayed 

throughout the store when referring to samples and downloadable products (links). 

 Open Links in New Window: Controls whether the download page opens in a new window. 

 Use Content-Disposition: Controls whether the content is opened in a browser window or 

downloaded. 

 Disable Guest Checkout if Cart Contains Downloadable Items: This setting disables the 

Guest Checkout option only if there are downloadable items in a cart, and leaves it enabled 

if a customer is purchasing other products. If you set this option to Yes, be sure to set the 

Shareable option to Yes as well. 
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Date and Time Custom Options 

The options in this section control how dates and times are displayed in your 

store. 

 Use JavaScript Calendar: Enables your store to present a JavaScript-powered calendar date 

picker in any field that requires the customer to select a date. When this option is set to No, 

then drop-down lists are provided to select the date and time. 

 Date Fields Order and Time Format: Select the order in which the day, month, and year 

values are presented in the format xx/yy/zz., and select a 12-hour (a.m./p.m.) or 24-hour 

time format. These fields are important for store views that are targeted for specific 

countries that use date and time formats that are different from your local custom. 

 Year Range: Indicate the range of years that is available for selection in either the JavaScript 

calendar or calendar drop-down lists. Use a four-digit year format. 

Managing Categories 

This section describes how to display, create, and edit categories and 

subcategories. 

The products in the web store are grouped into categories. Categories enable you 

to give your store structure and form. In Magento CE, each store you create is 

assigned to a unique category. Any other category that you want to use in your 

store must be created as a subcategory. All categories are technically considered 

subcategories because you are placing them under the root category. See Figure 

74. 
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Figure 74. Example Category Structure 

The way category names are displayed on the frontend depends on the layout. If 

the default theme is used for the web store, categories are shown in a bar near the 

top of the store web page. 

Each product can be assigned to one or more categories, as described in “Finding  

the Right Products,” page 38. 

Displaying Categories 

To display a list of all defined categories: 

Select Catalog > Manage Categories. The categories are listed in a tree view on the 

left, as shown in Figure 75.  
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Figure 75. Category List 

 If you have loaded Sample Data, these sample categories (Furniture, Electronics 

and Apparel) will appear in the category tree. Disabled categories are listed in gray 

text. 

Creating Categories 

This section describes the most important steps in creating a category. 

To create a new category: 

 To create a new root category, make sure that Choose Store View in the upperleft corner of 

the page is set to Default Config, and click Add Root Category. 

 To create a subcategory, select the parent category (it can be either a root category or a 

category) in the list and click Add Subcategory. 

Four tabs of information are provided to describe this category: General  

Information, Display Settings, Custom Design, and Category Products. Click each 

tab and specify the requested information, as described below. 

Note: Required  fields appear with a red asterisk (*). 
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General Information Tab 

Most of the fields in this page are self-explanatory. In this tab, you are asked to 

provide a category name, description, images (used to represent your category) as 

well as meta keywords and description for better search engine positioning. 

 

Figure 76. Create a New Category – General Information 

1. Specify a name for this category in the Name field. 

2. Set the Is Active field to Yes to specify that this category appears in the store. 

88 



 Setting Up Your Catalog 

3. In the URL key field you can specify a relative URL path which can be entered in place of the 

standard Target Path. It is “search engine friendly” because it can use the name of the 

category instead of the ID number. If you leave this field blank, Magento CE will 

automatically generate a URL with the name of the category upon creation of the category. 

If you enter a value here manually, you cannot use spaces in this field. The URL key field is 

not displayed for root categories. 

4. For Thumbnail Image, use the Browse button to select and upload a thumbnail image to 

represent the category. 

5. Specify a description in the Description text box. This description is presented on the 

frontend. 
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Note: You can use HTML tags in this text box. Alternatively, click the WYSIWYG 

Editor button to open a full-function HTML editor. The “What You See Is What 

You Get” (WYSIWYG) Editor includes a spelling checker, for which you need to 

download and install a plug-in for your browser. 

6. The Image field is used for a category image. Click the Browse button next to the field to select 

the file. This image will appear in the frontend for each category’s page between the category  

name and the content.  

7. In the Page Title field, specify the title of the page, which will be displayed on the browser tab 

header when the customer opens this category page. 

8. In the Meta Keywords and Meta Description text boxes, specify the keywords and description 

for search engines to use for this category when indexing your site. 

9. Select Yes for Include in Navigation Menu so that the category will appear in the navigation 

menu on the frontend. 

10.Click Save Category to save your changes. 

Display Settings Tab 

The Display Settings tab enables you to specify how this category is presented to the 

customer. 
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Figure 77. Create a New Category – Display Settings 

1. In the Display Mode field, select one of the following options to specify how you would like 

your category page to appear: 

 Static block only 

 Static block and product list below it 

 Product list only  

2. In the CMS Block field, select the static block that you would like to be shown for this 

category (if selected in the Display Mode field). This block must first be created in the CMS 

section; for more information, see “Managing CMS Pages,” page 174.  

 In the Is Anchor field, select Yes to specify that this category page is an anchor. Anchors are 

used for the layered navigation in Magento CE, as described in “Layered Navigation,” page 84. 

o If you set the category to be an anchor for Layered Navigation, then your web store displays 

the subcategories of this category in the SHOP BY panel on the left. This area also shows a 

linked list of the filterable attributes of the products in this category and its subcategories.  

o Figure 78 shows the SHOP BY panel for the Apparel category, which is set as an anchor.  
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Figure 78. Anchored Category 

3. For Available Product Listing Sort By, specify the attributes by which the customer can sort 

the list of products in this category. By default, all available attributes can be used for sorting; 

clear the Use All Available Attributes check box to modify the list. 

4. For Default Product Listing Sort By, select the attribute by which the product list is sorted by 

default. This is set in the catalog configuration (see “Setting Up Catalog Defaults,” page 70), 

but you can clear the Use Config Settings check box to select a default sorting attribute for 

this particular category. 

5. For Layered Navigation Price Step, specify the size of the price range to be used when 

calculating the price “buckets” for the Layered Navigation. This is set in the catalog 

configuration, but you can clear the Use Config Settings check box to specify a price range 

size for this particular category. 

Custom Design Tab 

The Custom Design tab contains additional settings to control the theme and layout 

updates that are used for this category page.  Depending on the settings they can 

also affect child pages as well. All of these settings are optional. For more information 

about custom designs and page layouts, see “Design and Content,” page 169. 

1. For Use Parent Category Settings, choose Yes to “inherit” the settings of this subcategory from 

its parent category. Doing so ensures a consistent look within a category family, and disables 

all other settings on this page. This setting is not available for root categories. 

92 



 Setting Up Your Catalog 

2. For Apply to Products, select Yes to apply the category page settings to the product pages of 

the products in this category. 

3. Select a custom design from the Custom Design drop-down list. Magento CE comes with 

several custom designs already defined, and you can modify these custom designs or create 

your own. For more information, see “Managing CMS Pages,” page 174. 

4. For the Active From and Active To fields, select the start and end dates for this custom design 

to be applied to this category. If you do not select a start date, the custom design is applied 

immediately. If you do not select an end date, the custom design is applied to this category 

until you manually deactivate it. 

5. For Page Layout, select a layout from the drop-down list. 

 No layout updates: Uses the default settings that come with the Magento CE installation 

 Empty: Displays the category page without any objects, except for the content (products or 

static blocks only), category name, and view options (number to display per page, view as grid 

or list, and sort be options) 

 1 column: Displays the contents, category name and view options, as well as the header, 

footer, search field, and navigation bar 

 Column on the left: Adds the left column to the 1 column display, which by default includes 

the currency selection and layered navigation 

 Column on the right: Adds the right column to the 1 column display, which by default includes 

the shopping cart view, wishlist, compared products list, polls, and newsletter sign-up 

 3 columns: Displays both the left and the right columns 

6. The Custom Layout Update is essentially a static block, with a few differences. Rather than 

HTML, the structure must be in XML format. The Update will appear at the bottom of the 

page, below the products, whereas a static block will appear above the products (if the static 

block is set to display with products). The custom layout update will appear on the page only 

during the dates specified in the Active From and Active To date range. 
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7. Click Save Category to save your changes. 

Catalog Products Tab 

This tab enables you to specify the products that belong to this category. 

Note: You can also assign a product to a category when editing a product’s 

record. For more information, see “Managing Products,” page 95. 

 

Figure 79. Creating a New Category – Products  

1. If needed, use the filter fields at the top of the table to filter the list of products. Click Reset  

Filter to clear all filter settings. 

2. Select the check box in the left column for each product that belongs in this category.  

Remember that a product can be assigned to more than one category. 

3. In the Position column, specify a whole number that indicates the order in which the product 

is listed when the products are sorted by Best Value. The product with a Position value of 1 is 

listed first, 2 is listed second, and so on. If more than one product has the same value for 

Position, the product with the lowest (that is, closest to 1) ID number is listed first. 

4. Click Save Category to save your changes. You may need to refresh the page to display the 

category in the tree. 

Editing Categories 
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To edit a Category: 

Click on a category in the tree, edit its information and click Save Category. 

Layered Navigation 

What is Layered Navigation? 

Of course, you want the customers browsing through your site to find the products 

that interest them in the fastest possible way. Otherwise, your sales opportunities are 

lost. When a customer is confronted with a category containing 60 products spread 

across multiple pages, most customers simply leave the site when they cannot find 

what they need on the first page. Magento CE enables you to provide customers with 

the option to find the products that they want by making a selection from a variety of  

filters, such as price, manufacturer, or any other aspect of the products, as shown in 

Figure 80. Layered navigation information is shown on category listing pages while 

searching for products. Show your customers what they want and you will raise 

conversions!  

The example in Figure 80 shows an enabled layered navigation filter by PRICE range 

and COLOR. 

 95 



Setting Up Your Catalog 

 

Figure 80. Layered Navigation 

Default Layered Navigation 

In Magento CE, two properties appear as navigation filters by default: PRICE and 

CATEGORY.  

• PRICE: Price ranges are selected logically in order to provide another filter for navigation. The  

ranges themselves are determined by the prices of products contained within them. There are 

never more than ten price ranges displayed at a time and products are distributed 

accordingly.  

• CATEGORY: If you define a category as an Anchor Category (see “Display Settings 

Tab,” page 81), its subcategories are displayed as layered navigation options. 

Figure 

80 shows that the first filter is CATEGORY and it features two options: Shirts and 

Shoes. In this example, Shirts and Shoes are subcategories of the category that is 

represented by this layered navigation block.  
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Defining Layered Navigation Filters 

The additional filters in Figure 80 are Manufacturer and Shoe Type. These are product 

attributes that have been selected as filterable. This is defined in the Use in Layered  

Navigation field under Catalog > Attributes, as described on page 89. 

There are two types of filterable attributes: 

• Filterable (with results): Links appear only for values where the number of results (the number 

in parentheses next to each value) is greater than zero.  

• Filterable (no results): Links appear for all values, regardless of the number of results.  

In order for an attribute to appear as a layered navigation filter, the Catalog Input 

Type for Storeowner must be Dropdown, Multiple Select or Price. This controls the 

number of possible filter options and makes them consistent. 

Price Layered Navigation 

The Price Layered Navigation algorithm enables you to create price ranges so that 

products are evenly distributed among ranges. You can also split each range 

iteratively. 

The enhanced configuration controls for the Price Layered Navigation feature were 

introduced in Magento CE version 1.7 and Magento EE version 1.12. 

Configuring the Price Layered Navigation Algorithm 

The algorithm for calculating the price layered navigation is configured in the 

Magento Admin Panel under System > CATALOG > Catalog > Layered Navigation.  

To set and configure the new price layered navigation algorithm: 

1. Log in to the Magento Admin Panel. 
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2. Navigate to System >Configuration > CATALOG > Catalog. 

3. In the Current Configuration Scope in the upper-left corner of the page select the desired 

store view. 

4. Expand the Layered Navigation field set. In the Display Product Count field, decide whether 

the number of products which fall into a price range will be displayed. 

5. In the Price Navigation Step Calculation field select Automatic (equalize product counts). 

Additional options appear. 

Note: The Automatic (equalize price ranges) option of the Price Navigation Step 

Calculation field is similar to the Automatic option which was available in 

the previous versions of Magento. If you select the Automatic (equalize 

price ranges) option, the previously existing price layered navigation 

algorithm will be used. 

6. In the Display Price Interval as One Price field, decide what will be the system behavior if all 

products which fall into a certain price range have the same price. Select Yes if you want to 

display a single price (not the range finite values). 

7. In the Interval Division Limit field, specify the threshold for a number of products within a 

price range after which the range cannot be further split. The default value is 9. 

8. To save the changes click Save Config. 

Price Layered Navigation Algorithm: Store Customer 

Experience 

The price layered navigation algorithm provides the optimal distribution of products 

among price ranges. In addition, the feature provides iterative splitting of price 

ranges.  
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Previously, if a customer selected to view products from a certain price range, there 

was no further subdivision to smaller price ranges on the resulting catalog page. For 

example, if a store customer clicked the $0.00-$99 range, the price filter on the page 

with a list of products contained the selected range only. See Figure 81. 

 

Figure 81. Store customer experience with price layered 

navigation in Magento Enterprise 1.11 and earlier 

With the iterative splitting feature, after a customer chooses to view the $0.00-$99 

range, the price filter on the page with a list of products can contain several sub-

ranges. 

See Figure 82. 
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Figure 82. Store customer experience with price layered 

navigation in Magento Enterprise 1.12 

Note: A price range is not further splitted after the number of products which fall  

into this range reaches the threshold set in the Interval Division Limit field 

under System > Configuration > CATALOG > Catalog > Layered Navigation.  

Managing Product Attributes 

What is an Attribute in Magento? 

An attribute represents a property of a product, such as: its name, image, SKU, color, 

manufacturer, and so on. Attributes enable you to add new product properties 

without having to write a single line of code or to add any columns to your database. 

Understanding attributes is crucial for making your store easy to use for customers. 

You assign attributes to your products in order to enable your customers and search 

engines to find them more easily. Your Magento CE web store automatically displays 

products according to their attributes, for easy accessibility by your customers, in the 

SHOP BY layered navigation panel on the left of your web store, as shown in Figure 

83. 
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Figure 83. Category Page with Layered Navigation 

Attributes also determine which products are displayed when a customer performs a 

search for a keyword. 

System attributes define the properties that are required by the store to function 

properly. 

These attributes cannot be deleted. 

You can add as many additional attributes as desired. In the Magento CE backend you 

can define attributes in sets. Attribute sets ease the definition process so that similar 

products can be created with the same attributes. Attribute sets enable you to assign 

multiple attributes to a product at one time by assigning an entire attribute set to a 

product.  

If a store sells televisions, shoes, books, and power tools, then four attribute sets 

could be defined: one specific to televisions, one for shoes, and so on. When a new 

 101 



Setting Up Your Catalog 

power tool product is added to your catalog, you can simply select the “Power Tool” 

attribute set to add the relevant attributes to this product.  

You should first define attributes, then define attribute sets and assign the relevant 

attributes to the attribute sets, as described in this section.  

Creating Attributes 

Attributes must be defined before defining attribute sets and products. 

Note: Only attribute sets can be assigned to a product, not individual attributes. 

To define attributes: 

1. Select Catalog > Attributes > Manage Attributes. A list of existing attributes is displayed, as 

shown in Figure 84.  

 

Figure 84. Manage Attributes Page 

2. Click Add New Attribute to display the New Product Attribute page (Figure 85) in which you 

can define a new attribute. 
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Figure 85. New Product Attribute Page 

3. In the Attribute Code field, specify a unique identifier for this attribute. Do not use spaces. The 

code does not appear on the frontend. 

4. In the Scope field select the scope to which this attribute applies. 

5. The Catalog Input Type for Store Owner setting controls how a store administrator specifies 

values for attributes. For descriptive textual attributes, you can use the Text Field or Text Area 

types; for list prices you use the Price type. Note that not all types can be used for layered 

navigation. 
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6. If this attribute has a default value, specify it in the Default Value field. 

7. If the value of the attribute must be unique for each product (for example, a SKU number), 

select Yes for Unique Value. 

8. If the value of the attribute cannot be blank for any product, select Yes for Values Required. 
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9. In the Input Validation for Store Owner field, select the type of validation that should be 

enforced on values of this attribute. For example, if the values of this attribute will be email 

addresses, select Email to cause the system to check each entered value of this attribute 

against the rules for valid email addresses. 

10. If this attribute will apply only to certain Magento CE product types, select Selected Product 

Types for Apply To. In the list that appears, select one or more product types for this 

attribute (use Ctrl+click to select multiple items). 

11.For Use in Quick Search and Use in Advanced Search, select Yes to enable the quick search 

and advanced search tools to search this attribute’s values. 

12.For Comparable on Front-end, select Yes to have this attribute appear in the compare 

window when products are compared. 

13.The Use in Layered Navigation field defines whether the attribute is used in layered 

navigation. The following options are available: 

 Filterable (with results): Only those attribute values that correspond to the existing products 

in your frontend catalog will be used in the layered navigation. 

 Filterable (no results): All values of the attribute that you have created on the Manage 

Label / Options tab will be listed. 

 No: Not used in layered navigation. 

Note that only attributes with the Dropdown, Multiple Select, or Price input type 

can be used in layered navigation. 

14.The Use for Promo Rule Conditions, field defines whether the attribute can be used in 

defining conditions for catalog and shopping cart price rules. 

15.The Position parameter determines the position of the attribute in the layered navigation 

block with respect to other filterable attributes. 
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16. In the Visible on Product View Pages on Frontend field, select Yes to specify that this 

attribute appears in the Additional Information part of a product’s page in the web store, as 

shown in Figure 86. 

 

Figure 86. Attributes on the Additional Information Panel 

17.For Allow HTML Tags on Frontend, select Yes to enable HTML tags that are specified in this 

attribute’s values to be honored on the frontend. 

18.For Used in Product Listing, select Yes to list values of this attribute in the product listing. 

19.For Used for Sorting in Product Listing, select Yes to enable the product list to be sorted by 

values of this attribute. 

20.Click Manage Label/Options at the top left of the page to display the Manage Label/Options 

page, as shown in Figure 87. 

 

Figure 87. Manage Label/Options Page 

21. In the Mange Titles box, specify a display name for this attribute for each store view. If you 

specify a value only in the Admin field, that value will be used in all cases. 
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22.For attributes with an input type of Dropdown or Multiple Select, you can enter values that 

can be specified for the attribute. To add a value, click the Add Options button. You can 

specify a different label for the value for each store view and set the default value by 

selecting the Is Default option button. For the Dropdown input type, you can select the Is 

Default option button only for one attribute value. For the Multiple Select input type, you 

can select multiple values by selecting the Is Default check box next to the desired attribute 

values. 

 

Figure 88. Attribute Value Specifications 

23.Click Save Attribute. 

Creating Attribute Sets  

 An attribute set is a collection of attributes, customized to fit certain types of 

products. All attribute sets must contain all of Magento’s system attributes, but you 

can customize them to include different combinations of simple attributes. Only 

attribute sets (not individual attributes) can be assigned to a product. If you want to 

add a small number of attributes, you can add them to the Default set, but if you 

want to add attributes that will be applied only to a subset of products, it is 

advisable to create an attribute set for each set of attributes that you want to assign 

to products. An attribute set can inherit attributes from another attribute set. This 

feature saves you from redefining sets of attributes that apply to many different 

products.  
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To create a new attribute set: 

1. In the Admin Panel, select Catalog > Attributes > Manage Attribute Sets. A list of existing  

attribute sets is displayed, as shown in Figure 89. 

 

Figure 89. Manage Attribute Sets Page 

Note: Figure 89 shows the attribute sets that are provided in Magento’s Sample 

Data. 

 

Note: The Default attribute set is composed mostly of system attributes. This 

attribute set is typically inherited by all other attribute sets. 

2. Click the Add New Set button to display the Add New Attribute Set page (Figure 90). 

 

Figure 90. Add New Attribute Set Page 

3. In the Name field, specify the name of this attribute set. This name is used only in the 

backend. 
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4. In the Based On field, select another attribute set from which this attribute set is to inherit. 

This enables you to reuse the attributes that are already defined in a set to build other 

attribute sets. The simple option is to leave the Default option that appears in this field. 

Click Save Attribute Set to display the Edit Attribute Set page (Figure 91). 

 

Figure 91. Edit Attribute Set 

Note: System attributes are indicated by an icon with an orange dot.  

The top left of the page shows the name of the attribute set that you are defining. 

The center of the page shows a hierarchical tree representing groups of attributes. 

An attribute group is a logical grouping of attributes within an attribute set. See 

“Creating a New Attribute Group,” page 94, for a description of how to define 

attribute groups. 

The right side of the page shows a list of attributes defined in other attribute 

sets and not assigned to this attribute set. 

5. Assign attributes to this attribute set by dragging them from the Unassigned Attributes area 

on the right into a group in the tree in the Groups area. 

Creating a New Attribute Group 

The center of the Edit Attribute Set page shows a hierarchical tree representing 

groups of attributes.  
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Attribute groups can be thought of as folders that contain attributes. Each group 

corresponds to a different tab on the product page in the backend. Magento CE 

comes with six attribute groups by default: General, Prices, Meta Information, 

Images, Recurring Profiles, Design, and Gift Options. They contain the various 

system attributes. System attributes cannot be removed from an attribute set; 

however, they can be moved to other attribute groups. Therefore, you can remove 

an attribute group as long as there are no system attributes within it. The order of 

both the attribute groups and the attributes can be changed by selecting and 

dragging them. This affects the order of tabs and attributes on the product page in  

the backend, respectively. You can also create a new attribute group, to which you 

can move system attributes, or associate simple attributes. 

 

Figure 92. Attribute Groups 
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To create a new attribute group: 

1. Click Add New in the Groups area to display a popup window asking for the group name. 

2. Specify the name of the new group and click OK. 

3. Click and drag attributes from the Unassigned Attributes area into the newly created group 

to assign them to this group. 

4. You can also click and drag attributes that are already assigned to move them between 

groups. 

Managing Products 

This section describes how to define and edit products.  

Tip: You should first define attributes and an attribute set, as described in 

“Managing Product Attributes,” page 88, before you define products that 

have those attributes. 

Product Types 

Magento CE offers a variety of product types that enable significant flexibility when 

defining products. The following lists the available product types and their typical 

usage: 

 Simple Product: This is the most basic product type. It is suitable for all kinds of physical 

(shipped) products.  

 Grouped: This option enables you to display several similar products on a single page. For 

example, if you are selling chefs’ knives and you have the same knife in four sizes, you can 

make a grouped product to display all four of these sizes. Customers can select the size(s) 

that they want and the quantity they need, and add them to the cart from this page.  
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 Configurable: This product type enables your customers to select the variant that they want 

by choosing options. For example, you can sell T-shirts in two colors and three sizes. You 

would have to create six variants as individual products (each with its own SKU) and then 

add these six to a configurable product where customers can choose the size and color, and 

then add it to their cart. A very similar functionality is possible by using Custom Options for 

Simple products. The difference between a configurable product and a product including 

custom options is that inventory is not checked or updated for individual options during the 

purchase of the latter and there is no possibility to go directly to a product with a given set 

of options. This also makes it hard for a search engine to find the product option. 

 Virtual Product: This is a product that does not require shipping or inventory. It is generally 

used for warranties or services. 

 Downloadable Product: This is a digitally downloadable product that sells one or more files 

of a product and provides samples of those files. These downloadable files can reside on 

your server or be provided as URLs to any other server. 

 Bundle: This product is composed of components that are presented in different ways and 

are made from existing products. A good example of a bundle is a complete computer. For 

this computer, you can configure how much RAM or what kind of monitor is included with 

this computer in your store. 

Creating a New Product 

The following steps are the same for all product types. Subsequent sections describe 

the differences between each of the product types. 

To create a new product: 

1. In the Admin Panel, select Catalog > Manage Products to display the Manage Products page, 

as shown in Figure 93. 
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Figure 93. Manage Products Page 

Note: Figure 93 shows the products defined in the Sample Data provided with 

Magento. If you downloaded Sample Data, as described in the Step 2: 

Downloading Sample Data section on page 11, then you may want to leave 

the products in for you to refer to as examples and delete them later. 

2. Click Add Product on the top right of the page to display the New Product page (Figure 94). 

 

Figure 94. New Product Page 

Product Wizard, First Page 

The New Product page is the first page of a product definition wizard that walks you 

through the process of defining a product.  

1. In the Attribute Set field, select the attribute set that contains the attributes that best 

describe this product. See “Managing Product Attributes,” page 88, for a description of how 

to define attributes. 
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2. In the Product Type field, choose the type of product you want to create.  

3. Click Continue to display the General tab, as shown in Figure 95. (This tab may look different 

depending on the product type that you choose.).  

 

Figure 95. General Tab 

General Tab 

Fill in all the mandatory fields, which are indicated by a red asterisk (*).  

 Name: The product name as it appears in the frontend.  

 SKU: The product’s store keeping unit (SKU). Magento CE uses SKU as a unique identifier for 

this product. SKU is global, meaning if you update the SKU for a product in one web store, it 

updates in all other web stores as well.  

 Weight: The product's weight. This value is usually used for shipping calculations. Specify 

only the number. Shipping service providers will interpret it according to the measurement 

units they use. 

 Status: Select Enabled to make this product available on the frontend. 

 Tax Class: The tax class of the product. See “Product Tax Class,” page 132, for more 

information. 
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 Visibility: Determines whether the product is displayed in the catalog pages and/or search 

results. The following options are available: 

o Not Visible Individually - The product will not be displayed individually in the frontend; 

however, it can be a component of a composite, configurable, bundle, or grouped product. 

o Catalog - The product will displayed on pages of categories it is associated to, but it will not 

appear in search results. 

o Search - The product will be displayed when your customers search for it either using the 

quick or Advanced Search tools, but will not be displayed on the related category page. 

o Catalog, Search - The product will be available on category view pages to which it is 

associated and on the search result page. 

The following describes the other fields in this page: 

 URL key: The search engine-friendly URL identifier is the name 

used for this product in the product’s URL. You cannot use spaces 

in this field. If the URL key is left blank, one is automatically 

generated by Magento CE.  

 Manufacturer: Select the name of the manufacturer from the 

drop-down list. 

 Color: Select the color of the product, if applicable. 

 Set Product as New from/to Date: The date range in which this 

product can be promoted as a new product in various locations 

throughout your site. 

 Country of Manufacture: Select the country in which the product 

was manufactured. 

 In feed: Determines whether this product is included in your 

store’s product RSS feed. 
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Note: Additional fields may appear on this (and other pages) if you add 

attributes to the Default attribute set or base the product on another 

attribute set. 

 

Note: The Create New Attribute button opens a popup window that enables you 

to enter an attribute to be added to the selected attribute set. However, we 

recommend defining the attributes structure first. 

Prices Tab 

Click the Prices tab in the Product Information panel on the left to display the Prices 

tab, as shown in Figure 96. 

 

Figure 96. Prices Tab 

Fill in all the mandatory fields, which are indicated by a red asterisk (*). 

This tab enables you to enter the Price, Cost and Special Price information for this 

product. You can also add Tier Pricing, as described in “Tier Pricing,” page 208. 

 The Special Price field is used for discounting or promotions, as described in “Special Prices,” 

page 206. 
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 The Cost field is only used in the backend. It can be used for generating margin and profit 

reports. 

 The Apply Map, Display Actual Price, and Manufacturer’s Suggested Retail Price fields are 

used for implementing the Minimum Advertised Price feature for this product. For more 

information, see “Minimum Advertised Price,” page 209. 

Meta Information Tab 

Click Meta Info on the left to display the Meta Information tab, as shown in Figure 

97. 

 

Figure 97. Meta Information Tab 

4. Specify information that enables search engines to more easily find and index 

this product.  

Images Tab 

Customers generally like to see what they are buying before they make a purchase. 

The Images tab enables you to upload pictures of your product. 

1. Click the Images tab on the left to display the Images tab, as shown in Figure 98.  
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Figure 98. Images Tab 
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2. Specify the image to be displayed in the web store to represent this product. Use the Browse 

button to select the image file from your local file system. 

Tip: You can select more than one file in this window to upload multiple 

images at once. 

3. After you have specified the image files of this product, click the Upload Files button. The 

Images tab shows uploaded the image files, as shown in Figure 99. 

 

Figure 99. Images Tab with Images Uploaded 

4. Select the appropriate options for each of the images, as follows: 

 Label: Alternate text for the image tag 

 Sort Order: The order in which the images are displayed in the Slideshow and MORE VIEWS  

gallery  

 Thumbnail: Used in shopping cart and related items 

 Small Image: Used in the Category listing, wishlist and so on 

 Base Image: Large product image (zoomed in) 

 Exclude: Excludes the image from the Slideshow and MORE VIEWS gallery 
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 Remove: Deletes the image from the collection; if the Remove check box is selected, the 

image will be removed after you save the product 

Description Tab 

Click Description on the left to open the Description tab, which enables you to 

create descriptions for the product (see Figure 100). 

 

Figure 100. Description Tab 

Both of the fields on this tab are mandatory. For both fields, you can use the 

WYSIWIG editor to format your descriptions. 

 Description: The information that you enter in the Description field is shown in the product’s 

page under the title Product Description.  

 Short Description: The information that you enter in the Short Description field appears on 

the product’s page under the title Quick Overview. This information is also shown when 

products are displayed in a list. 

Design Tab 
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The Design tab contains additional settings to control the appearance of this 

product’s product page, as shown in Figure 101. 

 

Figure 101. Design Tab 

All of these settings are optional. For more information about custom designs and 

page layouts, see “Design and Content,” page 169. 

1. Select a custom design from the Custom Design drop-down list. Magento CE comes with 

several custom designs already defined, and you can modify these custom designs or create 

your own. 

2. For the Active From and Active To fields, select the start and end dates for this custom 

design to be applied to this product. If you do not select a start date, the custom design is 

applied immediately. If you do not select an end date, the custom design is applied to this 

product until you manually deactivate it. 

3. The Custom Layout Update is essentially a static block, with a few differences. Rather than 

HTML, the structure must be in XML format. The Update will appear at the bottom of the 

page, below the products, whereas a static block will appear above the products (if the static 

block is set to display with products). The Custom Layout Update will appear on the page 

only during the dates specified in the Active date range. 
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4. For Page Layout, select a layout from the drop-down list. 

 No layout updates: Uses the default settings that come with the Magento CE installation 

 Empty: Displays the category page without any objects, except for the content (products or 

static blocks only), category name, and view options (number to display per page, view as 

grid or list, and sort be options) 

 1 column: Displays the contents, category name and view options, as well as the header, 

footer, search field, and navigation bar 

 Column on the left: Adds the left column to the 1 column display, which by default includes 

the currency selection and layered navigation 

 Column on the right: Adds the right column to the 1 column display, which by default 

includes the shopping cart view, wishlist, compared products list, polls, and newsletter sign-

up 

 3 columns: Displays both the left and the right columns 

5. For Display Product Options In, select a location for the product options to appear in the 

layout. 

Recurring Profile Tab 

By default, the Recurring Profile tab only appears for simple and virtual 

products. However you can configure it to become available for other 

product types, by changing the Apply To option of the Enable Recurring 

Profile attribute. A recurring profile enables you to set and configure 

recurring payments on a product. These are most often used for 

subscriptions or products with installment payment plans. When a product 

like this is purchased from your store, the customer is redirected to a third-

party payment system where a “recurring payment agreement” with the 

store is authorized by the customer. 
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Currently, creating recurring profiles is available only for the PayPal Express 

Checkout payment method. 

To enable a recurring profile for this product, select Yes for Enable Recurring 

Profile. Additional options become visible, as shown in Figure 102. 
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Figure 102. Recurring Profile Tab 

Most of the options on this tab are self-explanatory. For additional details on how 

recurring profiles work, see the 

http://www.magentocommerce.com/knowledge  base/entry/working  -  with  -  

recurring  -  profiles/     article in the Magento Knowledge Base. 

Note: Creating a recurring profile for a product does not create subsequent 

orders in the Magento Admin Panel. 

Gift Options Tab 
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The Gift Options tab contains one option. The Allow Gift Message option determines  

whether customers are able to add a gift message to this particular product during 

checkout.  

The default value of this setting is controlled by a Sales configuration setting 

(System > Configuration > Sales >Gift Options). To change this option, clear the 

Use Config Settings check box. 

Inventory Tab 

The Inventory tab enables you to control various aspects of inventory management 

for this product. 

Many of the settings on this tab are controlled by the Inventory configuration 

settings (System > Configuration > Inventory). To override these configuration 

settings for this product, clear the appropriate Use Config Settings check box. 

1. Select the Inventory option in the left panel to display the Inventory tab, as shown in Figure 

103. 

 

Figure 103. Inventory Tab 
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2. In the Manage Stock field, select Yes to specify that all inventory options are available for 

this single product, or select No to specify that you do not want to manage product 

inventory (in this case, the product is permanently available in the store to your customers).  

3. In the Qty field, specify how many items of this product you have in stock. 

4. In the Qty for Item’s Status to become Out of Stock field specifies that if stock quantity falls 

below this level, then the product becomes Out of Stock. 

5. The Minimum / Maximum Qty Allowed in Shopping Cart fields enable you to limit 

availability to products that have great prices to retailers, so that they are not sold to 

wholesale customers. 

6. In the Qty Uses Decimals field, select Yes to specify that customers can enter decimal 

quantities for this product, as opposed to integers. This is suitable for a product sold by the 

weight, volume or length. For example: 2.35 pounds of concrete or 3.75 feet of carpeting. 

7. The Backorders field enables your customers to place an order for a product that has an in-

stock quantity of less than 0. This option also enables you to notify your customers that even 

though there are no items of a product currently available, they can still place an order. You  

can do this by selecting the Allow Qty Below 0 option and the Notify Customer option. You 

can also enable this option without notifying customers by only selecting the Allow Qty 

below 0 option. 

8. The Enable Qty Increments field enables you to choose whether this product is sold in 

quantities other than 1 (for example wine that is sold in multiples of 6 bottles). If you select 

Yes for this option, the Qty Increments field becomes visible, enabling you to specify the 

quantity increment for this product. 

9. In the Stock Availability field, select the In Stock option if this product is in stock, or select 

Out of Stock otherwise. 

Websites Tab 
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The Websites tab enables you to choose which websites, stores, and store views this  

product is available on. Use the check boxes to make your selections. To set up 

websites, stores, and store views, see “Setting Up Your Store Hierarchy,” page 127. 

1. Select the Websites option in the left panel to display the Websites tab, as shown in Figure 

104. 

 

Figure 104. Websites Tab 

2. If your store has more than one website, store or store view, you must assign the product to 

the appropriate website in order to make it available in this website.  

Note: Sample Data contains three store views. If you want to create a product in 

the Sample Data environment, you must select the Main Website option 

when creating a product. 

Categories Tab 

The Categories tab enables you to assign this product to one or more categories. 

1. Select the Categories option in the left panel to display the Categories tab, as shown in 

Figure 105. 

 

Figure 105. Categories Tab 
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2. Specify the categories to which this product belongs by selecting the appropriate check 

boxes. 

Note: You can assign a product to more than one category. 

 

Note: You can also assign products to a category while editing the category. 

Related Products, Cross-Sell, and Up-Sell Tabs  

Each of these pages is similar and enables you to configure relationships between 

products. The interface in Figure 106 appears in each of these pages: 

 

Figure 106. Product Relationship Interface 

 To display all the products in the list, click the Reset Filter button. 

 Select the relevant checkboxes to assign products. You can use any of the filters 

available to make it easier to search for the products that you want. 

For more information about these pages, see “Promotions,” page 189. 

Product Alerts Tab 

This page is only available when alerts are enabled (System > Configuration > 

Catalog.  
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Figure 107. Product Alerts Tab 

This page displays a list of the customers that have subscribed to each type of alert 

for this product, and the dates on which they were notified about changes. 

Product Reviews Tab 

This tab provides a list of reviews posted by customers about a product that is being 

edited (the tab is not available for new product records for which there are no 

reviews). You can use the Edit button that appears in each review row to approve, 

edit or remove the review.  

Note: The Pending Reviews RSS link enables you to receive notifications of all 

pending reviews and enables you to first approve them before they are  

shown on the site. 

 

 129 



Setting Up Your Catalog 

Figure 108. Product Reviews Tab 

Product Tags Tab 

This tab displays the tags that customers have assigned to a product, and how many 

times each tag was used. This tab is not available in new product records for which 

no tags have been assigned. 

 

Figure 109. Product Tags Tab 

Note: You can click on a tag row to edit it or Approve, Reject, Disable or Delete it. 

Customers Tagged Product Tab 

This page enables you to see which customers have tagged specific products.  

 

Figure 110. Customers Tagged Product Tab 
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Note: You can click on a tag row to edit it or Approve, Reject, Disable or Delete it. 

Custom Group Configuration Pages 

Additional configuration pages may appear depending upon the groups that you 

have created using the Attribute Sets tool. See “Creating Attribute Sets,” page 92, 

for more information about attribute sets. An example custom group T-Shirts 

attribute is shown in Figure 111. 

 

Figure 111. Custom Attribute 

Fill in the attributes that appear in this page according to the definitions that are 

specified in the attribute set. Some of these attributes may be mandatory and each 

may be one of a variety of types according to the definitions of the attribute set. 

Custom Options Tab 

This page enables you to easily create product variants or products that can accept 

customer input, such as custom imprints or gifts. See “Creating Variations of a 

Product,” page 121, for more information on this topic. 
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Product Type Dependent Configuration Pages 

Depending upon the product type, additional configuration tabs may be available. 

The following provides a quick review of these types of pages. 

Downloadable Products: Downloadable Information Tab 

The Downloadable Information tab enables you to specify options for a 

downloadable product. 

 

Figure 112. Downloadable Information Tab 

This page contains two sections: 

 The Samples section enables you to display a sample of the downloadable product on 

the product’s information page. For example, this can be a short sample of a music file, a 

few pages of an eBook, or a trial version of a software application. You can provide as 

many samples as you require by clicking the Add New Row button and filling out the 

fields. You can add files using either of two methods: 

o Selecting the File option, clicking the Browse button (...) and then clicking the Upload 

Files button. This will upload the file from your local computer to the server.  
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o Selecting the URL option, specifying the link to a file that is already on a server in a 

different location, and clicking the Upload Files button.  

Samples that you put in the Samples section appear in the store as shown in 

Figure 113. 

 

Figure 113. Downloadable Product Sample 

 The Links section contains the actual products that can be purchased, along with 

possible samples for them. 

o The Links can be purchased separately option controls whether each of the 

downloadable products can be purchased by itself or not. This feature enables, for 

example, the tracks of a music CD product to be purchased separately. If you set this 

option to Yes, then you must input the price for each of the downloadable items. 

o Each of the items also has two options controlling its behavior. The Max. Downloads 

option controls how many times after purchase a product can be downloaded by the 

customer. The Shareable option controls whether after each purchase of the product, 

the downloadable item is available for download without logging in, or if it requires 
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logging in. If the Shareable option is set to Yes, then customers can click links in the 

Order Confirmation email that they receive in order to get the product. However, this 

setting also enables anyone who gets this link to download the product. Setting this 

option to Yes is the only way to enable Guests to check out (or to enable a comparable 

quick checkout method, such as PayPal Express or Google Checkout) to download the 

product. There are configuration settings that must be selected to match your store. 

The uploading process is similar to the uploading of the samples, as described 

above, with the exception of providing an option to tie in sample files for each 

downloadable product. This feature can be used to provide customers with a short 

sample of each track of a music CD, for example.  

Figure 114shows a product in a store with three links and samples for each of them, 

for which the setting Links can be purchased separately was set to Yes. 

 

Figure 114. Downloadable Product Links and Samples 
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Bundle Product: Bundle Items Tab  

An example of a bundled product is the Build Your Own Computer offering found in 

the demo store, as shown in Figure 115. 

 

Figure 115. Bundle Product 
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In Bundled product types, there are differences in the General and Prices pages, as 

follows:  

 SKU Fixed or Dynamic (General tab): Specifies whether the entire product is assigned an  

SKU based on its components, or is the SKU fixed for the bundle.  

 Weight Fixed or Dynamic (General tab): Specifies whether the entire product’s weight is 

based on the weight of its individual components, or is the weight fixed for the entire 

bundle. 

 Price Fixed or Dynamic (Price tab): Specifies whether the price of the product us based  

on the price of its individual component, or is the price fixed for the entire bundle. 

 Price View (Price tab): Specifies whether the product’s price is shown as a range, from 

the least expensive component to the most expensive (Price Range), or is only the least 

expensive shown (As Low As).  

The Bundle Items tab contains the following settings: 

 Ship Bundle Items: Specifies whether individual components are shipped separately or 

whether the entire product is shipped.  

 Bundle Items: Bundled Items appear in the store as a list of available options. You can 

add a new option using the Add New Option button. For each option you can configure 

its title, input type (single and multiple selection fields are available), whether the field is 

mandatory (for example: it can be True for a computer processor and False for an 

additional battery of a laptop computer), and its position on the page. 
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Figure 116. Bundle Items Tab 

After you add options, you can specify individual values for each option. Click the 

Add Selection button to open a selection area, as shown in Figure 117. 

 

Figure 117. Adding Products to a Bundle 

You can select any product that you want using the check boxes. Click the Add 

Selected Product(s) to Option button to confirm the assignment. For each selection, 

you can then define the following options: 

 Default Qty: Specifies the default quantity shown in the product view page 

 User Defined Qty: When set to Yes, this option enables customers to enter a quantity for 

a given selection 
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 Position: Specifies the Orders of a selection 

 Default: Specifies the predefined value 

Grouped Product: Associated Products Tab 

A grouped product enables you to purchase each of the items separately. 

In the store, a grouped product appears as shown in Figure 118. 

 

Figure 118. Grouped Product 

When creating a Grouped Product, the Associated Products page enables you to 

specify which products are included in a group, as well as the default quantity for 

each and their position (order) on the page. 

 

Figure 119. Associated Products in a Grouped Product 
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Note: There is no global price for grouped products. Their price is controlled 

only by the individual elements that you purchase. 

Configurable Product: Associated Products Tab 

Configurable products must be associated with simple products using attributes 

that a customer can select from a configurable product page. This means that when 

a shirt is offered in three sizes, then three simple products must be assigned to the  

configurable product, one for each size. 

The configurable product appears in the store with a section that provides 

customers with options, such as the Size option shown in Figure 120. 

 

Figure 120. Configurable Product 
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This is the most complex configuration page and it is described below it in three 

stages.  

Select Configurable Attributes 

This section enables you to select the product attributes that can be configured. The 

only attributes that are available on this tab are those that have a scope of Global, 

an input type of Dropdown, and the Use to create configurable product option set 

to Yes. 

 

Figure 121. Select Configurable Attributes 

Use the check boxes to select one or more desired attribute, and then click 

Continue. 

Create Simple Associated Product 

This section enables you to create simple products along with the configurable 

product.  

 

Figure 122. Create Simple Associated Product 

Click the Create Empty button to open a popup window with a regular product 

creation page, but which has a preselected product type, Simple Product, and an 

attribute set that is the same as the configurable product. 
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The Copy from Configurable button works in a very similar manner to the above, but 

it pre-fills many of the fields with information from the selected configurable 

product, as shown in Figure 123. 

 

Figure 123. Quick Simple Product Creation 

This area enables you to quickly create simple products without filling in all the 

information. Fill in the required fields and click the Quick Create button to create 

this product. The Auto generate option enables Magento CE to select the Name and 

SKU based on the attributes. 

Super Product Attributes Configuration 

This section enables you to specify the attribute name that appears in the store for 

selection and the price for each of the options. Two price options are provided: 

Fixed or Percentage.  
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The price for configurable products is a combination of the price from the Prices tab, 

as described in “Prices Tab,” page 99, and the values entered in this area. This means 

that if the configurable product’s price is $20 and the price for the Medium option is:  

Percentage and 10, then this variation of the product costs $22. The price of the 

associated products is not used for calculation. 

 

Figure 124. Selecting Associated Products 

Completing the Product Wizard 

Click the Save or Save and Continue Editing button in the top right corner of the 

page. If you choose the latter, after saving the product you are redirected back to its 

page. 

To edit an existing product: 

1. From the Catalog menu, select the Manage Products option to display a list of products, 

as shown in Figure 125. 
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Figure 125. Product List 

2. Click the Edit link on the right side of the row of the relevant product. 

Mass-Changing Products 

Magento CE provides various features that enable changes to be made on multiple 

products or their properties. On the product list, mark products using the selection 

check boxes. Then select one of the actions from the Actions dropdown field and 

click the Submit button: 

 Delete: Deletes the selected products from the store. 

 Change Status: Disables or enables multiple products at once. 

 Update Attributes: Updates the attributes of multiple products. When you click the Submit 

button, a new page opens containing a list of all attributes for all selected products. Select 

the Change check box for any attribute that you want to change, then specify the new 

attribute values. Click Save to confirm the changes. 

Note: You can use the Duplicate Product feature to create separate products 

without having to enter every value each time. To use it, click the Duplicate  

button on the product page of an existing product. 
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Creating Variations of a Product  

This section describes how to create variations of a product by adding input controls 

(input options) to a product’s page. An example of the variation of a product is the 

same product with different colors or sizes. In this case a customized field must be 

added by you to enable the customer to select the required color or size. 

Tip: If you want to track the quantity that is sold of each variant of the product, 

you must create a separate product for each variant of the product and 

group them in the product of type Configurable, and not use the 

variations options described here. 

To create variations of a product: 

1. From the Catalog menu, select the Manage Products option to display a list of products.  

2. Click the Add Product button to create a new product or click the Edit link to the right of the 

relevant product to open the edit page.  

3. Select the Custom Options tab. 

4. Click the Add New Options button on the top right of this page to display the controls 

shown in Figure 126. 

 

Figure 126. Creating Custom Options 

5. In the Title field, specify a name for this new property, such as the name Size. 
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6. In the Input Type field, select the type of input that can be given in this field, such as text or 

dropdown menu, as shown above.  

7. In the Is Required field, select Yes to indicate that this is a mandatory field, meaning that a 

customer must select an option in this field in order to purchase this specific product.  

8. If there is more than one option, then specify the order in which this option appears in the 

Sort Order field. A value of 1 indicates that it appears first. 

9. Click the Add New Row button to display the row shown in Figure 127, in which you can 

define the new variation of this product. For example, the product in a certain size and its 

corresponding price. 

 

Figure 127. Creating a Product Variation 

10. In the Title field, specify the name of this variation of the product, such as Size XL. 11. All the 

prices in these rows are relative to the price of this product as defined in the Prices page of 

the product wizard described on page 99. In the Price Type field, select one of the following 

options: 

Setting Up Your Catalog

 Fixed: To specify that the price of this variation of the product differs from the price of the 

base product by a fixed monetary amount, such as $1. 

 Percentage: To specify that the price of this variation of the product differs from the price of 

the base product by a percentage, such as 10%. 
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12. In the Price field, specify the difference between the price of this variation of the product 

and the price of the base product. Specify a fixed amount or a percentage according to the 

value that you entered in the Price Type field. You can also enter negative values. 

13. In the SKU field, specify the SKU for this variation of the product. 

14. If there is more than one variation, then specify the order in which this option appears in the 

Sort Order field. A value of 1 indicates that it appears first.  

15.Click the Save button. This example product is shown in the web store, as shown in Figure 

128. 

Figure 128. Product Variation in the Frontend 

In this example, you can see that the price is $13.50. However, if the Green color 

is selected, then the price is $18.75, as shown in Figure 129. 
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 Price Change for Product Variation Figure 129.

Note: If this product is added to the customer’s shopping cart, then the variation 
information appears there, as shown below:  

 

 

Importing and Exporting Product Data 

Unless you have a small product catalog, the prospect of creating each 

product manually, one by one, is daunting. Magento CE has a solution: 

Import your product data from a comma-separated values (CSV) spreadsheet 

file. You can also export your product data to a CSV file. 

Working with CSV Files 

In order to import a CSV file into Magento CE, it must have certain characteristics. 

Specifically, each column heading must exactly match the Attribute Code for the 

attribute in that column.  

Tip: To ensure that a CSV file’s column headings are understood by Magento 

CE, first export a product CSV file (see “Exporting Product Data,” page 
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126). You can then edit this file (by adding or updating rows) and then re-

import it. 

For the Category column, specify product category in textual form based on a 

category’s path, with a slash (/) between each category level; for example, 

Furniture/Living Room. Do not include the Root Category in the path. 

Setting Up Your Catalog

Importing Product Data 

With the Import feature, you can upload a file that contains the records for as many 

products as you want. 

The file that you upload must be in Comma-Separated Values (CSV) format. Most 

spreadsheet and database applications can read and create CSV files. 

To import a product CSV file: 

1. In the Admin Panel, select System > Import/Export > Import to open the Import page, as  

shown in Figure 130. 

 

Figure 130. Import Page 

2. Select Products from the Entity Type drop-down list.  

3. Select one of the Import Behavior options from the drop-down list: 
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 Append Complex Data: Adds new or edited products to your store’s database. Magento CE 

will not create duplicate entries for existing products and customers included in your CSV 

file.  

 Replace Existing Complex Data: Completely replaces your existing data or portions thereof. 

 Delete Entities: Completely deletes your existing database or portions thereof. 

4. Click Browse and locate the CSV file in your local computer’s file system. 

Note The total size of the CSV file must not exceed the maximum size for your 

environment (typically 32 MB) and must be saved with UTF-8 encoding. 

Check your spreadsheet or database application documentation for 

information about saving a CSV file with UTF-8 encoding. 

5. Click Check Data to validate the uploaded file. 

6. If the uploaded file is valid, a “File is valid!” response appears. Import your products or 

customers by clicking Import. If your file contains errors, Magento CE notifies you of the 

errors and enables you to skip the erroneous rows and importing the valid products or 

customers by clicking Import. 

When the import is complete, the “Import was successfully done” message appears. 

Exporting Product Data 

To export product information: 

1. In the Admin Panel, select System > Import/Export > Export. 

2. Select Products from the Entity Type drop-down list. The system generates a list of entity 

attributes that are relevant to your products. 

3. By default, all attributes are exported to the CSV file. In the Entity Attributes list, select the 

Skip check box for any attributes that you want to exclude from the CSV file. 
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4. By default, all records are exported to the CSV file. Use the controls in the Filter column to 

limit the records that are exported. 

5. Click Continue to export your selected product information to a CSV file. 

6. Open the saved file in your favorite spreadsheet application and edit as needed. 
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9 Setting Up Your Store Hierarchy 

If you have planned your store hierarchy (see “Store Hierarchy,” page 25) and set up 

the appropriate root categories (see “Creating Categories,” page 79), you are ready to 

set up your store hierarchy. 

To set up your store hierarchy: 

1. In the Admin Panel, select System > Manage Stores to open the Manage Stores page, as shown in 

Figure 131. 

 

Figure 131. Manage Stores Page 

2. To create a new website: 

a. Click Create Website to open the New Website page. 

b. In the Name field, specify a name for this website. Typically this will be the site’s domain name (for 

example, somecompany.com). 

c. In the Code field, specify a code name that the Apache Web server will use to point to the domain 

name (for example, somecompany_com). 

d. (Optional) In the Sort Order field, specify an integer number to determine where this website is listed 

in scope-selection drop-down lists in the backend. A specification of 1 places this website at the top of 

the list, 2 places it second, and so on. 

e. Click Save Website. 

3. To create a new store: 

a. From the Manage Stores page, click Create Store to open the New Store page. 
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b. In the Website drop-down list, select the website that will be the parent of this store. 

c. In the Name field, specify a name for this store. 

d. In the Root category drop-down list, select the root category for this store. A root category can be  

assigned to more than one store, or to stores in different websites. 

e. Click Save Store. 

4. To create a new store view: 

a. From the Manage Stores page, click Create Store View to open the New Store View page. 

Setting Up Your Store Hierarchy 

b. In the Store drop-down list, select the store that is associated with this store view. 

c. In the Name field, specify a name for this store view, for example, French. 

d. In the Code field, specify a code for this store view, for example, somecompany.fr. 

e. In the Status drop-down list, select whether this store view is Enabled or Disabled. 

f. (Optional) In the Sort Order field, specify an integer number to determine where this store view is  

listed under its associated store in scope-selection drop-down lists in the backend. A specification of 1 

places this website at the top of the list, 2 places it second, and so on. 

g. Click Save Store View. 

Note: If you are associating a separate domain with each website, some 

modifications must be made to the web server configuration files. For 

details, see the following Magento Knowledge Base article: 

http://www.magentocommerce.com/knowledge  -  base/entry/tutorial  -  multi  -  

site  multi  -  domain  -  setup     
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10Taxes 

Important: No guarantee is offered with respect to any of the information given here. 

Please contact an expert before you take any decisions about tax matters. 

Magento CE provides a variety of options for defining taxes that can be accessed by selecting the Sales 

menu and then the Tax option. Tax classes are used to define “  tax rules  .  ” Tax rules are defined as a 

combination of a Product Class, a Customer Class and a Tax Zone and Rate, as described below.  

Each type of customer can be assigned a class when you define them, and each product is assigned a 

tax class. For a description of how to define a customer, see “Managing Customers,” page 224. For a 

description of how to define a product, see “Creating a New Product,” page 96. 

Magento CE analyzes the shopping cart of each customer and calculates the appropriate tax according 

to the class of the customer, the class of the products in the shopping cart, and the region (as defined 

by the customer’s shipping address, billing address or shipping origin). 

Magento also supports the calculation of Value-Added Tax (VAT) for business-to-business transactions 

in the European Union. For more information, see “Appendix: VAT ID Validation,” page 279. 

Note: When you set up tax options, be sure to set your store scope so that the options are 

applied across stores and websites appropriately. 

Important: You can restrict access to tax settings in the Admin panel by setting permissions for users. 

You set permissions by creating roles. For more information, see “Limiting Administrator Access to the  

Admin Panel (Backend),” page 249. 

Note that to access tax functionality you need to make sure that the Sales/Tax areas are checked along 

with the System/Tax areas. If you are setting up another website and you want to load catalog prices 
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including tax for a different region than your default shipping origin, you’ll also need to allow access to 

the 

System/Shipping settings for that role, because shipping origin determines what the assumed store 

tax rate is for catalog prices. 

Tip: For more information about tax updates, including recommended tax configurations 

for different countries, see 

http://www.magentocommerce.com/knowledge  base/entry/magento  -  ce  -  18  -  ee  -  113  -  

tax  -  calc  .   

General Taxation Settings 

To configure general taxation settings:  

1. From the System menu, select the Configuration option.  

2. From the SALES section in the panel on the left, select Tax. 

3. Expand the Tax Classes section, as shown in Figure 132.  
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 Taxes 

 

Figure 132. Tax Class for Shipping and Gift Options 

4. In the Tax Class for Shipping field, designate a product tax class for the shipping amount, or select None 

if your store does not charge an additional tax on shipping expenses. 

5. In the Tax Class for Gift Options field, designate a product tax class for gift options, or select None if your 

store does not charge an additional tax on gift options. 

Note: For more information about product tax classes and how to set them up, see “Product 

Tax Class,” page 132. 

6. Expand the Calculation Settings section, as shown in Figure 133. 

 

Figure 133. Tax Calculation Settings 

 155 



Taxes 

7. In the Tax Calculation Method Based On field, select which amount is used as the basis for calculating 

taxes. Because of rounding, this selection may affect the total amount of tax you charge on an order. 

Option  Description 

Unit Price Using this rounding rule, Magento calculates the tax for each item and displays prices 

taxinclusive. To calculate the tax total, Magento rounds each of the item taxes 

individually and then adds them together. 

Row Total Using this rounding rule, Magento calculates the tax for each line. To calculate the tax 

total, Magento rounds each of the line item taxes and then adds them together. 

Option  Description 

Total Using this rounding rule Magento calculates the tax for each item and adds those tax 

values to calculate the total unrounded tax amount for the order. Magento then  

applies the specified rounding mode to the total tax to determine the total tax for the 

order. 

8. In the Tax Calculation Based On field, select whether the tax is calculated based on the customer’s 

shipping address, billing address, or your store’s shipping origin. 

9. In the Catalog Prices field, specify whether the catalog prices of items include tax or exclude tax.  

10. In the Shipping Prices field, select whether the shipping amounts include tax or exclude tax.  

11. In the Apply Customer Tax field, select whether tax is applied to the original or discounted price. 

12. In the Apply Discount on Prices field, select whether any discounts applied include the tax or exclude it. 

13. In the Apply Tax On field, select whether tax is applied to custom prices or to original prices. 

14.Expand the Default Tax Origin Calculation section to specify which country is used by Magento as the 

default for tax calculation, as shown in Figure 134. 
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Figure 134. Default Tax Origin Calculation 

Note: If you select Including Tax for any of the options described in the following steps, then 

the tax is only displayed if there is a tax rule that matches the tax origin or if Magento 

detects that the customer address matches the tax rule (which happens after a 

customer creates an account, logs in, or uses the Tax and Shipping estimation tool in 

the cart). 

15.Expand the Price Display Settings tab to select how prices for products shipping are displayed in the 

catalog (including tax, excluding tax, or both). 

16.Expand the Shopping Cart Display Settings section to select how taxes and prices are shown for 

products and in a shopping cart according to the requirements (legal and otherwise) of your store, as 

shown in Figure 135. 

 

Figure 135. Shopping Cart Tax Display Settings 
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17.Expand the Orders, Invoices, Credit Memos Display Settings tab to select how prices and taxes are 

displayed in orders, invoices, and credit memos. 

18.Expand the Fixed Product Taxes tab to specify the behavior of fixed per product taxes, such as the 

European DEEE/WEEE (Waste Electrical and Electronic Equipment) tax, according to the requirements for 

your store and products. 

Note: To assign a fixed tax to a product, create an attribute with the Catalog Input Type for  

Store Owner set to Fixed Product Tax, and assign this attribute to the attribute set for 

the product. 

Product Tax Class 

You create product tax classes and assign products to them depending on the type of product. 

For example, food might not be taxed (or might be taxed at a different rate). 

To define a product tax class:  

1. Select Sales > Tax > Product Tax Class to display the Product Tax Classes page (Figure 136), which shows 

a list of the previously defined product tax classes.  

Figure 136. Product Tax Classes Page 

2. Click the Add New button to display the New Class page, as shown in Figure 137. 
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Figure 137. New Product Tax Class Page 

3. In the Class Name field, specify a name for this tax class. 

Note: You can apply a tax class to a product by editing the product and choosing the 

appropriate option on the Prices tab. 

4. Click Save Class.  

Customer Tax Class 

You create customer tax classes and assign customers to them depending on the type of 

customer. 

For example, in some jurisdictions, wholesale transactions are not taxed but retail transactions 

are. 

To define a customer tax class: 

1. Select Sales > Tax > Customer Tax Classes to display a list of the previously defined customer tax classes. 

2. Click the Add New button to display the New Class page, as shown in Figure 138. 

 

Figure 138. New Customer Tax Class Page 

3. In the Class Name field, specify a name for this tax class. 
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Note: You can link a customer tax class to a customer group by editing the customer group. 

You can then assign this customer group when creating or editing a customer. 

4. Click the Save Class button.  

Tax Zones and Rates 

Tax rates are generally applicable to transactions that take place in specific geographical areas. 

The Tax Zones and Rates feature enables you to specify the tax rate for each geographical area 

for which you collect and remit taxes. Because you give each tax zone and rate specification a 

unique identifier, you can have multiple tax rates for a given geographic area (for example, for 

places that do not tax food or medicine but tax other products). 

Note: Store tax is used for initial display purposes on orders. Store tax is calculated based on 

the store’s address. Actual customer tax on an order is calculated after a customer 

enters their information, and then Magento calculates the actual tax based upon your 

store’s tax configuration. 

To define tax zones and rates:  

1. Select Sales > Tax > Manage Tax Zones and Rates option to display a list of the previously defined tax  

zones and rates. 

Figure 139. Manage Tax Rates Page 

2. Click Add New Tax Rate to display the Add New Tax Rate page, as shown in Figure 140. 
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Figure 140. Add New Tax Rate Page 

3. Set the Tax Rate Information (and optional Tax Titles) options as shown in the following table. 

Option Description 

Tax Identifier This is the title of the newly created tax rate. Do not use spaces. This 

identifier is not visible to customers if the alternate Tax Titles section is 

used. 

Country and State Select the country and state to which the specific tax applies. Country is 

required. State becomes enabled if you specify a country that has states. 

Option Description 

Zip/Post is Range  If you select No, specify the Zip or postal code in the Zip/Post Code field. 

You can use the asterisk (*) wildcard character in this field; for example, 

90* means all Zip codes from 90000 through 90999. 

Select Yes if you want this tax applied to a specific range of Zip codes.  

Range From / Range To Specify the starting and ending Zip or postal code ranges. 

Rate Percent Specify the tax rate. Enter the tax rate as a percentage number. For 

example, enter 9.75 for a tax rate of 9.75%. 
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Tax Titles This option applies only if you have a store in different languages and you 

want to have the languages displayed differently. Tax Titles let you name 

your tax rate if you have a store that is translated into different languages 

and you use the same tax rates for all languages. 

4. Click the Save Rate button. 

Tip: You can export your tax rates to either CSV (comma-separated value) format or Excel 

XML format using the Export button at the top of the grid. It can be easier to manage 

your tax rates in a spreadsheet format if you are familiar with the requirements for 

importing and exporting in CSV or XML formats. 

Tax Management Rules 

Tax rules are defined as a combination of a customer tax class and a product tax class with a tax 

rate. In other words, based on the class of the customer (customer tax class), the class of the 

products (product tax class) in the shopping cart, and the region (tax rate depending on the 

shipping address, billing address, or shipping origin), Magento calculates the appropriate tax 

for each order. 

Note: When you set up tax options, be sure to set your store scope so that the options are 

applied across stores and websites appropriately. 

To define Tax Management Rules: 

1. To define how taxes are charged, select Sales > Tax > Manage Tax Rules to display a list of the previously 

defined tax rules, as shown in Figure 141. 
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Figure 141. Manage Tax Rules Page 

Each tax rule is composed of a customer tax class, a product tax class, and a tax rate. 

2. To define a new tax rule, click Add New Tax Rule to display the Edit Rule page, as shown in Figure 142. 
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Figure 142. Edit Rule Page 

3. In the Tax Rule Information area, select the options as shown in the following table. 

Option Description 

Name Specify a name for this tax rule that will make it easy to identify. 

Customer Tax Class Select the customer tax class to which you will apply this tax rule. 

Product Tax Class Select the product tax class to which you will apply this tax rule. 
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Tax Rate Select the tax rate to apply for this tax rule. 

Option Description 

Priority Specify the priority of this tax, when more than one tax applies. Lower 

numbers have higher priority. If two tax rules with the same priority apply 

then the taxes are added together. If two taxes with a different priority apply 

then the taxes are compounded. When taxes are compounded, the first 

priority tax is calculated on the subtotal amount, and then the second priority 

tax is calculated on the subtotal plus the first priority tax amount. 

Calculate off subtotal 

only 

Important: Check this checkbox for taxes to be calculated off only the subtotal 

of the order. This means that for this tax rule, tax applies only to the subtotal 

of the order. 

Sort Order Specify the order in which tax rules are displayed on the Manage Tax Rules 

page. Lower numbers have higher sort order in the list. 

 

4. Click Save Rule or Save and Continue Edit to save your changes. 

Tip: When numerous taxes must be defined, you can ease the process by importing them 

from a spreadsheet. Select Sales > Tax > Import/Export Tax Rates. 

Fixed Product Tax 

Some tax jurisdictions have a fixed tax that must be added to certain types of products. 

Magento lets you set up a fixed product tax (FPT) for use in your store's tax calculations. For 

example, in some countries FPT can be used to set up a WEEE tax, also known as "ecological tax" 

or "eco tax," that is collected on certain types of electronics to offset the cost of recycling. This  

tax is a fixed amount, rather than a percentage of the product price. 

 165 



Taxes 

Your tax jurisdiction might also have rules about how you display the price of products to your 

customers, either with or without tax. Be sure you understand those rules so that you can set 

your FPT display options accordingly. 

Fixed Product Tax (FPT) Calculation 

Fixed product taxes are applicable at an item level based on the product. In some jurisdictions 

this tax is subject to an additional % tax calculation. 

 

FPT taxed/not taxed Display setting and associated calculation 

FPT is not taxed Excluding FPT: Treat FPT as a separate row in the cart and include the 

value of FPT in the appropriate tax calculations. 

Including FPT: FPT is added to the base price of an item but is not included 

in tax- rule-based calculations. 

Excluding FPT, FPT description, final price: Item prices are shown without 

FPT, FPT amount, and with FPT included.  FPT is not included in tax-rule-

based calculations. 

FPT taxed/not taxed Display setting and associated calculation 

FPT is taxed Excluding FPT: Treat FPT as a separate row in the cart and include the 

value of FPT in the appropriate tax calculations. 

Including FPT: FPT is included in the price of an item, and no change 

to tax calculations is required. 

Excluding FPT, FPT description, final price: Item prices are shown 

without FPT, FPT amount, and with FPT included. FPT is included in 

tax-rule-based calculations. 

 

Note: How you set the option to Display Prices in Sales Modules and Display Prices in Emails 

can affect customer confidence in their orders. For example, if you choose to display 
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Order Review prices without showing FPT, customers who buy items with associated 

FPT will see a total that includes the FPT tax amount, but they will not see an itemized 

entry for this amount. This might cause abandoned carts if your customers see an order 

total that does not match what they expect, based on an itemized list of products in the 

order. 

Step 1: Enable the FPT Tax 

To enable FPT: 

1. From the Admin panel, select System > Configuration. 

2. In the Configuration panel on the left, under Sales, select Tax. 

3. Click to expand the Fixed Product Taxes section. The section displays the set of options shown in the 

following figure. 

 
 

Figure 143. Fixed Product Taxes Options 

4. Set Enable FPT to "Yes." 
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5. Select one of the following options to determine how Fixed Product Taxes are displayed throughout 

your store (product page, catalog listing, etc.). 

Option Description 

Including FPT only The displayed price includes a fixed product tax, but not a 

description of the tax. 

Including FPT and FPT description The displayed price includes a fixed product tax and a 

description of the tax. 

Excluding FPT The displayed price does not include a fixed product tax. 

Excluding FPT, FPT description, final price The displayed price is shown not including FPT, and the FPT 

amount and subtotal are displayed on separate lines. 

 
If you select Excluding FPT, FPT description, final price, the following figure shows what your 

customers see on the shopping cart page. 

 

Figure 144. Shopping Cart Page with FTP Shown 
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6. Set Display Prices in Product Lists to determine how prices appear in products lists, such as the category 

page. 

7. Set Display Prices on Product View Page to determine how prices appear on the product page. 

8. Set Display Prices in Sales Modules to determine how prices appear in the Order Review section during 

checkout, and in the Items Ordered section of a sales order. 

9. Set Display Prices in Emails to determine how prices appear in the sales email confirmation that is sent 

when an order is placed. 

10.Set Apply Discounts to FPT to one of the following: 

o Yes: Discounts are applied to the fixed product tax amount. 

o No: Discounts are applied to the base price of a product without the fixed product tax included. 

1. Set Apply Tax to FPT to one of the following: 

o Yes: Tax is applied to the fixed product tax amount. 

o No: Tax is applied to the base price of products without the fixed product tax included. 

1. Set Include FPT in Subtotal to one of the following: 

o Yes: The fixed product tax is included in the shopping cart subtotal. 

o No: The fixed product tax is displayed under the shopping cart subtotal and is not included in the 

subtotal itself. 

1. When complete, click the Save Config button to save the settings. 

Step 2: Create a Fixed Product Tax Attribute for Products 

To create the attribute: 

1. From the Admin panel, select Catalog > Attributes > Manage Attributes. 
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2. To add a new FPT product attribute, click the Add New Attribute button in the upper right. 

3. In the Attribute Code field, specify a unique identifier for this attribute. Do not use spaces or special 

characters. However, you can use hyphens or underscores. The maximum length is 30 characters. In this 

example, "eco_tax" is the attribute code. 

4. In the Scope field, select the level at which the values of this attribute are shared, as shown in the 

following table. 

Option Description 

Global The value of this attribute for a given product must be the same throughout your 

website. 

Website The value of this attribute for a given product can differ on different websites; however, 

it cannot differ between store views contained under the same website. 

Store View The value of this attribute for a given product can differ on all websites and all store 

views. For example, if you were creating an attribute called Color, with a Store View  

scope, you would be able to set the color of a product to green in one store view, and 

blue in another store view. 

 

5. In the Catalog Input Type for Store Owner field, select "Fixed Product Tax." 

6. In the Apply To field, select one of the following options: 

o All Product Types o Selected Product Types: If you select this 

option, a dropdown list shows the product types to which you can choose 

to apply this attribute. 

7. Click Save Attribute. 

The following figure shows the New Product Attribute for the Fixed Product Tax. 

170 



 Taxes 

 

Figure 145. Fixed Product Tax Attribute 

Step 3: Assign the FPT Attribute to an Attribute Set 

To assign the new attribute to an attribute set: 

1. From the Admin panel, select Catalog > Attributes > Manage Attribute Sets. 

2. In the Manage Attribute Sets area, click the name of the attribute set in which you want to include the 

FPT attribute. This example uses the Default attribute set. 

3. The Edit Attribute Set 'Default' area displays a list of Groups and a list of Unassigned Attributes. Find 

your FPT attribute (eco_tax in this example) in the unassigned list and drag and drop it into the attribute 

group where you want it to appear. 

4. Click Save Attribute Set. 

In this example the eco_tax attribute is included the General attribute group, as shown in the 

following figure. 
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Figure 146. General Attributes Group with FPT Tax Attribute 

Step 4: Apply the Fixed Product Tax to Products 

To apply the FPT to products: 

1. From the Admin panel, select Catalog > Manage Products. 

2. For the product to which you want to add the FPT, click the Edit link in the Action column. 

3. In the Eco Tax area, set the scope for the tax and the countries and states in which this tax will apply. 

Depending on the choices you make, the input fields change to accommodate the details of where the 

tax will apply. 

4. In the Tax box, enter the amount for the Fixed Product Tax. 

5. To add more countries or states to which to apply the FPT, click the Add Tax button. You can apply a 

different amount for the tax for each locale where it applies. 
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6. When finished, click Save. 

Value-Added Tax 

Some countries charge a value added tax, or VAT, on goods and services. There can be different 

VAT rates depending on which stage you as a merchant are at in the manufacture or distribution 

of the products, materials, or services that you sell to your customers. In this case you may need 

to use more than one VAT rate in your store for tax calculation purposes. 

This section provides a sample procedure for setting up a 20% VAT in the U.K. for sales to retail 

customers. For other tax rates and countries, follow the general procedure but enter specific 

information that corresponds to your country, VAT rate, customer types, and so on. 

Note: Before proceeding, make sure to find out which rules and regulations apply to VAT in 

your area. 

Note: In certain business-to-business transactions, VAT is not assessed. Magento can 

validate a customer’s VAT ID to ensure that VAT is assessed (or not assessed) properly. 

For more information, see “Appendix: VAT ID Validation,” page 279. 

Step 1: Set Up Customer Tax Classes 

To set up example VAT customer tax classes: 

1. From the Admin panel, select Sales > Tax > Customer Tax Classes. 

2. Ensure that there is a customer tax class that is appropriate to use with the VAT. For this example, ensure 

that there is a customer tax class named Retail Customer. If Retail Customer does not exist, add it using 

the Add New button. 

Step 2: Set Up Product Tax Classes 
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To set up example VAT product tax classes: 

1. From the Admin panel, select Sales > Tax > Product Tax Classes. 

2. Click the Add New button and add three new classes: 

o VAT 

Standard o 

VAT 

Reduced o 

VAT Zero  

3. Click the Save Class button for each new class that you add. 

Step 3: Set Up Tax Zones and Rates 

To set up example VAT tax zones and rates: 

1. From the Admin panel, select Sales > Tax > Manage Tax Zones & Rates. 

2. For this example you can choose to remove the U.S. tax rates, or leave them as they are. 

3. Click the Add New Tax Rate button. Add new rates as shown in the table below. 

New Tax Rate Settings 

VAT Standard Tax Identifier: VAT Standard 

Country and State: United Kingdom 

Rate Percent: 20.00 

New Tax Rate Settings 

VAT Reduced Tax Identifier: VAT Reduced 

Country and State: United Kingdom 

Rate Percent: 5.00 
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1. Click the Save Rate button for each new rate that you add. 

Step 4: Set Up Tax Rules 

A tax rule is a combination of a customer tax class, a product tax class, and a tax rate. 

To set up example VAT rules: 

1. From the Admin panel, select Sales > Tax > Manage Tax Rules. 

2. Add new tax rules as shown in the table below. 

New Tax Rule Settings 

VAT Standard  Name: VAT Standard 

Customer Tax Class: Retail Customer 

Product Tax Class: VAT Standard 

Tax Rate: VAT Standard Rate  

VAT Reduced Name: VAT Reduced 

Customer Tax Class: Retail Customer 

Product Tax Class: VAT Reduced 

Tax Rate: VAT Reduced Rate 

1. Click the Save Rule button to save your VAT tax rules. 

Step 5: Apply Tax Classes to Products 

To apply example VAT classes to products: 

1. From the Admin panel, select Catalog > Manage Products. 

2. Select a product from your catalog to edit. 

3. In the Product Information tab, in the General section, find the Tax Class option. 
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4. From the list, select the VAT class that applies to the product. 

5. When finished, click the Save button. 

Compound Taxes 

For compound taxes, the total cost of a product or service is taxed at one rate, and then 

the total of that amount, including the first tax amount, is taxed a second time. 

Compound tax is also known as stacked tax. 

For example, in a regular tax calculation involving two tax rules, each rule is applied 

separately to the product subtotal, and the taxes are added together to calculate the 

total tax, which is then added to the product subtotal to calculate the grand total: 

 

Figure 147. Regular Two-Tax Calculation 

With compound taxes, the first tax is added to the product subtotal, and the second tax is 

applied to that total: 
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Figure 148. Compound Tax Calculation 

Setting Up a Compound Tax 

You set up a compound tax in Magento using different priorities for tax rules. If two tax rules 

with the same priority apply then the taxes are added together. If two taxes with a different  

priority apply then the taxes are compounded. When taxes are compounded, the first priority 

tax is calculated on the subtotal amount, and then the second priority tax is calculated on the 

subtotal plus the first priority tax amount. Lower numbers have higher priority. 

Important: In order for compound taxes to work correctly do not select the Calculate off 

subtotal only check box when you set up your tax rules that apply to compound taxes. 

This check box overrides the compounding calculation and cannot be used in 

conjunction with compound taxes. 

To set up compound taxes: 

1. Set up all the tax rates that will be used in your compound tax rule. See “Tax Zones and Rates,” page 

133. 
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2. Set up the first tax rule for compounding. For the first tax rule, be sure that you set a higher priority than  

you will set for the next tax rule, which will be compounded on top of this first tax rule. Lower numbers  

are used for higher priority. Use 0 for the highest priority. See “Tax Management Rules,” page 135. 

3. Set up the second tax rule for compounding. For the second rule, be sure that you set a lower priority 

(use a higher number) than you set for the first tax rule. 
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A variety of shipping rates are available for selection in Magento CE. This section 

describes a few of these shipping rate options for your web store.  

General Shipping Settings 

To configure general shipping settings:  

1. Select System > Configuration > Shipping Settings. 

2. Expand the Origin section and specify the address used for shipping calculations. Typically, 

this is the warehouse address from which products are shipped, as shown in Figure 149. 

 

Figure 149. Shipping Origin Settings 

3. Expand the Options section, as shown in Figure 150. 

 

Figure 150. Shipping Options Settings 

4. In this section, enable or disable shipping to multiple addresses. Shipping to multiple 

addresses is very useful for stores that sell gifts. It enables customers to send various parts of 

an order to different destinations. 
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5. Click Save Config to save your changes. 

Flat Shipping Rates 

A flat shipping rate refers to a fixed predefined cost for shipping which can be 

applied per item or per shipment, according to your preferences. 

To define flat shipping rates: 

1. Select System > Configuration > Shipping Method.  

Shipping 

2. Expand the Flat Rate section to define a fixed predefined amount for shipping, as shown in 

Figure 151. 



 

Figure 151. Flat Rate Shipping Settings 

Tip: Magento CE also provides the option to specify table rates by expanding the 

Table Rates section. This feature enables you to define shipping rates by 

weight, destination, price, the number of items and various combinations of 

these categories. The table rates are entered by importing a CSV file. See 

http://www.magentocommerce.com/knowledge  -  base/entry/how  -  do  -  i  -  set  -  

up  table  -  rate  -  shipping     for more information. 

3. In the Enabled field, select Yes. The flat rate method then appears as an option in the 

shopping cart and on the shipping page during the checkout. 

4. The contents of Title and Method name fields appear in the frontend as shown in Figure 152. 
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Figure 152. Flat Rate Shipping Method and Title 

Note: Some Shipping Methods, such as UPS, provide a variety of shipping 

methods to choose from. 

5. In the Type field, specify the entity to which the shipping fee applies, such as Per Item. In this 

case, the shipping fee is dependent on the number of items shipped. If you set the rate to be 

per item, it is multiplied by the total quantity of items in the shopping cart. If you have two 

of the same item or two different items, then the rate is the same.  You can also select Per 

Order in this field. 

6. In the Ship to applicable countries field, you can select the Specific Countries option to 

enable access to the field under it in which you can select specific countries, so that the 

appropriate (and different) shipping rates are applied to the relevant countries, as shown in 

Figure 153. 

 



Figure 153. Specific Countries Selection 

Tip: Hold down the Ctrl key while clicking options to select multiple countries. 

7. In the Sort Order field, specify the position of this shipping method in relation to the other 

shipping methods offered to the customer. 

Online Rates 

Apart from static options such as flat rates and table rates, Magento CE also offers 

dynamic retrieval of rates from various shipping providers. 

Shipping 

Note: Most shipping providers require that you open an account with them. 

Consult your shipping provider for details on how to obtain API credentials. 

To enable and configure these shipping methods, expand the appropriate tabs (UPS, 

USPS, FedEx, or DHL) and configure the settings. The configuration of this method is 

similar to the configuration of a Flat Rate, as described above. The exact options 

depend on the service provider; contact the provider for more information. 

For example, UPS rates can appear in your web store as shown in Figure 

154. 

 

Figure 154. UPS Shipping Options 
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Offering Free Shipping 

Tip: Free shipping per product can be defined as a shopping cart price rule. See 

“Promotions,” page 189, for more information. This option enables you to 

set up free shipping that is valid only when a customer provides the 

appropriate discount code. 

To define free shipping:  

1. Select System > Configuration > Shipping Methods. 

2. Expand the Free Shipping section to enable free shipping with optional minimum order 

amount, as shown in Figure 155. 
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Figure 155. Free Shipping Settings 

3. In the Enabled field select Yes to enable the method.  

4. In the Minimum order amount field specify the amount for an order over which shipping is 

provided free of charge.  

5. In the Ship to applicable countries field, you can select the Specific Countries option to 

enable access to the field under it in which you can select specific countries, so that free 

shipping is only applied to the relevant countries or you can select the All Allowed Countries 

to specify that free shipping is available for users from all countries. 

Acquiring Additional Shipping Modules 

Numerous other shipping modules are provided at 

http://www.magentocommerce.com/magento  -  connect     and new ones are uploaded 
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often. More information on installing shipping extensions is provided in “Extending 

Magento,” page 256. 

 





12Payment 

Now that you have a method to calculate the cost of the shipping of your products, you can 

configure the payment options that enable the collection of money. Magento CE offers several  

payment options and many more can be added by downloading Magento payment module 

extensions, provided at http://www.magentocommerce.com/magento  -  connect  .   More 

information on installing payment module extensions is provided in “Extending Magento,” 

page 256. 

The following shows how to set up some of the most popular payment methods. Setting up other 

options is just as simple. 

PayPal 

PayPal is one of the most popular ways to accept online payments. It enables you to 

accept credit cards and PayPal accounts. This section shows how to set up the PayPal 

Website Payments Standard method. Other PayPal payment methods are set up in a 

similar manner. 

To set up payment by PayPal Website Payments Standard: 

1. Your first step is to create a PayPal merchant account. Please check with PayPal 

(  www.paypal.com  )   for detailed instructions. 

2. In the Magento CE backend, select System > Configuration > PayPal to display the PayPal page, 

as shown in Figure 156. 
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Figure 156. PayPal Page 

3. In the Merchant Account section, select the country and specify the email address that is 

associated with your PayPal merchant account. 

4. Select the Website Payments Standard check box to display the Website Payments Standard 

Settings section, shown in Figure 157. 
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Figure 157. PayPal Website Payments Standard Settings 

5. In the Title field, specify a title to be shown to your customers. 

6. In the Sort Order field, specify an integer number to indicate where this payment method should 

appear on the list of available payments on the frontend. A value of 

1 places this payment at the top of the list, a value of 2 places it second, and so on. 

7. In the Payment Action field, select one of the following options: 

 Authorization: Blocks or holds funds in the PayPal account until these funds have been 

transferred to your account. This usually occurs when you process the Order. 

 Sale: Specifies that funds are transferred to your account immediately. 

8. In the Payment Applicable From field, leave the All allowed countries selection or select 

Selected Countries to select from a list of countries. 

9. In the Sandbox Mode drop-down list, select whether this payment method is in sandbox mode. 

Sandbox mode is used when you are setting up and testing the payment method; no actual 

payments are processed. 

10. In the Transfer Cart Line Items drop-down list, select whether information about each individual 

line item in the order is sent to the payment processor (Yes), or only the order total (No). 

11. In the Debug Mode drop-down list, select whether this payment method is in debug mode. 

Debug mode is used when there is a problem processing a payment and you want to know 

what data is being exchanged with PayPal and where the error is occurring. Data (except for 

credit card numbers) is stored in the system log file. 

12.Click Save Config. 

Note: This procedure includes only the basic setup items for this particular PayPal 

payment method. For information about other PayPal payment methods and 

configuration options, see 
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http://www.magentocommerce.com/knowledge  base/entry/setting  -  up  -  paypal  -  

for  -  your  -  magento  -  store  .   

PayPal Advanced 

The PayPal Advanced payment method is available for merchants in the United States 

only. 

General Concept 

The PayPal Payments Advanced payment method passes the information about the card, 

entered by a customer, directly to PayPal; it is never stored in your Magento system. A 

customer does not need to have a PayPal account to use this method. 

The PayPal Advanced payment method is not available for orders created from the 

Admin Panel. 

Configuring PayPal Payments Advanced 

To use the PayPal Advanced method, you should have a PayPal Payments Advanced 

account on PayPal. You need to have a separate account for each website. 

Configuring the PayPal Advanced method for each website is a two-step procedure for 

each website: 

1. Set the options in the Magento Admin Panel. 

2. Set the required options of the PayPal Payments Advanced account on the PayPal Manager 

website. 
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Setting PayPal Payments Advanced Options in the Magento 

Admin Panel 

To configure the PayPal Advanced payment method in the Magento Admin 

Panel: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Configuration. 

3. Select the desired website from the Current Configuration Scope drop-down list in the upper-left 

corner of the page. 

4. Under SALES in the left column, click PayPal. In the Merchant Country field select United States. If 

any other country is selected, the PayPal Payments Advanced settings are not displayed. 

5. In the Select a PayPal Solution section, select the PayPal Payments Advanced check box to make 

the payment method settings available. When the check box is selected, the corresponding 

configuration field set appears. The following settings are available:  

• Title: In the Title field, specify the name of the payment method that will be displayed to 

customers in the Payment Information section of the one-page checkout. This parameter can 

be set up for each store view. 

• Sort Order: When deciding to use a number of payment methods, in the Sort Order field 

determine the sequence number of this method in the list of available methods in the 

Payment Information section of the one-page checkout. 

Note: The payment methods for which the sort order is not set are displayed first. 

• Payment Action: Choose what type of transaction is conducted when the order is placed, and 

the entities that will be created in the backend as a result. The following options are available: 
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 Authorization: The payment is authorized and only an order is created in the backend of your 

store. 

 Sale: The payment is captured at PayPal's side, and as a result an order and an invoice are 

created in the backend of your store. 

• Payment Applicable From: Choose the countries from which customers can use this payment 

method. Choose between the following options:  

 All Allowed Countries: Customers from the default countries list can use this payment 

method. 

 Specific Countries: Only customers whose billing address includes one of the countries 

selected in the Countries Payment Applicable From field can use this payment method. The 

field basically works as a filter; so that this payment method will be listed for only those 

customers whose billing address is in one of these selected countries. 

• Debug Mode: In the Debug Mode field, specify whether communications with the payment 

system will be written into the log file. The log file for PayPal Payments Advanced is 

payments_payflow_advanced.log. 

6. In the API/Integration Settings field set configure the following:  

• In the Partner, User, Vendor and Password fields, specify your PayPal Payments Advanced 

account credentials. 

• Test Mode: The test mode helps testing the integration of Magento with the PayPal payment 

system. Transactions that are submitted while the account is in the test mode are not actually 

submitted to the credit card and electronic check processing networks, and credit card or 

bank accounts are not actually charged. Therefore, these transactions do not have valid 

transaction IDs. When you finish testing the integration project, the test mode must be turned 

off. 

• Use Proxy: Decide whether the proxy server is used for establishing the connection between 

Magento and the PayPal payment system. If you select Yes, two additional fields for specifying 

the proxy host and port are displayed. 
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7. Click Save Config in the upper-right corner of the page to save the settings. 

Setting the PayPal Payments Advanced Account Options on 

the PayPal Manager Website 

To make the necessary settings for the PayPal Advanced account, take the 

following steps: 

1. Log in to https://manager.paypal.com/     

2. Navigate to Service Settings > Hosted Checkout Pages. Options should be configured in the Set Up 

and Customize sections. 

3. Configure the options according to the recommendations displayed in the PayPal Payments 

Advanced field set in the Magento Admin Panel. 

PayPal Payments Advanced Method: Customer Experience 

A store customer selects the PayPal Payments Advanced payment method on the 

Payment Information checkout step and clicks Continue. The Order Review step 

appears, where the PAY NOW button is available instead of the usual PLACE ORDER 

button. After the customer clicks PAY NOW, the PayPal-hosted form opens in the 

customer’s browser. The customer enters the card information and clicks Verify Card. 

If the transaction is successful, the customer is redirected to the order confirmation 

page. 

Note: The form also contains the Pay with PayPal button; clicking it redirects a 

customer to the PayPal site, where the customer can complete the payment 

using PayPal Express Checkout. 
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If the transaction fails on any reason, an error message appears on the checkout 

page and the customer is directed to repeat the checkout process. These situations 

are handled on the PayPal side. 

Order Processing When the PayPal Advanced Payment 

Method Is Used 

Processing of orders that are paid using the PayPal Payments Advanced payment 

method is the same to regular processing of orders that are paid with PayPal. An 

invoice, shipment, and credit memo (online/offline refund) can be created. Multiple 

online refunds are not available for the PayPal Payments Advanced payment 

method. 

When PayPal Advanced is used, an order is created in the Admin Panel once a 

customer clicks PLACE ORDER on the Order Review step of the one-page checkout. 

The order status upon creation depends on the response the system receives from 

PayPal, and can be one of the following: 

 Processing: The transaction was successful 

 Pending Payment: The system did not receive any response from PayPal 

 Canceled: The transaction was not successful for some reason 

 Suspected Fraud: The transaction did not pass some of the PayPal fraud filters. The system receives 

the response from PayPal that the transaction is under review by Fraud Service. 

PayPal Express Checkout 

Configuring the PayPal Express Checkout payment method is similar to setting up 

the other PayPal payment methods. For this reason, the details of the basic PayPal 
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Express Checkout setup are not described here. However, there are two aspects of 

PayPal Express Checkout that you should be aware of when setting it up: Saving the 

customer’s billing address, and Order transactions. 

Saving the Customer’s Billing Address  

Prior to version 1.11 of Magento Enterprise Edition and version 1.7 of Magento 

Community Edition, the PayPal Express Checkout payment method did not allow 

saving the complete billing address for the order in Magento. Starting with those 

versions this restriction has been removed and a complete billing address can be 

saved in a Magento order when the PayPal Express Checkout payment method is used 

by a customer. The billing address can be received from PayPal, and can be edited by 

the customer. 

If you want to receive the billing address of a customer from PayPal for customers 

using the PayPal Express Checkout payment method, you need to take the following 

steps: 

1. Enable the corresponding functionality is enabled in your PayPal merchant account. Contact 

the PayPal technical support for details. 

2. In the Magento Admin Panel under System > Configuration > SALES > PayPal > Express 

Checkout Settings in the Require Customer’s Billing Address field select Yes, and save the 

configuration. If you want to request customers billing address only for orders which contain 

downloadable and/or virtual products only, in the Require Customer’s Billing Address field 

select For Virtual Quotes Only. 

When customers choose to pay using PayPal Express Checkout, they are redirected to 

PayPal. Having logged in to PayPal and reviewed the payment information, they are 

redirected back to the store, to the Order Review page, where they choose the shipping  

method, edit the billing and shipping addresses and place the order.  
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Note: If a billing address cannot be received from PayPal because of your 

configuration or due to any other reasons, the billing address fields on the 

Order Review page are prepopulated with the shipping address values. A 

customer can edit themt if necessary.  

Figure 158 illustrates the Order Review store page when a customer uses the PayPal 

Express Checkout payment method. 
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Figure 158. The Order Review page when PayPal Express Checkout 

payment method is used. 

If a customer leaves the billing and shipping addresses without changes, the 

PLACE ORDER button is enabled when the customer selects the shipping 

method in the Shipping Method field. 

If the customer edits the billing or shipping address, the PLACE ORDER button is 

disabled. The customer needs to click the UPDATE ORDER DATA button first. The 

system will update the information, including the available shipping methods, and 

the PLACE ORDER button will be enabled. 
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After the customer clicks PLACE ORDER, the order is created in Magento, and PayPal 

performs the related transaction(s). The complete billing and shipping addresses are 

saved in the order record in Magento.  

Order Transactions in PayPal Express 

Magento includes the option of using a new payment action, “Order,” for the PayPal 

Express Checkout payment method. When a store customer submits an order, 

having paid using the PayPal Express Checkout payment method, for which the 

Order payment action is set, the funds on the customer’s card are authorized. If the 

authorization times out before you capture all payment, the authorization is voided, 

and a new authorization and capture are conducted when you create an invoice. 

Only the amount equal to the invoice total is authorized and captured. The 

maximum number of these authorizations for one order, and the periods for which 

the first authorization and the order in general stay valid, depend on your PayPal 

merchant account settings. These parameters need to be specified in the Magento 

Admin Panel as well. Capturing can be done only from the Magento Admin Panel, 

by creating one or more invoices. 

Situations in which using the “Order” transaction may be appropriate include the 

following: 

 Back orders, in which available items are sent immediately, and the remaining part of the 

order is sent when available; this may include more than two shipments 

 Split orders, in which ordered items are sent in more than one shipment, perhaps to different 

addresses, and you want to collect a payment for each shipment 

 Drop shipments, which are shipments from other vendors for which you accept the payment 

Using the order payment action does not influence the checkout process for store 

customers. 
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Configuring the Payment Action for the PayPal Express Checkout 

To change the payment action settings for the PayPal Express Checkout 

payment method: 

1. In the Magento Admin Panel, select System > Configuration > SALES > PayPal. 

Configuration can be done either on the global or website level, so in the Current 

Configuration Scope drop-down list located in the upper left part of the page, leave 

Default Config or select the desired website. 

2. In the Express Checkout Settings field set, in the Payment Action drop-down menu, select Order. 

3. Configure these additional settings, which correspond to settings in your PayPal merchant 

account: 

 Authorization Honor Period (days): Defines how long the primary authorization stays valid. 

The value should be equal to the corresponding value in your 

PayPal merchant account. The default value in your PayPal merchant account 

is 3. To increase this number you need to contact PayPal. The authorization 

becomes invalid at 11:49 p.m., U.S. Pacific Time, of the last day. 

 Order Valid Period (days): Defines how long the order remains valid. When the order 

becomes invalid, you can no longer create invoices for it. Specify the value equal to the Order 

Valid Period value in your PayPal merchant account. The default value in your PayPal 

merchant account is 29. To change this number, you need to contact PayPal 

 Number of Child Authorizations: Defines the maximum number of authorizations for one 

order. That is, the maximum number of the online partial invoices you can create for one  

order. 

The number in this field should be equal to the corresponding setting in your 

PayPal merchant account. The default number of child authorizations in your 

PayPal account is 1. To increase this number, you need to contact PayPal. 

4. Click Save Config in the upper-right corner of the page to save the new configuration. 
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Managing Orders Paid Using PayPal Express Checkout with Payment 

Action Set to Order 

When the store customer submits the order, having paid using the PayPal Express 

Checkout payment method, for which the “Order” payment action is set, the order 

(with Processing status) is created in the Admin Panel. Two transactions are created for 

this order: one with type Order and one with type Authorization. See Figure 159. 

 

Figure 159. Order transaction for PayPal Express Checkout 

The funds on the customer’s account are put on hold, and you can capture the 

payment only from the Magento Admin Panel. To capture, you need to create an  

online invoice. Once you choose to create an online invoice, Magento determines 

whether the number of days passed from the first authorization exceeds the Order  

Valid Period value. If more days have passed, you cannot create an online invoice for 

this order. 

If the order is valid, Magento determines whether the first authorization is valid, 

comparing the number of days passed with the Authorization Honor Period value. If 

the authorization is valid, the necessary sum is captured; the rest is left on hold, and 

the number of captures is not limited. If the authorization is not valid anymore, it is 

voided. A new authorization and capture are created, but for the invoice total (not 

the order total). From this moment, each time you create an online invoice for this 

order, a new authorization and capture will be conducted only for invoices totals. 
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Also, Magento will determine whether the number of the conducted captures is equal 

to the Number of Child Authorizations value each time. If the number specified there is 

already reached, creating online invoices for the order will not be possible. 

If you click the Void button on the order view page, the Order transaction is voided. 

After this, no online invoice can be created for the order. 

Note: PayPal provides an option of capturing an amount larger than was ordered. 

However, this option is not supported in Magento. 

Other Payment Methods 

To define payments methods: 

1. In the Admin Panel, select System > Configuration > Payment Methods to display 

the Payment Methods page, as shown in Figure 160. 

 

Figure 160. Payment Methods 

A few payment options are described as follows. 

Saved Credit Cards 

202 



 Payment 

This option enables you to take credit cards and to process them offline. This 

method is useful when you have a card terminal in a brick and mortar store or 

have access to a virtual terminal. This payment method is enabled by default 

in the Sample Data. 

Tip: When using the Credit Cards payment method it is highly recommended to 

configure an SSL certificate for your web store. 

Note: Saving customer card data is discouraged unless absolutely necessary. Even 

though the data is encrypted it still poses a security risk to hold this information. 

To set up the Saved Credit Cards payment method: 

1. Select System > Configuration > Payment Methods to display the Payment Methods page. 

2. In the Current Configuration Scope drop-down list, select the scope for these configuration 

selections. 

3. Expand the Saved CC section to define credit cards, as shown in Figure 161. 
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Figure 161. Saved Credit Card Configuration Options 

4. Make your configuration selections. Most of these options are self-explanatory. The options that 

may need some explanation are as follows: 

 Request Card Security Code: Determines whether the payment method interface on the 

frontend requires the customer to supply the security code on the back of the card. If your 

credit card terminal requires the security code, set this option to Yes. 

 3D Secure Card Validation: Determines whether credit card validation is carried out using 

the 3D Secure system. You must be a 3D Secure system subscriber, and you must first set up 

the general 3D Secure configuration options in  System > Configuration > Payment Services. 
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5. Click Save Config to save your changes. 

This option appears in the web store as shown in Figure 162. 

Figure 162. Saved Credit Card Payment Method (Frontend) 

Customers who place an order in your web store and use the Saved Credit Card 

payment method see their card details as shown in Figure 163. 

 

Figure 163. Credit Card Information (Frontend) 

Tip: You can use the following test credit card number to test the payment 

methods in your web store: 

Visa 4111111111111111 

MasterCard 5555555555554444 

American Express 378282246310005 
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Use any expiration date in the future, and for the CVV/CVC/verification 

code, use 123 or 000. 

Checks and Money Orders 

This payment method enables you to accept paper checks and money orders as 

payment. The order remains in Pending status until the payment is received (or 

clears your bank, if you prefer). 

This payment method is enabled by default in the Sample Data. Expand the 

Check/Money Order section to define how checks and money orders are accepted in 

your web store, as shown in Figure 164. 
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Figure 164. Check/Money Order Configuration Options 

In the Make Check payable to field, specify the name of the entity to which the checks 

must be made out. 

This option appears in the web store as shown in Figure 165. 

Figure 165. Check/Money Order Payment Method (Frontend) 

Other Payment Methods 

There are numerous other payment methods available in the backend, and others 

can be obtained from Magento Connect 

(http://www.magentocommerce.com/magento  connect  )  .   

Most of the configuration options for these payment methods are similar to the 

options described in this chapter. Other configuration options are specific to each 

payment method, and you should consult the information you received when you 

subscribed to a given payment method to understand how these options work. 
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This chapter describes how to customize the look-and-feel of your web store by applying 

easy to use options that are provided in the Magento backend.  

Overview 

Magento provides a variety of simple-to-use design options that enable you to 

apply your own customized look-and-feel to your Magento web store with basic 

HTML knowledge. 

Tip: See http://www.magentocommerce.com/design_guide     for a description 

of how interfaces, themes, skins, layouts and blocks are used and to gain 

access to resources that will assist in their implementation. 

Terminology 

Following are some of the terms you should be familiar with when 

customizing the design of your store: 

Block: A Magento CE feature that modularizes page elements for easier 

management. 

Content block: Block that produces content, such as the content of a category  

list, mini cart, or product list. See also Structural block. 

Content Management System (CMS): A Magento CE feature that stores pages or 

parts of pages that you can use in your store. 

Layout: File that maps content blocks to structural blocks. More than one 

content block can be mapped to a single structural block. 
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Skin file: File that define the visual functional specifications of page elements, 

such as text, graphics, and the logic behind buttons and other controls. 

Structural block: Block created for the sole purpose of assigning visual 

structure to a store page; for example, header, footer, left column, main 

column. 

Template: A collection of XML and other files that define the block structure 

and logic for visual presentation. 

Theme: a collection of templates and skin files that control the visual 

elements of your store. These visual elements are applied to all pages in 

your store, giving your store a consistent look and feel throughout. 

Changing the Web Store’s Theme 

When you first install Magento CE, the design elements of your store are based on 

the Default Theme. You can modify this theme, add themes created by others, or 

create new themes from scratch. 

Tip: To design your own theme, see the Magento Designers Guide at 

http://www.magentocommerce.com/design_guide     

To add and activate a theme in your store: 

1. Go to the Magento Connect site (http://www.magentocommerce.com/magent  ‌     o  connect  )  . 

This site contains hundreds of extensions, which are add-ons to Magento software that can 

extend or enhance the look or functionality of your store. New ones are uploaded often. 

2. Click on the Core link to select one of the free extensions provided by Magento. The 

extensions are listed in the center of the page, as shown in Figure 166. 
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Figure 166. Magento Connect 

3. This example demonstrates the implementation of the Modern Theme. Scroll down the list 

of extensions and select the Modern Theme. 

4. Install the theme as you would any other Magento extension. See “Extending Magento,”  

page 256, for more information. 5. You can now activate this theme so that the web store 
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appears with a new layout. Select System > Configuration > Design and expand the Themes 

section. The Design page is displayed, as shown in Figure 167. 

 

Figure 167. Design Page 

Tip: The Add Exception option enables you to define special themes displayed 

for users using specific browsers. An example is showing an iPhone 

optimized theme for users using this device to browse the store. 

6. In the Default field, specify the name of the theme. In this example it is called Modern. 

7. Click the Save Config button on the top right of the page. The header, footer, menu bar, and 

background of the frontend now look different according to the new theme.  8. If your 

home page appears incorrect, it may be because the layout that you selected is suited to 

two columns when your home page has one column or vice versa. For the Modern theme, 

the following change must be applied so that that the frontend home page appears  

properly. From the top menu bar in the Admin Panel, select CMS > Pages to display the 

Manage Pages page, as shown in Figure 168. 

212 



 

 Manage Pages Page Figure 168.

 Design and Content 

This page shows two Home Page rows:  

 One row has the value 2 columns with right bar in its Layout column and its Status column 

shows Enabled. 

 The other row has the value 1 column in its Layout column and its Status column shows 

Disabled. 

9. Click on the first and second rows of the homepage. The page shown in Figure 

169 is displayed for each of them. 

 

Figure 169. Edit Page Page 

 Change the Enabled status of the page with 2 columns with right bar layout to Disabled.  
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 Change the Disabled status of the page with 1 column layout to Enabled. The homepage of 

the frontend now appears similar to the page shown in Figure 170. 

 

Figure 170. Frontend Home Page With New Theme 

Managing CMS Pages 

Content Management System (CMS) pages are static pages such as your Homepage, 

About Us and Customer Service pages that provide information about the web store 

and are managed through the Backend panel. CMS Pages are full pages that are 

available via their own URL addresses. Static Blocks are sections of code or graphics 

that can be referenced inside CMS pages as well as Category landing pages. They 

are page elements that can be reused and referenced throughout your site. 

The following example shows how to create a new page in Magento CE and then 

how to create a link to it from your store footer. 

To add a CMS page: 
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1. Select CMS > Pages to display the list of currently defined CMS pages as shown in Figure 

168. 

2. Click the Add New Page button on the top right of the page to display the New Page page, 

as shown in Figure 171. 

 

Figure 171. New Page Page 

3. In the Page Title field, specify the words to appear in the browser’s title bar. 

4. In the URL Key field, specify the unique identifier to be used in the URL. It must contain all  

lower case letters and no spaces. The following example uses our_history. 

5. Leave the default value in the Store View field.  

6. In the Status field, select Enabled. 

7. Click Content in the left navigation bar. Use the WYSIWIG editor to define the content for 

this page. 

8. Click Design in the left navigation bar to open the design options, as shown in Figure 172. 
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Figure 172. Custom Design Options 

9. Click the Layout field and then select one of the following options: 

 Empty: Shows the content of an empty page with no header, footer or side bars.  

 1 Column: Displays all the content entered in a single central column with a header and 

footer.  

 2 Columns with left/right bar: Displays all the content entered on the page with a header, 

footer and left/right bar.  
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 3 columns: Displays both the left and right columns from the design package with the 

content shown between. 

10.Click Save Page. You can now open a browser and browse to this Landing page. 

The URL is taken from the value that you specified for URL Key, as described 

above. For example: /our_history is added to the web store’s URL. 

11.The following steps show how to add a link to this page from the frontend’s footer. Select 

CMS > Static Blocks option to display the list of existing Static Blocks. 

12.Click on the Footer Links row to display the definition of the frontend’s footer.  

 

Figure 173. Editing a Static Block 
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13. In the Content field, use the WYSIWYG editor to add a link to the new page. You can do this 

by pressing ENTER after one of the existing links, typing the link text, selecting this text, and 

clicking the Link icon (  ). Use the Insert/Edit Link dialog box to specify the link attributes, 

as shown in Figure 174. 

 

Figure 174. Insert/Edit Link Dialog Box 

The footer of the frontend now appears as shown in Figure 175. 

 

Figure 175. Updated Footer Block 

Customizing Transactional Emails 

Transactional Emails are all emails sent from a Magento CE store. Magento CE offers 

flexible, easy-to-use functionality to enable you to customize these emails and 

translate them into multiple languages to best use them for communication with 

your customers. 
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This section describes how to modify the emails that are sent from the web store, for 

example, when an account is created or an order is placed. 

To customize a transactional email template: 

1. Select System > Transactional emails to display a list of the custom email templates created 

in this web store.  

Note: This page shows only customized emails. If this page is empty, it means 

that Magento will only send standard default emails. 

2. Click the Add New Template button to display the New Email Template page. 

 

Figure 176. New Email Template Page 
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3. In the Template field, select the name of one of the transactional emails that you want to 

customize, such as New account.  

4. In the Locale field, select the language. 

5. Click Load Template. 

6. In the Template Name field, specify a name for the customized email template. 

7. If desired, modify the Template Subject field. 

8. In the Template Content area, use the WYSIWIG editor to modify the content. You must 

change the contact phone number and email address as well as the logo image reference at 

the top of the page to reflect your own store information in all active templates.  

9. Click the Save Template button. 

10.Now that your customized email template is ready and available, the next step is to inform 

Magento CE that it should use this template to send email to customers instead of the 

default template. This is controlled in various configuration sections depending on the type 

of email.  

In our example of customizing a New Account email, select System > Configuration 

> Customers > Customer Configuration. Then expand the Create New Account 

Options section and select your newly customized transactional email in the 

Default Welcome Email field. 

Facebook Open Graph Extension 2.0 for 

Magento 
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The Facebook Open Graph 2.0 extension enables you to add custom social 

networking buttons to your store. The extension uses the new Facebook Open 

Graph 2.0 protocol.  

Compatibility 

The Facebook Open Graph 2.0 extension is compatible with Magento Enterprise 

Edition and Professional Edition 1.8 and later, and Magento Community Edition 1.3 

and later. 

Downloading and Installing 

The Facebook Open Graph 2.0 extension is free of charge; you can download it from 

Magento Connect  ,   the official marketplace for Magento extensions. 

Installing 

You can install the extension using the Magento Connect Manager. To access it in 

the Magento Admin Panel navigate to System > Magento Connect > Magento 

Connect Manager.  

Setting Up 

To make new social networking buttons appear in your store, after installing the 

extension you need to take two basic steps: 

1. Create an application on the Facebook Developers site  

2. Configure Magento 

In the following subsections these procedures are described in detail. 
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Creating an application on the Facebook Developers site 

The current implementation of the Facebook Open Graph 2.0 extension requires an 

application to be created manually on the Facebook Developers site. 

To create an application: 

1. Navigate to http://developers.facebook.com/     

2. Click Apps in the top menu  

3. Click Create New Application and perform all of the steps of the app creation wizard. Using 

the app by the Facebook Open Graph 2.0 extension implies  the following restrictions and  

requirements: 

• Please note, that the App Namespace value, which you set on the first step of the app 

creation, will be used in Magento configuration.  

In the left column select Settings > Basic. Under the Select how your app 

integrates with Facebook heading select Website. In the Site URL field enter 

your store address. See Figure 177. 

Important Note: Your website and store should have one domain name. 
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Figure 177. Website settings on Facebook Developers 

• For Action Types in the Advanced settings in the Graph API URL field enter own, want or 

other action you want to be associated with a social networking button on your product 

pages. This title is for internal use. See Figure 178. 
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Figure 178. Object Type settings in the Facebook Developers 

Application 

Note: You cannot set the “dislike” action as it is not supported by Facebook Open 

Graph 2.0. 

• The Object Type you create should have the following Object Properties: 

 URL (page URL) 

 Title (product title) 

 Image (image URL) 

 Description (product description) 

 Price 
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By default, a new Object Type has only the first four properties. To add the Price 

property, use the Add Another Property button on the Object Type page. See Figure 

179. 

 

Figure 179. Adding properties to an Object Type 

Configuring Magento 

To configure the Facebook Open Graph 2.0 extension settings in Magento Admin Panel: 

1. Navigate to System > Configuration > SOCIAL > Facebook. If you don’t see the SOCIAL heading 

in the left column, you may have not installed the extension. 

2. In the Current Configuration Scope drop-down list in the upper left corner of the page select 

your website. 

3. Under Facebook Config set the following: 

 Enable Facebook on Frontend: Select Yes if you want social buttons to appear on the frontend. 

 App Namespace: Enter the App Namespace value of your application. You can find it in the 

Basic Settings section of your app on the Facebook Developers site. See Figure 180 for 

illustration. 
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Figure 180. App Namespace value 

 App ID and App Secret: Specify the App ID and App Secret values of your application. You can 

find it in the Basic Settings section of your app on the Facebook Developers site. See Figure 

181.  

 

Figure 181. App ID and AP Secret values 

 Object Type – Enter the Open Graph Type value of your Object Type. To find it on the Facebook 

Developers site, open the settings of your application, navigate to Open Graph > Dashboard, 

click your object type, and expand the Advanced settings. On the page header the system will 

display the Apps > %Your Facebook Application Name% > Open Graph > Object Type: 

%Object name%. See Figure 182. 
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Figure 182. Open Graph Type setting 

 Actions Settings (can be different for each store view: To add and configure a social networking 

button, click Add Action Button. For each button, specify the following: 

o In the Action column, specify the internal button action title, for example, own or want. This 

value should correspond to the value you have specified 

in the Graph API URL field on the Facebook Developers site. The Graph 

API URL field is available in the Advanced section of the Action Type 

settings. See Figure 178. 

o In the Button Title column, specify the name of the social networking button as you want it 

to appear in the frontend. 

o In the Enable FriendBox column decide if you want to display in the frontend the related 

Facebook block, which contains the count and the pictures of friends.  

o In the Count in FriendBox column, set the maximum number of friends that can be displayed 

in the related Facebook block. By default, it is set to 3. If you set zero value (0) or leave the 

field empty, then the default value is applied. 
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1. To save the configuration, click Save Config in the upper right corner of the page. 

Now the social networking buttons you have created and the corresponding 

Facebook blocks will appear on the product pages of your web store. In the 

following section of this guide you can find the detailed description and illustrations 

of how these buttons look and work. 

Facebook Open Graph 2.0 Extension: Web Store Customer 

Experience 

When the Facebook Open Graph 2.0 extension is successfully installed and all 

configuration is done, the social networking buttons will be displayed on each product 

page in the frontend, along with the Facebook blocks providing the information about 

other Facebook users and friends who clicked your social networking buttons for the 

product (if set to be displayed). Information provided in the blocks depends on the 

customer who is logged in to Facebook and whether his or her friends have performed 

some actions with your app (that is clicked your social buttons). The following 

situations are possible (in this example, the Want and I own this social networking 

buttons were added): 
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1. ustomer is not logged in to Facebook. See Figure 183. 

 

Figure 183. Product page for a customer who is not logged in to 

Facebook 
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Customer is 

2. logged in to Facebook, but none of the customer’s friends wants or owns the 

product. See Figure 184. 

 

Figure 184. Product page  a customer who is logged in to 
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 Customer is 

Facebook, but none of his or her friends wants or owns the 

product 

  

3. logged in to Facebook, but he or she has not performed any action with the app yet. 

See Figure 185. 
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Customer is 
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 Customer is 

Figure 185. Product page for a customer, who is logged in to 

Facebook, but he or she has not performed any action with the 

app yet 

  

4. logged to Facebook, and his or her friends have already performed some action 

with the app. See Figure 186. 
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Customer is 

 

Figure 186. Product page for a customer, who is logged to 

Facebook, and his or her friends have already performed 

some action with the app 
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 Customer is 
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This chapter describes a variety of ways to promote your products.  

Overview 

Magento CE features a variety of ways to promote your products. These include 

options for presenting additional products in order to increase conversion rates and 

for providing various discounts and promotions. The possibilities are endless! 

Up-selling, Related Products, and Cross-selling 

Three types of product promotion selling options are provided in Magento CE: Up-sell 

products, Related products, and Cross-sell products.  

 Up-sell Products: When a customer views a product, the Up-sells for this product are items 

that your customer could buy instead of the product that is being viewed. These products 

may be of a better quality, more expensive, or more popular, or produce a higher profit 

margin. These products appear on the Product Information page.  

 Related Products: Related products appear in the Product Information page in the right 

column. Related products are meant to be purchased in addition to the item the customer is 

viewing.  

 Cross-sell Products: Products that are promoted in the shopping cart page right before 

checkout. When a customer navigates to the shopping cart (whether automatically after 

adding a product or otherwise), these products are offered as suggestions in addition to the 

products already in the shopping cart. They are similar to impulse buys, like magazines and 

candy at the cash registers in grocery stores.  

Up-Sells 
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 Promotions 

The up-sell products appear in the Product Information page under the Product 

Description, as shown in Figure 187. This example presents a more expensive 

keyboard and other products as up-sells to the less expensive keyboard. 

To add Up-sells to a product: 
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1. In the Admin Panel select Catalog > Manage Products to display a list of products, as shown 

in Figure 188.  

 

Figure 188. Manage Products Page 

2. Click the Edit link which appears on the right side of the row of the product for which you 

want to define Up-sells. The page shown in Figure 189 is displayed: 

 

Figure 189.  Edit Product Page 

3. Select the Up-sells tab in the panel on the left.  
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Figure 190. Products Selected as Up-Sell Products 

Tip: By default the list shows only products that were already selected as up-

sells. If there are none or you want to add other products, click the Reset 

Filter button to display a list of all the products. 

4. Use the check box in each row or the products that you want to appear as up-sells to this 

product.  

5. Click the Save button. 

Related Products 

Related Products are shown in the right column of your web store in a separate block. 

The example in Figure 191 shows a mouse product that was added as a Related 

Product for a keyboard purchase. 
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Figure 191. Related Item 

To add Related Products to a product: 

1. In the Admin Panel, select Catalog > Manage Products to display a list of products. 

2. Click the Edit link that appears on the right side of the row of the product for which you want 

to define Related Products. 

3. Select the Related Products tab in the panel on the left to display the Product Listing page.  

Tip: By default the list shows only products that were already selected as Related 

Products. If there are none or you want to add other products, click the 

Reset Filter button to display a list of all the products. 

4. Use the check box in each row of the products that you want to appear as Related Products to  

this product.  

5. Click the Save button. 

Cross-sells  

Cross-sell products are shown in a block below the shopping cart products, as shown 

in Figure 192. 
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Figure 192. Cross-Sell Item 

Cross-sell products are displayed after a product has already been added to the 

shopping cart. By default, three products are randomly selected by Magento CE from 

the products that have been defined as Cross-sell products of all the products in the  

shopping cart.  

To add Cross-sell products to a product: 

1. In the Admin Panel, select Catalog > Manage Products to display a list of products. 

2. Click the Edit link that appears on the right side of the row of the product for which you want 

to define Related Products. 

3. Select the Cross Sells tab in the panel on the left to display the Product Listing page.  

Tip: By default the list shows only products already selected as cross-sells. If 

there are none, or you want to add other products, click the Reset Filter 

button to display a list of all the products. 

4. Use the check box in each row of the products that you want to appear as Crosssells for this 

product.  

5. Click the Save button. 
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Catalog and Shopping Cart Price Rules 

There are two types of price rules in Magento CE: Catalog Price Rules and Shopping 

Cart Price Rules. Catalog Price Rules are applied to products before they are added to 

the shopping cart. Shopping Cart Price Rules are applied to products in the shopping 

cart.  

Catalog Price Rules  

Catalog Price Rules are applied to products before they are added to a shopping cart. 

They can be used to create sales and discounts that do not require that a discount 

code be supplied by the customer. The process of defining a Catalog Price Rule 

consists of three stages: 

• Defining the Catalog Price Rule Information, page 194, defines general information about the 

rule. 

• Defining the Catalog Price Rule Conditions, page 196, defines the conditions that trigger the 

rule. 

• Defining the Catalog Price Rule Actions, page 198, defines the actions that are executed when 

the conditions of this rule are met. 

Defining the Catalog Price Rule Information 

To create a Catalog Price Rule:  

1. From the Admin Panel, select Promotions > Catalog Price Rules > Add New Rule button to 

display the page shown in Figure 193. 
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Figure 193. Adding a New Catalog Price Rule 

2. In the Rule Name and the Description fields, specify a unique name and a description for this 

Catalog Price Rule.  

3. In the Status field, select Active. 

4. In the Websites field, select the website to which this rule applies. 

5. In the Customer Groups field, select one or more customer groups to which this rule applies.  
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6. In the From Date and To Date fields, set a date range for the rule to take effect. If you leave the 

date range empty, then the rule is enabled as soon as it is created.  

Advanced Tip: You can use the Priority field (1 is the highest priority) when there 

are multiple rules. This determines which rule takes effect when more than 

one Catalog Price Rule applies. 

Defining the Catalog Price Rule Conditions 

After you have set up the general information for the price rule, you must create the 

conditions that specify when the rule is triggered.  

The following example shows how to discount every T-shirt that is over $20 by 10%  

by defining a rule that has two conditions.  

To define Catalog Price Rule Conditions: 

1. Select the Conditions option in the panel on the left to display the page shown in Figure 194. 

 

Figure 194. Specifying Rule Conditions 

2. The first rule appears by default: If ALL these Conditions are TRUE. It specifies whether the 

rules that you define must all be met or if any of them can be met (AND or OR) in order to 

trigger the rule’s action. In our example, we wanted the discount to take effect when the 

product is a T-shirt and when the T-shirt costs over $20. Therefore, leave the word ALL in the 

page above. 

3. Click on the  icon to display a selection field and select the SKU option under Product 

Attributes from the dropdown menu. The page changes as shown in Figure 195. 
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Figure 195. Adding a SKU Condition 

4. Click on the is link to display the comparison operator drop-down list shown in Figure 196. 

 

Figure 196. Comparison Operator Drop-down list 

5. Select the is one of comparison operator. 

6. Click on the three dots to the right of the words is one of to display the value field, as shown in 

Figure 197. 

 

Figure 197. Value Field 

7. Click on the Chooser icon  to display a list of products from which you can select, as shown 

in Figure 198. 
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Figure 198. Item Selection 

The page above shows the list of products filtered to show only those that have 

the word Shirt in their name.  

8. Select the check boxes of the products (T-shirts in this example) to which this rule is to apply.  

9. Save this selection of products by clicking the Apply icon . 

10.Now this rule specifies that it applies to T-shirts. You must now add the Condition that the 

product must cost over $20 in order for the rule to apply. To do so, click on the  icon to 

display a selection field and select the Price option under Product Attributes from the drop-

down list.  

11.Click on the is link and select equals or greater than from the comparison operator drop-down 

list.  

12.Enter the value 20.00 in the value field on the right to create the second Condition, as shown 

in Figure 199. 
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Figure 199. Two Conditions Specified 

Defining the Catalog Price Rule Actions 

Now that the conditions have been defined that trigger this rule, we must define the 

actions to be taken when the conditions are met. The following defines that the price 

is discounted by 10%. 

To define Catalog Price Rule Actions: 

1. Select the Actions option in the panel on the left to display the page shown in Figure 200. 

 

Figure 200. Specifying Actions 

2. The Apply drop-down list enables you to define whether the discount that is specified in the 

Discount amount field is a percentage or a fixed amount of the price of this product. It also 

enables you to define whether the discount amount is subtracted from the original price (By) 

or whether the Discount amount field actually defines the final price (To). For our example, in 

the Apply field, select By Percentage of the original price. 

3. In the Discount Amount field, specify the value 10.00. This specification defines a final price 

that is a 10% reduction of the original price.  
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Note: Mistakenly selecting the To Percentage of the original price option would 

give a final price that is equal to 10% of the original price, meaning a 90% 

reduction. 

4. Select the Save Rule button to create the rule. 

5. You must also select either the Save and Apply or the Apply Rules button to immediately 

apply this discount to the selected products.  

Note: As you add new rules, the system must recalculate the prices and the 

priorities of the rules. Generally, system rules are automatically processed and 

applied each night. In order to apply a new rule immediately, you must select 

one of the Apply buttons. 

Shopping Cart Price Rules 

Shopping Cart Price Rules, as the name implies, are applied when a customer 

reaches the shopping cart. They can be applied either with or without the customer 

entering a coupon code, and include features not found in traditional coupon tools. 

This example defines a simple 10% discount coupon to be used for clogs when the 

shopping cart subtotal is over $100.  

The process of defining a Cart Price Rule consists of three stages: 

 Defining the Cart Price Rule Information, page 199, defines general information about this 

rule. 

 Defining the Cart Price Rule Conditions, page 201, defines the conditions that trigger the rule. 

 Defining the Cart Price Rule Actions, page 201, defines the actions that are executed when the 

conditions of this rule are met. 

Defining the Cart Price Rule Information 
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To create a Cart Price Rule:  

1. In the Admin Panel, select Promotions > Cart Price Rules > Add New Rule button to 

display the page shown in Figure 201. 
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Figure 201. Adding a New Shopping Cart Price Rule 

1. In the Rule Name field and the Description field, specify a unique name and a description for 

this Shopping Cart Price Rule.  

2. In the Status field, select Active. 

3. In the Website field, select the website to which this coupon applies. 

4. To specify that this rule only applies when a coupon code is used, select Specific Coupon in 

the Coupon drop-down list, and specify the code of the coupon that the customer must 

specify in the web store. 
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5. To specify that each customer can use this coupon only once, specify 1 in the Uses Per 

Customer field. 

Tip: If you want to create a limited offer, the coupon can be limited to be used a 

certain number of times by selecting Specific Coupon in the Coupon drop-

down list and specifying that number the Uses per coupon field. 

6. In the From Date and To Date fields, set a date range for the rule to take effect. If you leave the 

date range empty, then the rule is enabled as soon as it is created.  

Advanced Tip: You can use the Priority field (1 is the highest priority) when there 

are multiple rules. It determines which rule takes effect first when more than 

one Cart Price Rule applies. 

7. By default, an announcement of this shopping cart price rule is included in your store’s RSS 

feed. To suppress this announcement, select No in the Public in RSS Feed drop-down list. 

Defining the Cart Price Rule Conditions 

After you have set up the general information for the price rule, you create the 

Conditions that specify when the rule is triggered. The following example shows 

how to create a rule that has one condition, which checks when the shopping cart  

subtotal is over $100. 

To define Catalog Price Rule Conditions: 

Select the Conditions option in the panel on the left and define a rule with the single 

condition “Subtotal equals or greater than 100,” as shown in Figure 202. 
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Figure 202. Shopping Cart Price Rule Condition 

Defining the Cart Price Rule Actions 

Now that the condition has been defined that triggers this rule, you must define the 

actions to be taken. The following defines that 10% is reduced from the product’s 

original price. 

To define Cart Price Rule Actions: 

1. Select the Actions option in the panel on the left to display the page shown in Figure 203. 

 

Figure 203. Specifying Shopping Cart Price Rule Actions 

2. The Action tab has two important sections. The first one controls the discount. In the Apply 

field, select Percent of product price discount.  

3. In the Discount amount field, specify 10 to indicate that 10% is reduced from the product’s 

original price. 

Tip: Other options, not related to this example, are available, such as: Fixed 

amount discount, Fixed amount discount for whole shopping cart, and Buy 

X get Y free. 

4. In the Maximum Qty Discount is Applied to field, specify the maximum quantity of products to 

which this discount can be applied. If you enter 5 in this field, then the first five products of 
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this type purchased in the same shopping cart get the 10% discount and the sixth product of 

the same type does not get the discount. 

5. In the Discount Qty Step (Buy X) field, specify how often the discount is applied. This field is 

not relevant to our example, so leave this field empty. If you enter 8 here, then a 10% discount 

is applied to all the products after the eighth product is added to the shopping cart. If more 

than eight items are added to the shopping cart, the ninth through 15th products do not get 

the discount until the 16th product is added to the shopping cart, at which point the discount 

is 10% for all 16 products. This discount continues for every factor of eight. 

6. In the Free Shipping field, specify whether to combine the coupon amount with a free 

shipping offer, for only the products for which the coupon is valid or for the entire Order, 

when one of these products is in the shopping cart. This field is not relevant to our example,  

so leave the No value in this field.  

7. After defining the coupon as described above, select the products for which the coupon is 

valid. In our example, the coupon discount applies to clogs. Define a condition that applies to 

the SKU of clogs, as shown in Figure 204. 

 

Figure 204. Specifying Products to Apply the Discount To 

8. Click the Save Rule button.  

Example: Defining a Buy 2 Get 1 Free Promotion 

 253 



Promotions 

This section describes how to create another discount coupon with a Buy 2 get 1 free 

promotion. In this example, the web store is trying to push a digital camera as a family 

deal. This is a Shopping Cart Price rule. 

To define a Buy 2 get 1 free promotion: 

1. Define the Coupon Information, as described in “Shopping Cart Price Rules,” page 199, but 

leave the Coupon drop-down list selected to No Coupon. This selection specifies that the 

discount takes effect as soon as a customer adds the products to the shopping cart.  

 

Figure 205. Buy X get Y Free Promotion 

2. Do not define any conditions, because this rule is always applied to the Digital Camera. The 

deal is created for the Argus QC-2185 Quick Click 5MP Digital Camera available in the 

Magento Sample Data.  

3. Click the Actions tab in the left navigation bar. In the Apply field, select the Buy X get Y free 

option. 

4. In the Discount Amount field, specify 1. This is the number of units that are offered free. 
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5. In the Discount Qty Step field, specify 2. This is the number of units that must be purchased in 

order to receive the free unit. 

6. In the bottom section, set up the condition to specify the SKU of the item that is featured in  

this promotion 

7. Click the Save Rule button.  

You can now send out your marketing message telling customers that if they buy 

3 Argus QC-2185 Quick Click 5MP Digital Cameras one of them will be free.  

Tip: It is good practice to test the effect of these rules yourself before trying 

them out on the public. Either use a discount code that only you know or 

assign your test customer to a testing customer group and limit the cart 

rules to only that customer group. 

Auto-Generating Coupon Codes 

For shopping cart price rules, you can auto-generate batches of coupon codes and 

track their usage. 

Auto-Generating Coupon Codes Quick Reference 

Batches of discount coupon codes can be generated and managed on the Manage 

Coupon Codes tab of the Shopping Cart Price Rule page (Promotions > Shopping Cart 

Price Rules > %your rule%). To make the tab appear, in the Coupon field select 

Specific Coupon, select the Use Auto Generation check box, and click Save and 

Continue Edit. 

See Figure 206. 
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Figure 206. The Shopping Cart Price Rule page. Enabling the 

autogeneration of coupon codes. 

The default settings for the format of auto-generated coupon codes are configured 

under System > Configuration > Promotions > Auto Generated Specific Coupon 

Codes. 

 For detailed description of the auto-generation of coupon codes, see Auto-

Generating, Exporting, and Managing Coupon Codes, page 205. 

Configuring Coupon Codes Auto-Generation Settings 

You can set the default requirements for the coupon code format under System > 

Configuration > Promotions > Auto Generated Specific Coupon Codes. The following 

settings are available for configuring: 

 Code Length: Defines a coupon code length excluding prefix, suffix and separators. 
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 Code Format: Defines a coupon code format. The options are: Alphanumeric (a combination of 

letters and numbers), Alphabetical (letters only), Numeric (numbers only). 

 Code Prefix: Defines a value that will be appended to the beginning of all the coupon codes. If  

you do not want to use a prefix, leave this field blank. 

 Code Suffix: Defines a value that will be appended to the end of all codes. If you do not want 

to use a suffix, leave this field blank. 

 Dash Every X Characters: Defines the interval at which a dash (-) will be inserted in all coupon 

codes. If you do not want to use a dash, leave this field blank. 

Note: Coupons whose codes differ only by dash character(s) are considered to be 

different coupons. 

These settings can be overridden each time you need to generate a batch of coupons 

on the Shopping Cart Price Rule page. 

Auto-Generating, Exporting, and Managing Coupon 

Codes 

To generate and export a batch of coupon codes:  

1. Log in to the Magento Admin Panel. 

2. Navigate to Promotions > Shopping Cart Price Rules. 

3. Select an existing rule or create a new one. 

4. In the Coupon field select Specific Coupon. 

5. Select the Use Auto Generation check box. Perform other rule configurations, if necessary. 

Important Note: Shopping cart price rules with auto-generated coupon codes 

cannot be used in automated email reminders. If the shopping cart price rule 
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for which you set Specific Coupon in the Coupon field has been used in an 

automated email reminder rule, it will be automatically unassigned after 

saving the rule. 

6. Click Save and Continue Editing. The Manage Coupon Codes tab appears. See Figure 207. 

7. On the Manage Coupon Codes tab, specify the quantity of codes to be generated in the 

Coupon Qty field, correct the code format settings (if necessary) and click Generate. The 

generated coupon codes appear in the grid. For each coupon, you can see whether it has been 

used and how many times. To delete the coupon codes, select the check boxes in the first  

column, select Delete from the Actions drop-down menu, and click Submit. 

8. To export the codes, filter the list of codes so that only the desired codes are displayed, choose 

the file extension in the Export to field, click Export, and save the file.  

 

Figure 207. The Shopping Cart Price Rule page. Generating and 

managing coupon codes. 

Tracking the Usage of Coupon Codes 

Information about how often each coupon was used is displayed in the grid on the 

Manage Coupon Codes tab of the Shopping Cart Price Rule page. See Figure 207 
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above for illustration of the grid. You can also create detailed report about coupon 

usage in orders. 

To create a report about the usage of coupons generated for a specific 

shopping cart price rule: 

1. Navigate to Reports > Sales > Coupons. The Coupons Usage Report page opens. 

2. In the Show Report For field select the scope, configure report filters. In the Shopping Cart 

Price Rule field select Specified and select the desired rule(s). 

3. Click Show Report in the upper right corner of the page.  

Special Prices 

Special prices enable you to define a discounted price for a product for a specified 

period of time.  

To define Special Price: 

1. In the Admin Panel, select Catalog > Manage Products to display the list of products. 

2. Click the Edit link on the right side of the relevant product’s row. 

3. Click the Prices tab in the left navigation panel.  

 259 



Promotions 

 

Figure 208. Prices Options 

4. In the Special Price field, enter the special price.  

5. Optionally, set Special Price From / To Date. If you leave these fields blank, the special price is 

applied immediately and applies until removed on the same page. 

6. Click Save. 

The special price is shown on the frontend as shown in Figure 209. 
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Figure 209. Special Price – Frontend 

Tier Pricing 

Tier Pricing is a promotional tool that enables a web store owner to price products 

differently when higher quantities are purchased. This is an effective way to move 

more merchandise and appeal to customers who buy more than one product at a 

time. When a customer adds a certain quantity of a product to their shopping cart, 

the price is automatically changed to reflect the discount. 

To define Tier Pricing: 

1. In the Admin Panel, select Catalog > Manage Products to display the list of products. 

2. Click the Edit link on the right side of the relevant product’s row. 

3. Click the Prices tab in the left navigation panel.  

4. Add tiers by clicking the Add Tier button. You can create as many tiers as you need. 

 

Figure 210. Specifying Price Tiers 
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5. Click Save. 

Tip: To apply a tier to multiple groups, but not all groups, create multiple tiers, 

each with the same Qty and Price information and select a different 

customer group in each. 

The prices on the frontend take precedence from the highest to the lowest quantity. 

Therefore, if you have a tier for the quantity 5 and one for the quantity 10 and a 

customer adds 5, 6, 7, 8 or 9 items to the shopping cart, then the customer gets the  

discounted price that you specified for the quantity 5 tier. As soon as the customer 

adds the 10th item, the discounted price specified for the quantity 10 tier 

supersedes the quantity 5 tier and that discounted price (of 10) applies instead.  

After saving the product, it shows the Tier Pricing block on the frontend.  

 

Figure 211. Tier Pricing Block- Frontend 

On the product listing pages, the best available deal is displayed below the regular 

price, as shown in Figure 212. 
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Figure 212. “As Low As” Indication 

Minimum Advertised Price 

This section describes how a Minimum Advertised Price (MAP) policy can be applied in 

Magento CE. 

Minimum Advertised Price – General Concept 

If you have a minimum advertised price in the agreement with a manufacturer, you 

can still sell the merchandise at lower price, though this price will be hidden. It will 

not be visible to customers on the product page and will not be indexed by search 

engines. As a result, a price below the minimum advertised will not appear in any 

catalog of products collected from multiple web stores. The “crossed-out” price,  

which can be displayed on catalog and product pages, will be the manufacturer’s 

suggested retail price (MSRP). For storing the MSRP value, a new system attribute 

was added to the default attribute set. 
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An individual setting enables you to specify how the actual price is shown to 

customers: on clicking the Check for price link on a catalog or product page, when a 

product is added to the shopping cart, or before the order confirmation. 

The MAP functionality can be applied to all product types except gift card products, 

and bundle products with dynamic pricing. 

The MAP functionality only influences the way products prices are displayed on the 

frontend.  

The following terminology is used in reference to this feature: 

 Actual Price: The price that is specified in the Price of Special Price field on the product view 

page. 

 Manufacturer’s Suggested Retail Price (MSRP): The retail price as suggested by the 

manufacturer. The Actual Price is typically lower than MSRP. 

Minimum Advertised Price – a Quick View 

MAP can be enabled and configured under System > Configuration > Sales > 

Minimum Advertised Price. See Figure 213. 
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Figure 213. MAP global settings 

After MAP is enabled, the configuration on the product level becomes available with 

the Apply MAP, Display Actual Price, and Manufacturer’s Suggested Retail Price fields. 

See Figure 214. 

 

Figure 214. MAP settings on product level 
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When MAP is applied globally, all prices on the frontend are hidden; the Click for price 

links appear instead. If you specify the Manufacturer’s Suggested Retail Price (MSRP), 

it will appear crossed-out. See Figure 215. 

 

Figure 215. MAP is applied for the “Cuddle bear toy” and “Teddy 

bear toy” products. For the “Teddy bear toy,” the MSRP is 

specified, and it appears crossed out. 

The way the actual price is displayed depends on the Display Actual Price setting. The 

following options are available: 

 On Gesture (default value) - Clicking the Click for price link opens a pop-up window, 

containing the actual price and the information message. The actual price is shown on the last 

steps of the ordering process as well. See Figure 216. 
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Figure 216. For the “Teddy bear toy” the Display Actual Price is set 

to “On Gesture.” 

 In Cart - Clicking the Click for price link in a catalog redirects to the product page, where  

instead of the price or next to the crossed-out MSRP the following message is displayed: “To 

see product price, add this item to your cart. You can always remove it later.” The What’s this 

link is also included, which points to further explanations. The actual price of the product is 

displayed after it is added to the shopping cart. See Figure 217. 
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Figure 217. Product page on the fronted. Display Actual Price of 

the product is set to “In Cart.” 

 Before Order Confirmation - Clicking the Click for price link in a catalog redirects to the 

product page, where the following message is displayed instead of the price or next to the 

crossed-out MSRP: “See price before order confirmation.” The What’s this link points to further 

explanations. The actual price and totals are displayed on the Order Review step of the one-

page checkout, or on the order review pages of the Google checkout or PayPal checkout. See 

Figure 218. 
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Figure 218. Product page on the fronted. Display Actual Price of 

the product is set to “In Cart.” 

For products that allow configuration on the frontend, and whose prices depend on 

the variant selected (the variants themselves can actually be either custom options or  

simple products with their own SKUs and stock management), the following logic is 

implemented if MAP is applied: 

 MAP is applied to the main price; prices of the options, bundle items, and associated products  

(which add or subtract from the main price) are displayed normally. 

 If a product does not have a main price, and its price is derived from the associated products’ 

prices (such as in a grouped product), the MAP settings of the associated products are applied. 

Note that the MAP feature is not supported for bundled products with dynamic pricing. 

Regarding other price settings, the MAP application logic is the following: 

 If tier pricing is set, the tier price is displayed according to the Display Actual Price setting. 

 If a special price is set, it is considered to be the actual price for MAP. 
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In the order management and customer management tools, as well as in the reports 

sections of the Admin Panel, only the actual price appears.  

Setting Up MAP 

MAP functionality can be configured at both the global and product levels.  

On the global level, you can enable/disable the functionality, apply it to all products, 

define how the actual price is displayed, and edit the text of the MAP related 

messages and information tips on the frontend.  

When MAP is enabled globally, product-level MAP settings become available. For a 

product you can choose to apply MAP, specify the MSRP, and define how the actual 

price is displayed.  

Product-level MAP settings override the global ones. 

Setting up MAP on the global level 

By default the MAP functionality is disabled globally. 

To enable and configure MAP: 

1. In the Magento Admin Panel, select System, and click Configuration. 

2. In the Current Configuration Scope in the upper left corner of the page, select the desired 

website. 

3. In the left column under SALES, click Sales. 

4. On the Minimum Advertised Price field set configure the following settings: 

Option Description Scope 

Enable MAP Select Yes to enable the MAP. Websit
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e 

Apply MAP 

(Default 

Value) 

Applies MAP to all catalog products. 

If set to Yes, all prices in the catalog on the frontend 

are substituted with the Click for price links. On 

product pages, the prices are either substituted with 

the Click for price links or with the information about 

how to see prices, depending on the Display Actual  

Price setting.  

Websit

e 
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Display Actual 

Price 

Defines how the actual price is displayed on the 

frontend. Select from the following: 

On Gesture - Clicking the Click for price link opens a 

pop-up window, containing the actual price. On all 

other stages of the ordering process (in the shopping 

cart, on the order review) the actual price is displayed 

normally. 

In Cart - Clicking the Click for price link in a catalog 

redirects to the product page. On the product page, 

the price is replaced with the following message: “To 

see price, add this item to your cart. You can always 

remove it later". The What’s this link points to an 

information tip. The text of the information tip can be 

edited in the Default "What's This" Text Message field. 

The actual price is shown when customer 

adds the product to the shopping cart. It is 

also shown during the checkout as usual. 

Before Order Confirmation - Clicking the Click for price 

link in a catalog redirects to the product page. On the 

product page the price is replaced with the following 

message: “See price before order confirmation." The 

What’s this link points to the information tip.  

The actual price is displayed on the Order 

Review step of the one page checkout or on 

the order review pages of the Google 

checkout or PayPal checkout. In the 

shopping cart, neither the prices nor the 

subtotals are displayed. 

When there is at least one item in the 

Websit

e 
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shopping cart with Display Actual Price set to 

Before Order Confirmation, the order total is 

not shown in the cart. Instead, the message 

“Order total will be displayed before you 

submit the order” is shown. 

Option Description Scope 

The option selected defines how product prices are 

displayed in wishlists and comparison lists as well 

Default Pop-up 

Text 

Message 

The text field for editing the information message 

displayed if the Display Actual Price field is set to On 

Gesture. 

Store 

view 
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Default "What's 

This" Text Message 

The text field for editing the text of the What’s this 

information tip. 

Store 

view 

1. To save the configuration, click the Save Config button in the upper-right corner of the page. 

Setting Up MAP on the Product Level 

MAP settings on the product level become available once the MAP functionality is 

enabled.  

For gift cards and bundle products with dynamic pricing, the MAP settings are not 

available. 

To configure MAP settings on a product level: 

1. Select Catalog and click Manage Products. 

2. Open the product for editing. 

3. On the Prices tab, the following MAP settings are available: 

Option Description 

Apply MAP Defines whether MAP is applied to the product.  

Display 

Actual 

Price 

Defines how the actual price of the product is displayed on the 

frontend. The value here overrides the corresponding global setting.  

Manufacturer’

s 

Suggested 

Retail Price 

The price at which a manufacturer "suggests" to sell the product. If 

specified, it appears crossed-out on the catalog and product pages on 

the frontend. 

4. To save the settings click Save or Save and Continue. 
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Note: If a product added to the shopping cart has MSRP specified, it will not be 

displayed crossed-out in the mini shopping cart or in the shopping cart side 

block. 

How MAP Is Applied for Different Product Types 

The following describes how MAP is applied for different product types. 

Product type MAP implementation 

Simple, Virtual The actual price is not shown on the catalog and product pages; it 

is displayed according to the Display Actual Price setting. The  

custom 

Product type MAP implementation 

options prices are displayed normally. 

Grouped Prices of the associated simple products are not shown on the 

catalog and product pages; they are displayed according to their 

Display Actual Price setting. 

Configurable The actual price is not shown on the catalog and product pages; it 

is displayed according to the Display Actual Price setting. The  

prices of the options are displayed normally. 

Bundle with fixed 

price 

The actual price is not shown in the catalog; it is displayed 

according to the Display Actual Price setting. The prices of the 

bundle items are displayed normally. 

Downloadable The actual price is not shown on the catalog and product pages; it 

is displayed according to the Display Actual Price setting. The  

prices of the links are displayed normally. 

How MAP Is Applied for Different Price Settings 

The following describes how MAP is applied for different price settings. 

Price setting MAP implementation 
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Tier Price If tier pricing is set, the tier pricing message is not displayed in the 

catalog. On the product page a notification is displayed that 

indicates that the price can be lower when ordering more than a  

certain quantity, but the discount is displayed in percentages only. 

For associated products of a grouped product, the discounts are 

not displayed on the product page. 

The tier price is shown according to the Display Actual Price 

setting. 

Special Price If the Special price is specified, the special price is displayed 

according to the Display Actual Price setting. 

 

Product Group Price 

The Product Group Price feature enables you to set different product prices for 

different customer groups on the product level. The functionality is aimed at 

improving the admin user experience with setting promotional prices for customer 

groups.  

Terminology 

 Regular price: The value of the price system product attribute (which by default corresponds 

to the Price field on the Prices tab of the Product Information page available under Catalog > 

Manage Products > %desired product%). 

 Promotional price: A product price that is defined by any of the following system product 

attributes: special_price, group_price, or tier_price; or the resulting price after a catalog 

price rule is applied.  

Note: The group_price attribute is a system product attribute which was added 

for storing the group price value.  
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Setting a Group Price for a Product 

To set a group price for a catalog product: 

1. Log in to the Magento Admin Panel. 

2. Navigate to Catalog > Manage Products > %desired product%. The Product Information page 

opens. 

3. On the Prices tab in the Group Price field click Add Group Price. 

4. Select the target customer group and specify the price for the selected group. The Website 

column defines the scope of the Group Price field. 

Note: For bundle products, the group price is specified as a discount percentage.If 

bundle items have their own group prices set for the same customer group, 

then the discount specified for the whole bundle product is applied to these 

group prices. 

5. To save your changes, click Save or Save and Continue Edit.  

Group Price Implementation Details  

A group price can be specified for the following product types: 

 Simple 

 Configurable 

 Virtual 

 Bundle 

 Downloadable 

The list of product types for which a group price can be specified is defined in the 

settings of the group_price product attribute. The settings are available under 
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Catalog > Attributes > Manage Attributes > group_price. The list of product types, 

for which the attribute is used, can be configured in the Apply To field. 

Note: For the Grouped and Gift Card product types, the Group Price functionality 

will not be applied even if these product types are selected in the Apply To 

field of the group_price attribute.In this case, for Grouped products, the 

Group Price field will not even be displayed on the Product Infornation page 

in the Admin Panel. For Gift Card products, the Group Price field will be 

displayed, but its value will not be considered by the system. 

Displaying the group price in the frontend fits the general logic of price displaying in 

Magento. If besides the regular price, a product has promotional price(s), the lowest 

price value is displayed in the frontend. If a product custom option has price set as a 

percentage, than the lowest promotional price will be used as base for the 

calculation. The same logic is applied when the associated products (the options) of 

a configurable product have prices set as a percentage. 

The following table illustrates how the minimum promotional price logic is 

implemented. The table provides several examples, but it is not an exhaustive list of 

possible combinations.  

Backend Price Settings  Price Displayed in the Frontend 

Price = $4 

Special Price = $5 

Tier Price = $3 

For customers from the tier price group(s): 

$ 4  

As low as: $3 

For customers from other groups: 

$4 

Price = $5 

Special Price = $3 

Tier Price = $4 

For all customers: 

Regular Price: $5 

Special Price: $3 

278 



 Promotions 

Price = $5 

Special Price = $3 

Tier Price = $4 

Price after a catalog price rule applied = $2 

For customers from the catalog price rule 

group: 

Regular Price: $5 

Special Price: $2 

For customers from other groups: 

Regular Price: $5 

Special Price: $3 

 

Price = $5 

Special Price = $4 

Group Price = $3 

For customers from the price group: 

Regular Price: $5 

Special Price: $3  

For customers from other groups: 

Regular Price: $5 

Special Price: $4 

Important Note: When a group price is set for a product, then the catalog price 

rules for the corresponding customer groups are applied to the group price, 

not to the regular price. 

Newsletters  

Magento CE provides a Newsletter feature, which enables store administrators to 

send newsletters to customers who have registered to receive them. 

The first step in creating newsletters is to configure the newsletter settings for your  

site.  

To configure newsletter settings on your site: 

1. In the Admin Panel, select System > Configuration to display the configuration page. 
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2. In the CUSTOMERS area in the left navigation panel, select the Newsletter option and expand 

the Subscription Options area to display the page shown in Figure 219. 

 

Figure 219. Newsletter Subscription Options 

3. In the Need to Confirm field, select Yes to specify that each customer that registers for a 

newsletter will receive an email asking them to confirm their registration. This technique is 

called double opt-in, meaning that customers confirm that they want to receive a newsletter 

twice. This method reduces the number of customers that consider your newsletter as spam.  

Newsletter Templates 

 Before sending a newsletter, create a newsletter template. You can create and save 

as many of these as required for any situation, whether it be an annual holiday 

newsletter or weekly product updates.  

To create a new newsletter template: 

1. In the Admin Panel, select Newsletter > Newsletter Templates to display a page listing the 

previously defined newsletter templates. You can edit an existing template or create a new  

one. 

2. To add a new template, click the Add New Template button to display the New Newsletter 

Template page, as shown in Figure 219. 
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Figure 220. New Newsletter Template Page 

3. In the Template Name field, specify a unique and indicative name for this template. This value 

is not visible for customers.  

4. In the Template Subject field, specify the subject of the email to be sent to your customers. 

5. In the Sender Name and Sender Email fields, specify the name and email of the sender of the 

email to be sent to your customers. 

6. In the Template Content field, use the WYSIWIG editor to compose the body of the email. Note 

that this field is pre-filled with tags showing an unsubscribe link in the email. We recommend 

that you do not remove this link so that all emails that are sent enable your customers to 

unsubscribe from the newsletter. 

 281 



Promotions 

7. Click Preview Template, to display the content with the formatting as it will be viewed by your 

subscribers. 

8. After you have finished editing the template, click the Save Template button to save it. 

Tip: After you have saved a template, a Save As button appears when you edit 

this template. The Save As button enables you to duplicate the template, so 

that you can make changes and save the template as a new template 

without affecting the original template. This can save you time because you 

will not need to reenter all the template information in order to create a 

new template. If you already have an existing template that is similar to the 

new template, simply edit the fields that you require, and then use the Save 

As button to create a new template. 

Newsletter Queues 

A newsletter that has many recipients must be sent in stages. The process of sending 

the newsletter is managed by a queue. After you start this queue, Magento CE sends 

the emails in packs. 

To send your newsletter using a queue: 

1. In the Admin Panel, select Newsletter > Newsletter Templates to display a list of newsletter 

templates. 

2. In the Action drop-down list for the relevant template, select the Queue Newsletter option. 

3. In the Queue Date Start field, specify when the newsletter will start being sent. 

4. In the Subscribers From field, select one or more store views whose customers this newsletter 

will be sent to. 

5. Review the template and parameters and then click the Save Newsletter button to schedule 

sending the newsletter. 
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Tip: To ensure delivery of your newsletters, it is recommended that you 

integrate your Magento CE installation with a third-party newsletter 

provider. These services are “whitelisted” by email service providers. Look 

for newsletter providers in the Magento Connect website. 

Newsletter Reports 

Three newsletter reports are provided in the Newsletter menu:  

 Newsletter Queue: Shows the newsletter queues that have been defined and indicates their 

progress in sending emails. 

 Newsletter Subscribers: Shows a list of customers that have subscribed to your newsletter. It  

also enables you to unsubscribe these customers manually. 

 Newsletter Problem Reports: Shows a list of errors that have occurred while sending the email. 

This Report enables you to remove the incorrect emails from the subscribers list. 

 283 



15Managing Orders and Customers 

 This chapter describes how to manage customer records and how to add orders from the 

backend. 

Managing Customers 

Viewing and Editing Customers 

To view existing customers:  

1. In the Admin Panel, select Customers > Manage Customers to display the Manage 

Customers page, as shown in Figure 221. The Manage Customers page contains a list of all 

the customers that opened accounts in your web store or were added using the Add New 

Customer feature.  

 

Figure 221. Manage Customers Page 

2. Click the Edit link on the right side of a customer’s row to display the customer information 

page, as shown in Figure 222. 
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Figure 222. Customer Information Page 

The tabs in the left panel provide a variety of types of information about the 

customer and for handling the relationship with a customer, such as: when the 

customer last logged in and out, addresses, ordering statistics, recent orders, current 

shopping cart contents, their last reviews, the newsletter to which they subscribed 

and so on. 

Adding a Customer 

Customers typically register themselves in your web store using the My Account link 

in the header of each page. In addition, you can use the following procedure to add 

a customer using the backend. 

To add a new customer: 

1. In the Admin Panel, select Customers > Manage Customers. 

2. Click the Add New Customer button to display the New Customer page, as shown in Figure 

223. 
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Figure 223. New Customer Page 

This page enables you to define basic identifying information about the 

customer and his/her various addresses. Many aspects of the information 

retained about a customer in Magento CE can be accessed by editing the 

customer’s information, as described in “Viewing and Editing Customers,” page 

223.  

3. The fields on this page are self-explanatory. Specify the customer’s information and then 

click the Save Customer button.  

Managing Customer Groups 

The customer group to which the customer belongs determines which discounts are 

given to this customer, as defined in the Catalog Price Rules and Shopping Cart Price 

Rules (described in the “Catalog and Shopping Cart Price Rules,” page 193), and the 

tax rule that is applied to that customer. 

Managing Orders and Customers
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To create and edit customer groups: 

1. In the Admin Panel, select Customers > Customer Groups to open the Customer Groups 

page, as shown in Figure 224. 

 

Figure 224. Customer Groups Page 

2. Do one of the following: 

 To create a new customer group, click Add New Customer Group. 

 To edit an existing customer group, click the row for the desired group. 

The customer group editing page opens, as shown in Figure 225. 

 

Figure 225. New Customer Group Page 

3. Specify a unique name for this customer group (or modify the existing name). 

4. Select a tax class to associate with this group. 

5. Click Save Customer Group. 

Checking Online Customers 

You can check which customers are currently online and view their activity. 
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To view online customers: 

In the Admin Panel, select Customers > Online Customers to display the Online 

Customers page, as shown in Figure 226. 

 

Figure 226. Online Customers Page 

Customer Reports 

A variety of customer reports can be generated by selecting Reports > Customers in 

the Admin Panel. 

The following describes the available customer reports: 

 New Accounts: Shows the customers that have opened accounts in your web store during 

the period that you specify. 

 Customer by orders total: Lists customers in descending order of money spent in your web 

store. 

 Customer by number of orders: Lists customers in descending order of number of orders 

placed in your web store. 

Importing and Exporting Customer Information 

Another way to add customer records to Magento CE is by importing the data from a  

comma-separated values (CSV) file. The file that you upload must be in 

CommaSeparated Values (CSV) format. Most spreadsheet and database applications 

can read and create CSV files. This feature is convenient if you have existing  

customer information in another system and you want to bring it into Magento CE. 
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In order to import a CSV file into Magento CE, it must have certain characteristics. 

Specifically, each column heading must exactly match the Attribute Code for the 

attribute in that column. An easy way to get the correct column headings is to 

export the existing Magento CE customer data to a CSV file, then add or update the 

information to the CSV file before re-importing it into Magento CE. 

Exporting Customer Data 

To export customer information: 

1. In the Admin Panel, select System > Import/Export > Export. 

2. Select Customers from the Entity Type drop-down list. The system generates a list of entity 

attributes that are relevant to your customers. 

3. By default, all attributes are exported to the CSV file. In the Entity Attributes list, select the 

Skip check box for any attributes that you want to exclude from the CSV file. 

4. By default, all records are exported to the CSV file. Use the controls in the Filter column to 

limit the records that are exported. 

5. Click Continue to export your selected product information to a CSV file. 

6. Open the saved file in your favorite spreadsheet application and edit as needed. 
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Importing Customer Data 

With the Import feature, you can upload a file that contains the records for as many 

customers as you want. 

To import a customer CSV file: 
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1. In the Admin Panel, select System > Import/Export > Import to open the Import page. 

2. Select Customers from the Entity Type drop-down list.  

3. Select one of the Import Behavior options from the drop-down list: 

 Append Complex Data: Adds new or edited products to your store’s database. Magento CE 

will not create duplicate entries for existing products and customers included in your CSV 

file.  

 Replace Existing Complex Data: Completely replaces your existing data or portions thereof. 

 Delete Entities: Completely deletes your existing database or portions thereof. 

4. Click Browse and locate the CSV file in your local computer’s file system. 

Note The total size of the CSV file must not exceed the maximum size for your 

environment (typically 32 MB) and must be saved with UTF-8 encoding. 

Check your spreadsheet or database application documentation for 

information about saving a CSV file with UTF-8 encoding. 

5. Click Check Data to validate the uploaded file. 

6. If the uploaded file is valid, a “File is valid!” response appears. Import your products or 

customers by clicking Import. If your file contains errors, Magento CE notifies you of the 

errors and enables you to skip the erroneous rows and importing the valid products or 

customers by clicking Import. 

When the import is complete, the “Import was successfully done” message appears. 

Managing Orders 

The section “Managing Orders, page 62, introduces the procedures for handling the 

day-to-day order management tasks in your web store. This section assumes that 

you are familiar with that information. 
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See “Viewing the Orders in Your Web Store,” page 63 for a description of how to 

view and edit the Orders in your web store. This section goes into more details 

about the order life cycle in Magento CE. 

Orders Terminology 

 This section describes some of the terms used for handling orders in Magento CE. In 

addition to creating orders, there are many features in the Magento CE backend that  

are part of the process of managing and fulfilling orders, such as creating invoices, 

shipments, and credit memos, and editing and cancelling orders.  

Sales Order 

When an order is created in a Magento CE web store, either in the frontend or in the 

backend, a sales order record is created to record this transaction. This sales order 

can be seen in the orders list by selecting the Orders option from the Sales menu in 

the backend.  

This is only a temporary record. Payment has not yet been processed and the order 

can still be canceled.  

Invoice 

An invoice is a record of the receipt of payment for an order.  

Note: In some cases, payment is automatically received during the creation of an 

Invoice. 

Creating an invoice converts the temporary sales order into a permanent record of 

an Order, which can no longer be canceled. 

Multiple invoices can be created for a single order, each containing as much or as 

few of the purchased products that you specify.  
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Shipment 

A shipment is a record of the products in an order that have been shipped. As with 

invoices, multiple shipments can be associated with a single order, until all of the 

products in the order are shipped.  

Credit Memo 

A credit memo is a record of a refund. A product cannot be refunded until it has 

been paid (which means that it has been invoiced). This means that you are not able 

to create a credit memo before an invoice has been created.  

The credit memo serves as a record of a refund, but it is not a record of the actual 

return of funds to the customer.  

Creating New Orders 

This section describes how to create an order using the backend, such as when an 

order is received on the phone. 
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To create a new order from the backend: 

1. In the Admin Panel, select Sales > Orders. 

2. Click the Create New Order button on the top right of the page to display the Create New 

Order page, as shown in Figure 227. 

 

Figure 227. Create New Order Page 
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3. Select a customer If you have multiple websites, stores, or store views, select the one to  

which this order applies. The Create New Order for <customer> page opens, as shown in 

Figure 228. 

 

Figure 228. Create New Order for <customer> Page 

Note: If the customer does not already exist in your customer records, click 

Create New Customer on the first Create New Order page. You will need to 

complete all the address information. 

4. Click the Add Products button to display the list of products, as shown in Figure 229. 
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Figure 229. Product List for Creating Orders 

5. Use the check boxes to select the products to be purchased, and click the Add Selected 

Product(s) to Order button. 

Tip: If you selected one of the existing customers, then the left column shows a 

list of the products that this customer has in his/her cart, wish list, recently  

ordered, viewed, or compared. To add one those products to the order, 

select the required product and click Update Changes button. 

6. Complete the other mandatory fields of the order. Mandatory fields are marked by an 

asterisk (*). 

7. You can define many options for the order, such as choosing custom prices for products and 

applying discount codes. 

8. After you have completed all the required order information, click the Submit Order button 

to display the order information page. 

9. To confirm payment, click the Invoice button to generate an invoice for your review.  
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10.Review the invoice, and if all is well, click the Submit Invoice button at the bottom of the 

page. 

11.When you are ready to ship the products, click the Ship button to generate a Shipment  

document. 
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12. If applicable, you can add a tracking number received from the shipping service by clicking 

the Add Tracking Number button. Adding a tracking number enables customers to view the 

status of their shipment using the shipping carrier’s website. 

13.Review the shipment. You can modify the quantity to be shipped if only part of the order is 

ready.  

The order status changes to Completed after all its products have been shipped.  

14.Click the Email Copy of Shipment option to automatically send an email to notify the 

customer that the products were shipped. 

15.Click the Submit Shipment button at the bottom of the page.  

16.Click the Back button to return to the orders page, where you can create additional Orders if 

needed. 

Clearing the Shopping Cart 

If, at any time during the ordering process, the customer decides not to move  

forward with the order, you can clear the customer’s shopping cart in either of two  

ways: 

 Click the Clear Shopping Cart button on the Create New Order page (see Figure 230). 
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Figure 230. Clearing the Shopping Cart on the Create New Order 

Page 

 Click the Clear Shopping Cart button on the Shopping Cart page (Customers > Manage 

Customers > %customer% >Manage Shopping Cart); see Figure 231. 

 

Figure 231. Clearing the Shopping Cart on the Shopping Cart Page 

Refunding 

You can create a record of a product refund from an existing order by generating a 

credit memo.  

To view the list of refunds made in your web store: 

From the Sales menu, select the Credit Memos option to display the Credit Memos 

page, as shown in Figure 232. 
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Figure 232. Credit Memos Page 

To refund a product from an existing order: 

Note: You can create credit memos only for orders for which invoices were 

created. Without an invoice, an order is assumed not to be paid so that there 

is nothing to refund. 

1. In the Admin Panel, select Sales > Orders to display a list of the existing orders. 

2. Click the View link on the right side of the row of the desired order to display the order view 

page.  

3. Click the Credit Memo button to generate a credit memo.  

4. Scroll down to the Items to Refund area, and in the Qty to Refund field of each relevant 

product, specify the quantity of products to refund. 

5. To specify that this product was actually returned to the web store, select the Return to 

Stock check box, as shown in Figure 233. 
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Figure 233. Items to Refund 
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6. (Optional) Select the Email Copy of Credit Memo check box, as shown in Figure 234, to 

automatically send an email to the customer that the order has been refunded. You can also 

adjust the refund totals to match your business rules. 

 

Figure 234. Refund Totals 

7. Click the Refund button at the bottom of the page. The total of the order from which this  

product was refunded is updated automatically.  

8. Click the Back button to return to the orders page where you can create additional orders, if 

required. 

9. Note: Refunding an order in Magento CE does not cause an actual payment refund. You 

must refund the payment on your own. The credit memo is only a record used to track the 

refunds and to provide proper values in the reports. 
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16Managing Customer-Generated 

Content 

This chapter describes how to manage customer generated content, such as ratings, 

reviews, tags, and polls. 

Managing Ratings and Reviews 

Rating and review functionality is provided by Magento CE to enable customers 

and web store owners to give their opinions, feedback, and comments about 

products. 

Ratings and reviews appear in the frontend, as shown in Figure 235. 

Figure 235. Ratings and Reviews Links on the Frontend 

The quantity of stars indicates the satisfaction rating. You can click on the Review(s)  

link to display the actual reviews provided by customers or input your own Review, 

as shown in Figure 236.  
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Figure 236. Customer Reviews Frontend Interface 

Generated Content

To add a review, the customer clicks on the Add Your Review link on the product 

information page to open the Write Your Own Review page, as shown in Figure 

237. 
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Figure 237. Write Your Own Review Page (Frontend) 

Adding a Custom Rating 

By default, the customer can rate the quality, price, and value of a product. You 

might want to add custom ratings, to enable customers to rate such aspects as 

durability, warranty, and so on. This section describes how to create a new 

customized rating.  

1. In the Admin Panel, select Catalog > Reviews & Ratings > Manage Ratings to display the 

Manage Ratings page, as shown in Figure 238. 

 

Figure 238. Manage Ratings Page 

2. Click the Add New Rating button to display the New Rating page, as shown in Figure 239. 
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Figure 239. New Rating Page 

3. In the Default Value field enter a name for this rating.  

4. Click the Save Rating button. 

Approving Reviews for Public Viewing 

New reviews that are submitted by customers must be approved by the web store 

administrator in the backend before they appear on the frontend.  

To view and approve new reviews:  

1. In the Admin Panel, select Catalog > Reviews & Ratings > Customer Reviews > Pending 

Reviews to display the Pending Reviews page, as shown in Figure 240. 
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Figure 240. Pending Reviews Page 

2. Click the Edit link on the right side of the relevant review’s row to display the Review Details 

page, as shown in Figure 241. 

Generated Content

 

Figure 241. Review Details Page 

3. You can modify the review, if required. 

4. In the Status field, change the Pending status to Approved or Not Approved.  
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Managing Tags 

Tags can be assigned by customers directly in the frontend. A tag describes a 

specific property of a product, such as Cool, Valentine’s gift and so on. Popular Tags 

serve as a descriptor that customers can select in order to view the products to  

which a specific tag has been assigned. Figure 242 shows an example of various 

tags as they appear in the web store.  

 

Figure 242. Tags Display in the Frontend 

Adding Tags 

The number of tags that can be added to a product is unlimited and they can later 

be renamed or deleted. To add one or more tags to a product, the customer scrolls 

down on the product page to the Product Tags section, as shown in Figure 243. 

 

Figure 243. Adding Product Tags (Frontend) 
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Tags must be separated by spaces, and phrases (two or more words that comprise a 

single tag) must be enclosed in single quotation marks (‘).Figure 243 shows what it 

looks like when a customer adds three tags: 

 rock and roll 

 t-shirt  

 red 

After a customer submits product tags, an administrator has to approve them on 

the backend so that they will appear on the frontend. 

Approving Tags 

Tags must first be approved by the backend administrator before they appear on 

the front-end. After a tag has been approved by the backend administrator, it can 

be used for other products and does not need to be approved again. 

To approve a tag: 

1. In the Admin Panel, select Catalog > Tags > Pending Tags to display the Pending Tags page, 

as shown in Figure 244. 

 

Figure 244. Pending Tags Page 

Generated Content
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This page shows a list of tags that have not yet been approved.  

2. Use the check boxes in the left column to select all of the tags that you want to approve (or 

all of the tags that you want to disable). 

3. In the Action drop-down list, select Change Status. The Status drop-down list becomes 

visible. 

4. In the Status drop-down list, select Approve (or Disable). 

Note: To modify a tag or view details about a tag, such as the product or 

products it was applied to, or the name of the customer who submitted it, 

click the row for that tag. 

 

Note: If a customer has entered a tag that you do not want to ever see again, 

simply change the status to Disabled. 

Managing Polls 

Polls provide a powerful marketing tool for finding out the opinion of your 

customers about your products, store, customer service, or anything else.  

It is very simple to create a poll. Figure 245 shows an example of how a poll appears 

in the frontend. 
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Figure 245. Poll on the Frontend 

A poll occupies only a small amount of space on your store pages and is shown in 

the right column by default. Poll results are immediately displayed to the customer 

after the customer submits an answer, as shown in Figure 246. 

 

Figure 246. Poll Results 

To create a poll: 

1. In the Admin Panel, select CMS > Polls to open the Poll Manager page, which shows a list of 

existing polls. 

2. Click the Add New Poll button in the top right corner of the page to display the New Poll 

page, as shown in Figure 247. 

 

Figure 247. New Poll Page 

3. In the Poll Question field, enter the question that your customer will be asked. 
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4. In the Status field, specify whether the poll is Open or Closed. The status of the poll is Open 

by default, which means that it appears in your store. If you do not want it to appear in your 

store, select the Closed option. 

5. Select one or more stores that you want the poll to appear in. 

6. Click the Poll Answers option in the left panel to display Assigned Answers page. 

7. Click the Add New Answer button to add possible answers to your question that can be 

selected by customers, as shown in Figure 248. 

 

Figure 248. Assigned Answers Page 

8. In the Answer Title field, specify the text of the answer to appear in your store for customers 

to select.  

Generated Content

9. To influence the poll results in advance, you can add votes to the count in the Votes Count 

field, which is 0 by default. 

10.Repeat steps 7 through 9 for each answer that you want to appear in this poll. 

11.Click the Save Poll button. 
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Customers can answer a poll only once and you can view the results in the backend 

by clicking on the row for the poll in the Poll Manager page. If you have multiple 

polls open, they will cycle randomly in the frontend, meaning customer may see a 

different poll every time they refresh a frontend page. 

Editing a Poll 

After a poll has been created, you can edit it by clicking on the roll for the poll in the 

Poll Manager page (CMS > Polls).selecting the Poll Manager option from the CMS 

menu.  

To close the poll so that it no longer appears in the store, change the Status field to 

Closed in the Poll information section.  

To see the votes that have been tallied for each answer, click the Poll Answers  

option in the left panel to display the number of votes in the Vote Count field, as 

shown in Figure 249. 

 

Figure 249. Poll Results (Backend) 
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17Monitoring and Improving the Store

This chapter describes how to monitor and improve your web store by using reports, search 

terms, synonyms, redirects, and Google Analytics 

Reports 

This section describes some of the most important reports in Magento CE. This 

section first provides a full description of how to generate a Sales Report and a brief 

description of other important reports. 

Generating Reports 

Magento CE provides a variety of reports that you can access at any time. To see the 

reports that you can generate in Magento CE, from the Reports menu, select a type 

of report and then select a specific report of that type. 

Some report pages have filter controls that enable you to narrow the scope of the 

report, as shown in Figure 250. 

 

Figure 250. Report Filter Controls 

312 



 The Show Report For drop-down list enables you to select the store view or website (or all  

websites) to report on. 

 The Match Period To drop-down list enables you to select which records to report on, based 

on either the order creation date or the order modified date. 

 The Period drop-down list enables you to aggregate the report data into rows for each day, 

month, or year within your report From and To dates. 

 Use the From and To calendar controls to determine the start and end dates that will be 

covered by the report. 

 For Order Status, select Any to include all orders, or select Specified to select one or more 

order status values from a list. 

Monitoring and Improving the Web Store 

 The Empty Rows drop-down list enables you to select whether to include date period rows 

that have no data. 

 The Show Actual Values drop-down list enables you to select whether to display actual (Yes) 

or projected (No) values. Projected values are based on estimates of amounts to be paid. 

When you are finished making filter selections, click Show Report (or Refresh, in  

some reports) to generate the report. To export the report information shown on 

the screen, select the CSV (Comma Separated Values) option or the Excel XML 

option from the Export to drop-down list, and click Export. 

Refreshing Sales Report Statistics 

To reduce the performance impact of generating sales reports (those that are 

available under Reports > Sales), Magento CE calculates and stores the required 

statistics for each report. When you generate a report, the report uses the stored 

statistics, rather than recalculating the statistics each time you generate a report. 
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The sales report statistics need to be refreshed in order for the reports to use the 

most recent data. Refreshing the sales report statistics is a manual process. 

To refresh the Sales Report statistics: 

1. In the Admin Panel, select Reports > Refresh Statistics to open the Refresh Statistics page, as 

shown in Figure 251. 

 

Figure 251. Refresh Statistics Page 

2. Use the check boxes on the left to select the reports for which you want to have the statistics  

refreshed. 

3. In the Actions drop-down list, select the scope of the statistics to be refreshed: 

Refresh Lifetime Statistics or Refresh Statistics for the Last Day. 

4. Click Submit. 

Available Reports 

The following describes the reports that are available in Magento CE. 

Report Path Description 

Total Ordered Reports > Sales > Shows orders for the specified time period. 

Monitoring and Improving the Web Store 

Report Path Description 

Orders 

Order Taxes Reports > Sales > Tax Shows taxes charged for orders in the 
specified time period; grouped by tax rate. 
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Total Invoiced vs. 
Paid 

Reports > Sales > 
Invoiced 

Shows amounts paid and unpaid for invoiced 
orders in the specified time period. 

Total Shipped Reports > Sales > 
Shipping 

Shows orders shipped in the specified time 
period, grouped by carrier/method; includes 
shipping charge amounts. 

Total Refunded Reports > Sales > 
Refunds 

Shows refunds applied to orders in the 
specified time period. 

Coupons Usage Reports > Sales > 
Coupons 

Shows coupons used for orders in the 
specified time period, grouped by coupon 
code. 

PayPal 
Settlement 

Reports > Sales > 
PayPal Settlement 
Reports 

Shows PayPal settlements for the specified 
time period. Click Fetch Updates to retrieve 
data from PayPal. 

Products in Carts Reports > Shopping Shows products that are currently in Cart > 
Products in carts shopping carts. 

Abandoned Carts Reports > Shopping 
Cart > Abandoned Carts 

Shows shopping carts that were started but 
then abandoned. 
Tip: This report enables you to contact the 
customers and offer them discounts or 
otherwise turn an abandoned cart into a 
conversion. 

Products 
Bestsellers 

Reports > Products > 
Bestsellers 

Shows the products that were sold in the 
highest quantity in the specified time period. 

Products Ordered Reports > Products > 
Products Ordered 

Shows all products that were ordered in the 
specified time period. 

Most Viewed Reports > Products > 
Most Viewed 

Shows the products that were viewed the 
most times in the specified time period. 

Low Stock Reports > Products > 
Low Stock 

Shows the products whose stock levels are 
low. 

Downloads Reports > Products > 
Downloads 

Shows the number of purchases and 
downloads for each downloadable product. 

New Accounts Reports > Customers > 
New Accounts 

Shows the new accounts that were created 
during the specified time period. 

Customers by 
Orders Total 

Reports > Customers > 
Customers by orders 
total 

Shows the customers listed in descending 
order of total order amount. 

Customers by 
Number of 
Orders 

Reports > Customers > 
Customers by number of 
orders 

Shows the customers listed in descending 
order of number of orders placed. 

Customers 
Reviews 

Reports > Reviews > 
Customers Reviews 

Shows the customers listed in descending 
order of number of reviews contributed. 

Products Reviews Reports > Reviews > 
Products Reviews 

Shows the products listed in descending 
order of number of reviews. 

Customers Tags Reports > Tags > 
Customers 

Shows the customers listed with the number 
of tags each one has created. 

Products Tags Reports > Tags > 
Products 

Shows the number of unique tags and total 
number of tags created for each product. 

Popular Tags Reports > Tags > 
Popular 

Shows the number of times each tag has 
been applied. 

Search Terms Reports > Search Terms Shows the terms that were submitted in the 

Monitoring and Improving the Web Store

Report Path Description 
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search tool. 
Tip: If you see that the Hits field of a product 
shows a high number (meaning that 
customers search for it often), but the 
Results column shows a low number or zero, 
then you should review your product names 
and descriptions to promote products related 
to this keyword. 

 

Search Synonyms and Redirects 

The following shows you how to fine-tune Magento’s search behavior. Two mains 

options are provided: 

 Search Synonyms: Misspelled search terms may mean missed opportunities for you. If you 

know that a frequently used search term is often misspelled by customers, and thus does 

not display results, you can add additional search terms.  

 Redirects: You can specify that when a customer searches for a certain term that they are re-

directed to a specific page. Direct customers to a specific product page, a specific brand 

landing page, or an informational page. For example, the search term “Returns” can take 

customers directly to the Shipping Policy page.  

The following example demonstrates how to add the misspelled search term “latop” 

so that the results are returned for the correct term, “laptop.” 

To add new search synonym and or redirection: 

1. In the Admin Panel, select Catalog > Search Terms to display the Search page, as shown in 

Figure 252. 
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Figure 252. Search Page 
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2. Click the Add New Search Term button to display the New Search page, as shown in Figure  

253. 

 

Figure 253. New Search Page 

3. In the Search Query field, specify the incorrect spelling of the term (“latop” in this example). 

4. In the Synonym For field, specify the correct search term that is defined in your web store 

(“laptop” in this example). 

5. In the Redirect URL field, specify the URL to which the customer is redirected when no 

results are returned for the search term. 

6. Click the Save Search button. 
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Google Analytics 

Google Analytics is a free service provided by Google to help website owners find 

out more about the traffic on their website and about conversions. Magento CE 

supports both the following Google Analytics options: 

 Page View Tracking: Enables you to see the origin from which your web store visitors linked 

to your store.  

 E-commerce Tracking: Enables you to see which customers make purchases and what they 

buy. 

You can sign up to this service at https://www.google.com/analytics  .   While signing 

up, a report is displayed showing your new Google Analytics account number in 

the following format: UA-XXXXXXX-1. Write this number down, because it is 

required for configuring Google Analytics in Magento CE.  

To add Google Analytics tracking to Magento: 

1. In the Admin Panel, select System > Configuration > Google API 

2. Expand the Google Analytics section as shown in Figure 254. 
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Figure 254. Google Analytics Options 

3. In the Enable field, select Yes. 
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4. In the Account number field, specify the Google Analytics account number that you wrote  

down when you signed up for the service. 

Tip: Magento supports native integration with Google Website Optimizer, which 

is another free service from Google that enables you to test different 

versions of page elements and to select the elements that provide the best 

conversion rates. 
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18Keeping Your Store Healthy 

Now that you have your own web store running and are selling products, do not forget to 

keep it in good condition. Make sure that your hosting provider performs regular file and 

database backups  

Backups and Rollbacks 

Magento CE enables you to perform different types of backups (backup of database, 

file system, or both) and to perform rollbacks automatically. 

Backup and Rollback Quick Reference 

The main tasks related to creating backups and restoring the system are performed 

in the Magento Admin Panel under System > Tools > Backups. 

Files are compressed using the .gz and .tgz formats. Backup files are stored in the 

var/backups directory in your Magento file system. The content of the 

/var/cache, /var/log, /var/session and /var/report folders is excluded 

from the backup. 

Creating and Managing Backups 

To create a backup: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Tools > Backups. 

3. Click one of the following buttons, depending on the backup type you need to create: 
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 System Backup: Creates a complete backup of the database and the file system. On the next 

step you will have the possibility to choose whether to include the media folder to the 

backup. 

 Database and Media Backup: Creates a backup of the database and the media folder. 

 Database Backup: Creates a backup of the database. 

4. The confirmation dialog box appears. If you agree to put the store into the maintenance 

mode for the time of backup creation, select the corresponding check box. After the backup 

creation is completed, the maintenance mode is turned off automatically. If you are creating 

a system backup, select the Include Media folder to System Backup check box if you want to 

include the media folder. Confirm the backup creation. 

Database backup files are compressed using the .gz format. For the system backups 

and database and media backups, the .tgz format is used. Backup files are stored in 

the var/backups directory in your Magento file system. The files that are stored in 

the 

/var/cache, /var/log, /var/session and /var/report folders are excluded 

from the backup. 

Records about all created backups are listed in a grid on the Backups page. Deleting 

a record deletes the archive file as well. 

Rolling Back the System 

To roll back the whole system or the database: 

1. In the Magento Admin Panel, navigate to System > Tools > Backups 2. The 

Backups page opens, where all previously created backups are listed in a grid. For 

the desired backup, click the Rollback link in the Action column. Note that all 

changes made since the backup creation will be lost after the rollback. 
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3. Confirm rolling back, specify your Magento Admin Panel account password, and choose 

whether you want to put your store into the maintenance mode for the time of rolling back.  

When restoring file system or database and media files you can choose to use the FTP 

connection. 

4. After the rollback, you are redirected to the login page to log in to the Admin Panel. 

5. Refresh cache types and rebuild required indexes. This can be done under System > Cache 

Management and System > Index Management, respectively. 

Important note: Use the Rollback functionality with caution. Ccustomers who 

are in the process of checking out when you start the rollback may not be 

able to complete the checkout. 
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19 Indexing 

Indexing is how Magento transforms data such as products, categories, and so on, to 

improve the performance of your web store. As data changes, the transformed data must be 

updated—or 

reindexed. Magento has very sophisticated architecture that stores merchant data (including 

catalog data, prices, users, stores, and so on) in many database tables. To optimize storefront 

performance, Magento accumulates data into special tables using indexers. 

For example, suppose you change the price of an item from $4.99 to $3.99. Magento must 

reindex the price change to display it on your web store. 

Without indexing, Magento would have to calculate the price of every product on the fly— 

taking into account shopping cart price rules, bundle pricing, discounts, tier pricing, and so 

on. Loading the price for a product would take a long time, possibly resulting in cart 

abandonment. 

Index Management Page 

The Index Management page enables you to perform actions on the various indexes  

that Magento maintains. To access the Index Management page, click System > 

Index Management. 

 

Figure 263. Index Management Page 
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The page is presented differently If you enabled flat catalog product options. For 

more information, see “Using Flat Catalog and Product Reindexing,” page 271. 

The following figure shows an example of the Index Management page with the flat 

catalog product options enabled.  

 

Figure 264. Index Management Page with Flat Data Indexing Enabled 

Understanding the Columns on the Index Management 

Page 

The following table describes the columns on the Index Management page: 

Column Name Description 

Index Name of the indexer 

Description Description of the indexer 

Mode In the preceding figures, most of the indicated indexers are set to  

Update on Save, which means a reindex is required when a change is 

saved in the Admin Panel. To change this option, see “How to Reindex 

Manually,” below. 

Status Displays one of the following: 

Reindex Required if a change has been made that requires reindexing. 

If a check box and Reindex Required link appears in that row, you can 

manually reindex as discussed in”How to Reindex Manually,” below. 

Ready if the index is up-to-date. 
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Update Required Indicates whether or not you must manually reindex. (The value in the 

Mode column indicates whether the indexer must be manually 

updated.) 

Updated At Displays the date and time an index was last manually updated, or 

Never if the index has never been manually updated. 

Action Displays a Reindex Data link. Click the link to reindex that option only. 

How to Reindex Manually 

For the indexers that require manual updates, you have the following options on this 

page. 

The indexers that require manual updates display with a check box next to their 

name (Product Attributes, Tag Aggregation Data, and, optionally, Catalog Search 

Index). 

Task Steps 

Manually reindex To manually update one or more indexers: 

To update more than one indexer at a time, select the check box next 

to its name. From the Action list, click Reindex Data and click Submit. 

To update one index only, click the Reindex Data link in the Action  

column on the right. 

Change the 

indexing mode 

By default, indexers that require manual updating are set to Update on 

Save which means reindexing occurs after a change is made in the 

Admin Panel. 

The other option is to manually reindex every time a change is made. 

(For example, if you change product attributes in the Admin Panel, you  

must 

Task Steps 
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manually update the Product Attributes index.) 

To change the indexing mode: 

1. Select the check box next to one or more indexers to change. 

2. From the Actions list, click Change Index Mode. This displays the Index 

Mode list. 

3. From the Index Mode list, click the desired option. 

4. Click Submit. The value in the Mode column updates to indicate your  

choice. 

Using URL Rewrites 

URL rewriting (sometimes referred to as request rewriting) enables you to access  

resources such as product pages, categories, and so on, by additional uniform 

resource identifiers (URIs). 

For example, suppose your web store has a product named Microsoft Natural 

Ergonomic Keyboard 4000 assigned to the Computer Peripherals category. By 

default, the product can be accessed using a URL like 

http://www.example.com/peripherals/microsoft-natural-ergonomic-

keyboard-4000.html. URL redirect enables you to create an additional URL like 

http://www.example.com/great-keyboard.html. 

Using URL rewriting, you can choose a combination of: 

 Custom, category, or product URL rewrite type 

 Request path, which can be any valid URI (for example, for a seasonal promotion, you might 

want a product URL to end with best-valentinesgift.html) 

 Target path, which specifies the actual path to the product or category (for example, for a 

promotion, you might want a category named spring-sale) 
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Note: The custom and target path options enable you to redirect to a custom  

path, such as a Content Management System (CMS) path. The target path 

must be valid; otherwise, the redirect results in a 404 (Not Found) error on 

your web store. 

 Redirect type (determines how search engines rank the redirect) o None (useful if you 

don't want the customer to have to wait the additional time required to redirect) 

o Temporary (HTTP 302 (Found)) o 

Permanent (HTTP 301 (Moved 

Permanently)) Note: Magento recommends 

choosing a permanent redirect because search 

engines generally preserve the page's ranking. 

A 302 (Temporary) redirect does not preserve a 

page's ranking. For more information, consult a 

resource such as seomoz.org     or google.com  .    

Sample URL Rewrites 

Magento CE enables you to create redirects to add additional URLs for items. You can  

do this, for example, to make items more attractive to buyers. You can create a 

redirect to any valid path, including paths you create in your CMS. 

For example, you can change the following product URL: 

http://www.example.com/peripherals/microsoft-naturalergonomic-keyboard-

4000.html 

and add another one such as: 

http://www.example.com/best-keyboard.html 
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or you can create another URL for a category like: 

http://www.example.com/all-on-sale.html 

To create a category path like the following for a promotion, you must first create a 

path using the CMS or by other means. 

http://www.example.com/save-now/spring-sale 

URL Rewrite Option: Setting Category and Product URL 

Suffixes 

By default, Magento enables web store customers to access products and categories  

with a URL that ends with .html. You can optionally change both the product and  

category URL suffix to any alphanumeric string. 

The examples throughout this section use the default suffix, .html. 

To optionally change the product and category URLs: 

1. Log in to the Admin Panel as an administrator. 

2. Click System > Configuration. 

3. In the CATALOG group, click Catalog. 

4. In the right pane, expand Search Engine Optimizations. 

5. Enter valid values in the Product URL Suffix and Category URL Suffix fields. 

6. Valid values are alphanumeric characters (a-z, A-Z, 0-9) or the underscore character 

(_). 

7. Click Save Config at the top of the page. 

Getting Started with URL Rewrites 
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To get started: 

1. Log in to the Admin Panel as an administrator. 

2. Click Catalog > URL Redirects. The following figure shows a sample URL Redirect 

Management page. 

 

Figure 265. URL Redirect Management Page 

The preceding figure shows the following sample URL rewrites that are created for 

the Magento sample data. 

The following table discusses the meanings of the columns on this page. 

Column  Description 

ID  A unique identifier Magento assigns to the URL rewrite. 

Store View Name of the store with which the URL rewrite is associated. 

Type Typically displays either System (system, or Magento default, URL 

rewrites) or Custom) URL rewrites you configure. 

ID Path The system, or actual, URI of the product or category. 

Request Path  The unique part of the URI for that redirect. The request path can 

be any URL-encoded string. For example, great-

valentinesgift.html. 

Target Path  The URI that identifies the product, category, CMS page, and so  

on. The target path you enter must be valid; otherwise, the 

redirect fails with a 404 (Not Found). 
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Options  Displays one of the following: 

R if you chose a temporary (HTTP 302) redirect. 

RP if you chose a permanent (HTTP 301) redirect. 

Nothing if you chose to not redirect. 

Action  Click Edit in this column to edit or delete the redirect. (You can 

also click the row itself.) 

Creating New URL Rewrites 

This section discusses how to create new custom, product, or category URL redirects. 

1. Complete the tasks discussed in “Getting Started with URL Rewrites,” page 267. 

2. Click Add URL Rewrite. 

3. From the Create URL Rewrite list, click one of the following: 

Option  Description 

For Category Redirect to a category page. Magento system category paths use the 

format catalog/category/view/id/category-string 

You can optionally redirect to a custom CMS path if you have already 

set one up. 

For Product Redirect to a product page. Magento system product paths use the 

format 

catalog/product/view/id/string or catalog/product/ 

view/id/product-string/category/category-string 

You can optionally redirect to a custom CMS path if you have already 

set one up. 

Custom  Redirect to any valid path. To use this option, you must know the exact 

request and target path. 

The bottom section of the page refreshes to reflect the choices available for the 

type of URL rewrite you selected. 
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4. Do any of the following: 

o Custom redirect: Enter the required information. For more information, see 

step 6. 

o Category redirect: Click the name of the category. o Product redirect: 

Click the name of the product. 

5. For product redirect only: Optionally click the name of a category, or click Skip choosing  

category to let the product remain associated with its original category. You need to click a  

category name only if you want the URL redirect to go to a different category. 

6. Enter the following information: 

Option Description 

Type Usually displays Custom. 

Store From the list, click the name of the store to which the URL rewrite applies. 

Request 

Path 

Enter a unique path to identify the product or category. The path can be in any 

format that uses URL percent encoding. Examples: 

best-valentines-gift.html 

greatest-keyboard.html 

products-on-sale.html 

best/products/on/sale/now.html 

Option Description 
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Target 

Path 

Enter a request path in one of the following formats: 

Custom redirect: Any valid path. 

Category redirect: 

System path: Unless you set up a custom path using the CMS, you should leave 

this field unchanged. By default, system category paths have a format like: 

catalog/category/view/id/categorystring o 

Custom path: Any valid path  Product redirect: 

System path: Unless you set up a custom path using the CMS, you should leave 

this field unchanged. By default, system category paths have a format like: 

catalog/product/view/id/string or 

catalog/product/view/id/productstring/category/cate

gory-string 

Custom path: Any valid path 

Redirect 

type 

From the list, click: 

No 

Temporary (302) 

Permanent (301). Magento recommends choosing this option because search 

engines retain the page ranking. 

Descript

ion  

Enter an optional description. 

 

1. At the top right corner of the page, click Save. 

The following figure shows a sample product permanent redirect that adds 

the URL http://www.example.com/greatest-keyboard.html to the English web 

site for a product whose ID is 159. 
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Figure 266. URL Redirect Information 

Verifying URL Rewrites 

This section discusses how to verify that a sample product URL rewrite is displayed 

correctly on your Magento web store. 

1. In the Admin Panel, click System > Index Management. 

2. Click Select All at the top of the left column. 

3. From the Actions list, click Reindex Data. 

4. Click Submit. The following figure shows an example.

 

Figure 267. Verifying Product URL Redirect 

5. Click Catalog > URL Rewrite Management. To open the URL Rewrite Management page. 

6. Click a row corresponding to a product redirect. The following figure shows the example 

used in this section. 
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7. Open a new browser window or tab page. 

8. In the browser's location or address field, construct the URL to the product as follows: 

o Start with the scheme (http:// or https://, then your web store's domain name, followed by /. 

o Append to it the value of the Target Path field from the Admin Panel, followed by /. 

o Append to it the value of the Request Path field. 

For a Magento web store whose domain is http://www.example.com, the URL should 

look like the following: 

http://www.example.com/sale-keyboard.html 

1. Press ENTER. The following figure shows an example of a successful redirect. 
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Figure 268. Successful Redirect 

Note: If a 404 (Not Found) error appears, verify the target path precedes the 

request path and that each path is separated by one / character. 

2. Optionally verify category and custom redirects the same way. 

Editing or Deleting URL Rewrites 

To edit or delete a URL rewrite: 

1. Log in to the Admin Panel as an administrator. 

2. Click Catalog > URL Rewrites. The URL Rewrite Management page opens. 

3. Click the row of the URL redirect to edit or delete. To edit a URL redirect, you can also click 

Edit in the Action column. 

4. To delete the URL redirect, click Delete. You are required to confirm the action. To edit a 

redirect, edit or change the information displayed on your screen. For additional information, 

see “Creating New URL Rewrites,” page 268. 

Using Flat Catalog and Product Reindexing 

Magento uses the Entity-Attribute-Value (EAV) model for storing customer,  

product, and category data in its database. Although the EAV model enables 

you to have completely extensible attributes for those objects, object 

attributes are stored in multiple tables rather than one very large table. 

Because attributes are stored in many tables—and that includes copies of 

some of the same attributes—SQL queries are long and complex. The flat 

catalog feature creates new tables on the fly, where each row contains all 

necessary data about a product or category. 
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Flat Catalog Prerequisite: Enabling Frontend Options 

To enable flat catalog and product indexing: 

1. Log in to the Admin Panel as an administrator. 

2. Click System > Configuration. 

3. In the CATALOG group, click Catalog. 

4. In the right pane, click Frontend. 

5. From the Use Flat Catalog Category list, click Yes. 

6. From the Use Flat Catalog Product list, click Yes. The following figure shows an example. 

 

Figure 269. Flat Index Frontend Options 

7. In the upper right corner, click Save Config. 
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Verifying the Results of the Flat Catalog Configuration 

This section discusses examples of both changes to individual products and 

changes to multiple products and categories at the same time. 

Note: Magento recommends performing the tasks discussed in this section in a 

development environment first. 

Verifying Flat Catalog Changes for a Single Product 

To verify flat catalog changes for one product: 

1. Log in to the Admin Panel as an administrator. 

2. In a different browser tab page or window, open your web store's front page. 

3. In the Admin Panel, click Catalog > Manage Products. 

4. Choose a product to modify.This example uses the Nokia 2610 Phone. 

5. Click the name of the product to edit it. 

6. Click the General tab. 

7. Append _DEMO to the value in the Name field. The following figure shows an example. 
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Figure 270. Changing an Attribute Value 

8. Click Save. 

9. View your web store. 

10.Search for the product you edited or browse to the category that contains it. 

11. If necessary, refresh the page to see the result of the change you made. The following figure 

shows an example. 
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Figure 271. Product Page Showing Updated Attribute 

Verifying Flat Catalog Changes for Multiple Products 

To verify flat catalog changes for multiple products: 

1. Log in to the Admin Panel as an administrator. 

2. In a different browser tab page or window, open your web store's front page. 

3. In the Admin Panel, click Catalog > Manage Categories. 

4. From the Choose Store View list, click the name of a store to view categories for that store. 

(You can also click All Store Views). 

5. In the left pane, click the name of an existing category. 

6. Click Add Subcategory. 
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7. In the Name field, specify Demo category. 

8. From the Is active list, click Yes. 

9. Click Save Category. 

10.Click the Category Products tab. 

11.Click Reset Filter to display your products. 

12.Select the check box of several products to add them to the new category. The following 

figure shows an example. 

 

Figure 272. Demo Category 

13.Click Save Category. 

14.View your web store. 
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15.Search for or browse to the category you created. 

16. If necessary, refresh the page to see the changes you made. The following figure shows an 

example of adding several products to a subcategory of Electronics. 
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Figure 273. Category Page 
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20Getting Help 

Magento CE offers a variety of options and possibilities, but also has a learning curve. 

Magento provides several resources for getting help discovering Magento CE and using it 

daily to attain your eCommerce objectives. 

You can start with the Search field at the top of the community site found at 

http://www.magentocommerce.com  ,   which provides results from the Magento forum, 

knowledge base, wiki, groups, and other resources.  

If you are unable to find answers to your questions, try posting your question in the 

Magento Answers site and the Magento forums, where thousands of participants help each 

other with Magento issues.  

To access Magento Answers: 

Go to http://www.magentocommerce.com/answers/     and log in or using the user 

name and password that you created before downloading Magento CE. (If you do 

not have a Magento user name, you can register for one from this page.) Follow the 

onscreen directions to ask your question. 

To access Magento forums: 

Go to http://www.magentocommerce.com/boards     and log in using the user name 

and password that you created before downloading Magento CE. Choose a forum 

that best matches your question. 
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If you found the answer yourself and were unable to find it elsewhere, please share 

it with others. Use the wiki or forums to write and share it. 

There are also several other community features in addition to the forums described above 

that enable the exchange of ideas and help. They are: 

 Groups: Link community members working on or interested in specific subjects, such as 

Designing For Magento and Drop Shippers. 

 Chat: Provides a real time discussion with Magento community members. 

 Wiki: Provides community editable pages for sharing ideas and findings, tutorials and 

information  

The following lists other resources available to help you use get the most out of Magento: 

Knowledge Base 

The Magento knowledge base is a Wiki that provides instructions published by 

Magento or community members in the form of guides and “how-to” articles. 

At: http://www.magentocommerce.com/knowledge  -  base      

Getting Help 

Webinar Archive 

Up-to-date webinars are provided by Magento in which you can learn real-world tips 

and tricks in order to get the most out of your stores and promotions. 

At: http://www.magentocommerce.com/media/webinar  -  archive     

Screen casts 
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Screen casts are presentation videos that can guide you through many of the 

Magento features. 

At: http://www.magentocommerce.com/media/screencasts     

Magento Designer’s Guide  

The Magento Designer’s Guide provides information for designers describing 

Magento concepts and design implementation in Magento. 

At: http://www.magentocommerce.com/design_guide      

Magento Blog  

The Magento Blog contains fresh updates describing new Magento releases, 

interesting showcases and events. 

At: http://www.magentocommerce.com/blog      

Magento on Twitter 

You can keep up with Magneto events and announcements by following Magento 

on Twitter. 

At: http://twitter.com/magento     

Technical Documents and Magento Core API 

These provide developers with information on how to develop Magento CE.  

At: http://docs.magentocommerce.com/     

Here you can find information about all Magento classes and functions. 

At: http://www.magentocommerce.com/support/magento_core_api     
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Here you can find information and usage examples for calling Magento CE using an 

API. 

This enables easier integration of Magento CE with existing systems. 

 

21Appendix: VAT ID Validation 

All editions of Magento include a value-added tax (VAT) ID validation feature. The feature is 

intended for B2B merchants from the European Union (EU), where VAT is charged if a 

merchant and a customer are in the same country, and VAT is not charged if a merchant and 

a customer are in different countries within EU and both parties are EU-registered business  

entities. 

VAT identification number (VAT ID) Validation enables store administrators to create more 

than one default customer group, which will be automatically assigned to each customer 

during account creation, address creation or update, and checkout according to the 

customer’s VAT ID, and the customer’s and merchant’s location countries. This feature 

enables merchants to create different tax rules for intra-country (domestic) and intra-EU 

sales, and to apply the corresponding VAT amount automatically. 

Note: VAT-related tax rules do not influence other tax rules and do not prevent  

applying other tax rules where applicable. Only one tax rule can be applied 

at a given time. 

Magento performs VAT ID validation using the web-services of the European Commission 

server: http://ec.europa.eu/taxation_customs/vies/  .    

VAT ID Validation Quick Reference 
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The following table lists the main tasks concerned with the VAT ID Validation feature 

and the locations, where they can be performed in the Admin Panel. 

TASK ADMIN MENU SCOPE 
Create customer groups, which 
can be used as default for the VAT 
ID Validation functionality 

Customers > Customer Groups  

Enable the VAT ID Validation 
functionality 

System > Configuration > CUSTOMERS > 
Customer Configuration > Create New 
Account Options 

Store view 

o Set the default groups for 
customers from your country and 
from other EU countries 

System > Configuration > CUSTOMERS 
>Customer Configuration > Create New 
Account Options 

Store view 

o Set your country and VAT ID  System > Configuration > GENERAL > General 
> Store Information 

Store view 

o Modify Magento list of EU 
countries  

System > Configuration > GENERAL > General 
> Countries Options 

Global 

o Edit the VAT Number customer 
address attribute 

Customers > Attributes > Manage Customer 
Address Attributes  

Global 

o Create tax rates and tax rules for 
domestic, intra-EU and other VAT-
related customer groups 

Sales > Tax   
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For assigning groups to customers, the default customer’s address (billing or 

shipping) for tax calculation is used; the setting is configured under System > 

Configuration > CUSTOMERS > Customer Configuration > Create New Account 

Options > Tax Calculation Based On).  

If the VAT ID Validation feature is enabled, you can still choose not to apply it for a 

certain customer by selecting the correspondent check box on the Customer 

Information page under Customers > Manage Customers.  

Configuring VAT ID Validation 

Configuring the VAT ID Validation includes these steps: 

1. Creating VAT-related customer groups.  

2. Creating tax classes, tax rates and tax rules.  

3. Configuring the VAT ID Validation settings. 

4. Setting your VAT ID and location country. 

5. Modifying the list of EU member countries used by Magento. This step is only necessary if 

the EU gets new members or some countries leave the EU. 

Creating the VAT-Related Customer Groups 

VAT ID Validation functionality automatically assign one of the four default 

customer groups to customers according to VAT ID validation results:  

 Domestic 

 Intra-EU 

 Invalid VAT ID  
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 Validation error.  

You can create new customer groups to be used in the VAT ID Validation 

functionality or use existing groups, if they comply with your business logic. 

Customer groups are created under Customers > Customer Groups.  

When configuring the VAT ID Validation functionality, you will need to assign each 

of the created customer groups as a default for customers with appropriate VAT ID 

validation results. For details see the Enabling and Configuring the VAT ID Validation 

Functionality section further. 

Configuring the VAT-Related Tax Rules 

The VAT ID Validation functionality was implemented to facilitate the VAT applying 

for EU B2B merchants. In Magento, taxes are applied using the tax rules mechanism. 

Each tax rule is defined be three entities: 

Appendix: VAT ID Validation

 Customer Tax Classes 

 Product Tax Classes  Tax 

Rates. 

To use the VAT ID Validation functionality effectively, you need to create the appropriate 

tax rules.  

Important Note: According to the EU taxation policy, the supply of services 

between businesses (B2B services) is in principle taxed at the customer's 

place of establishment 

(  http://ec.europa.eu/taxation_customs/taxation/vat/how_vat_works/vat_o  

n_servi   ces/index_en.htm     )  . So if you sell downloadable or virtual products, 

which do not require shipping, the VAT rate of a customer’s location country 

should be applied for both, intra-union and domestic sales. 
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It means that you additionally need to create individual tax rules for a product 

tax class corresponding to the downloadable and virtual product types. 

The following table contains the minimal list of tax rules which must be created to use 

the VAT ID Validation functionality. 

Tax rule # Customer Tax Class Product Tax Class Tax Rate 

1 A class for domestic customers 

A class for customers with 

invalid VAT ID 

A class for customers, for whom 

VAT ID validation 

failed 

A class for products of all 

types, except bundle and 

virtual 

VAT rate of the 

merchant’s country 

2 A class for intra-union 

customers 

A class for products of all 

types, except 

downloadable and 

virtual 

VAT rates for all EU 

countries, except 

merchant’s country. 

Currently this rate is 

0% 

3 (required only 

if you sell 

products of 

bundle or virtual 

type) 

A class for domestic customers 

A class for customers with 

invalid VAT ID 

A class for customers, for whom 

VAT ID validation 

failed 

A class for downloadable 

and virtual product types 

VAT rate of the 

merchant’s country 
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4 (required only 

if you sell 

products of 

bundle or virtual 

type) 

A class for intra-union 

customers 

A class for downloadable 

and virtual product types 

VAT rates for all EU 

countries, except 

merchant’s country. 

Currently this rate is 

0% 

Note: It is recommended that you apply the merchant’s VAT rate for customers 

with invalid VAT IDs and those for which validation fails.You can create 

other tax rules and apply other tax rates according to your business logic. 

In the Magento Admin Panel, all tax rule related entities, including tax rules, tax 

rates, product tax classes and customer tax classes, are managed under Sales > Tax; 

tax classes are assigned to customer groups under Customers > Customer Groups > 

%customer 

group%. 

Enabling and Configuring the VAT ID Validation 

Functionality 

To enable VAT ID and set default groups: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Configuration > CUSTOMERS > Customer Configuration. 

3. In the Current Configuration Scope field in the upper-left corner leave Default Config or 

select the desired store view. 

4. Expand the Create New Account Options field set.  

5. In the Enable Automatic Assignment to Customer Group field, select Yes. The following 

fields appear: 
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 Tax Calculation Based On: Choose whether VAT calculation will be based on customer's 

shipping or billing address. If the customer does not have a shipping address (that is, the 

customer has only now registered and the system does not yet take into account the 

customer's shipping address), the Default Tax Destination Calculation address will be used 

for tax calculation to be displayed to the customer. 

Important Note: If the Tax Calculation Based On is set to Shipping Address, then 

Magento will use billing address for VAT calculation, if a customer only buys 

downloadable and/or virtual products.  

 Group for Valid VAT ID – Domestic: Choose a customer group, which is automatically 

assigned to customers coming from your country and whose VAT ID is valid. See 

“Configuring Additional Settings for the VAT ID Validation Feature,” page283, for details 

about setting your location country. 

 Group for Valid VAT ID - Intra-Union - Choose a customer group, which is automatically 

assigned to customers coming from EU countries other than yours, and whose VAT IDs are 

valid. See “Configuring Additional Settings for the VAT ID Validation Feature,” page 283, for 

details about where your location country is set. 

 Group for Invalid VAT ID: Choose a customer group, which is automatically assigned to 

customers whose VAD ID is invalid. 

Appendix: VAT ID Validation

 Validation Error Group: Choose a customer group, which is automatically assigned to 

customers for whom the VAT ID validation failed.  

 Validate on Each Transaction: Choose whether VAT ID validation will be performed each time 

during order creation even if a previously saved customer address with validated VAT ID is 

used. The option applies to one-page checkout in the frontend only. If a new customer 

address is used (including guest checkout or if a customer has no address assigned to their 

account), then the validation is performed irrespective of this setting. During order creation 

in the Admin Panel, no automatic validations are performed.  
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 Default Value for Disable Automatic Group Changes Based on VAT ID (available only if 

Default Config is selected in Current Configuration Scope): Choose whether the automatic 

change of customer group based on VAT ID will be enabled or disabled by default. The 

setting can be overridden on the product level. The setting influences the system behavior 

in the following situations: 

i. The VAT ID of the customer’s default address or the whole 

default address changes. 

i i. Customer group change was emulated during the 

checkout for a registered customer who had no previously 

saved address or for a customer, who registered during the 

checkout. If the automatic group change is enabled, then 

in the first case the customer group changes automatically, 

and in the second case the temporarily emulated customer 

group is assigned to customer.  If the automatic group 

change is disabled, the customer group that is assigned 

assigned never changes, unless an administrator changes 

it manually. 

 Show VAT Number on Frontend: Choose whether the field for entering and storing the VAT  

ID number will be visible in the frontend. 

6. To save the settings, click Save Config. 

If the VAT ID Validation feature is disabled (the Enable Automatic Assignment to 

Customer Group field set to No), then the system behavior is as usual, and the 

default customer group can be set in the Default Group field. 

When the feature is enabled, the system does not automatically validate customer 

VAT IDs nor does it change customer groups. 
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Configuring Additional Settings for the VAT ID Validation 

Feature 

To set your VAT ID and location country: 

1. Navigate to System > Configuration > GENERAL > General. 

2. In the Current Configuration Scope field, select the desired store view. 

3. Expand the Store Information field set.  

4. In the Country field, select your country.  

5. In the VAT Number field, enter your VAT number. You can validate the entered value by 

clicking the Validate VAT Number button. The result of validation will be displayed 

immediately.  

Note: If your VAT number is valid, then apart from validation result for each 

customer’s VAT ID validation, the validation server will send to Magento the 

following additional information: VAT request identifier and VAT request 

date. If a customer’s VAT validation is performed during checkout, then the 

VAT request identifier and VAT request date are saved in the Comments 

History section of the Order View page under Sales > Orders > (select 

appropriate order). 

6. To save the settings, click Save Config. 

To modify the list of the countries that are EU members: 

1. Navigate to System > Configuration > GENERAL > General. 

2. In the Current Configuration Scope field, select the desired store view. 

3. Expand the Countries Options field set.  
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4. In the European Union Countries field make the necessary changes in the list of countries 

that are EU members. 

5. To save the changes, click Save Config. 

VAT ID Validation Implementation Details: 

Customer Experience 

Assigning Customer Groups Based on VAT ID Value 

during Registration  

If the VAT ID Validation feature is enabled, after registration each customer is 

proposed to enter the VAT ID number. However only those who are registered VAT 

customers are expected to fill this field. 

After a customer specifies the VAT number and other address fields, and chooses to 

save, the system saves the address and sends the VAT ID validation request to the 

European Commission server. According to the results of the validation, one of the 

default groups is assigned to a customer. This group can be changed if a customer 

or an administrator changes the VAT ID of the default address or changes the whole 

default address. And the group can be temporarily changed (group change will be 

emulated) in some cases during one-page checkout. 
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Applying and Assigning Customer Groups During 

Checkout  

The system behavior concerned with the VAT ID validation and the customer group 

change during the checkout depends on how the Validate on Each Transaction and 

the Disable Automatic Group Change settings are configured. This section describes 

the implementation of the VAT ID Validation functionality for the checkout on the 

frontend. 

In case a customer uses Google Express Checkout, PayPal Express Checkout or 

another external checkout method, when the checkout is performed completely on 

the side of the external payment gateway, the Validate on Each Transaction setting 

cannot be applied. Thus the customer group cannot change during checkout.  

The following diagram illustrates the flow of VAT ID validation and customer group 

change during one-page checkout. 
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Figure 274. One-page checkout with VAT ID validation 

VAT ID Validation Implementation Details: 

Admin Experience 
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The VAT Number Customer Address Attribute 

Customer VAT ID value is stored in the vat_id customer address attribute. The default 

label of this attribute is VAT number. Customer address attributes are managed under 

Customers > Attributes > Manage Customer Address Attributes. 

The VAT number field is always present in all shipping and billing customer addresses 

in the backend. It is not mandatory. Displaying the field in the frontend is configured 

in the Show VAT Number in Frontend field under System > Configuration > 

CUSTOMERS > Customer Configuration > Create New Account Options. 

Note: For customers not from the EU countries, consider storing the VAT number 

(if any), in the existing Tax/VAT Number customer attribute to avoid any 

possibility of customer group change (whether persistent or emulation 

during checkout). It is recommended that you rename the Tax/VAT Number 

customer attribute to avoid confusion with the new VAT Number customer 

address attributte that is used for the VAT ID Validation functionality.  

Disabling Automatic Customer Group Change 

When the VAT ID Validation functionality is enabled, the group of a customer can only 

be changed manually in the Admin Panel, no automatic changes of customer group 

can take place.  

When the VAT ID Validation functionality is enabled, the system will automatically, 

permanently change a customer group in the following situations: 

 The VAT ID of the customer’s default address or the whole default address changes.  

 The customer group change was emulated during the checkout for a registered customer 

who had no previously saved address, or a customer who registered during the checkout. 
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The automatic customer group change can be disabled by selecting the Disable 

automatic group change check box on the customer’s page under Customers > 

Manage Customers > %customer% > Account Information. See Figure 275. 

 

Figure 275. Disabling automatic group change on customer level 

Important Note: The setting does not influence the emulation of the customer 

group change during checkout. 

The default value of the Disable automatic group change check box is set in the 

Default 

Value for Disable Automatic Group Changes Based on VAT ID field under System > 

Configuration > CUSTOMERS > Customer Configuration > Create New Account 

Options. The configuration setting is made on the global level. The default value 

applies to new customers and to customers whose records are available in the system 

when the VAT ID Validation functionality is enabled for the first time.  
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VAT ID Validation in Customer Accounts in the Admin 

Panel 

When an administrator adds a new default address with a VAT ID to the account of a 

new or existing customer or changes the VAT ID of the existing default address, the 

system validates the VAT ID and assigns the appropriate customer group to the 

customer. The validation is performed after the Save or Save and Continue button is 

clicked. 

Note: The system behavior is as described when the VAT ID Validation 

functionality is enabled and configured. 

If you want to disable the automatic change of a customer group, select the Disable 

automatic group change check box on the Account Information tab of the Customer  

Information page. 

VAT ID Validation During Order Creation in the Admin 

Panel 

This section describes the system behavior when an admin creates a new order in the 

Admin Panel, with the VAT ID Validation functionality enabled and configured.  

During order creation in the Admin Panel no VAT ID validation is performed 

automatically. To validate the VAT ID of the customer address, an administrator 

needs to click the Validate VAT Number button in the Billing Address or Shipping 

Address section of the Create New Order page. See Figure 276. 
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Figure 276. Validating customer VAT ID during order creation in the 

Admin Panel 

After the validation, the administrator receives a notification about the validation 

results in the form of a pop-up message. 

A customer group, which should be assigned to a customer according to the 

validation results, can differ from the customer group that is currently assigned to the 

customer. In this case the system displays a dialog box suggesting that the 

administrator confirm or reject the group change emulation for the customer’s 

current order. If the administrator confirms, then the group change is emulated for 

the current order and the corresponding VAT rate is applied (if the corresponding tax 

rule is configured in the system). The actual customer group of a customer is not 

changed. 

If a new customer account is added during the order creation, and an administrator 

confirms using the customer group that corresponds to the VAT ID validation results,  
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then after the order creation the customer account is saved in the system and the 

customer group that was used for order creation is assigned to it.  
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orders, 166 Payment, 

153 payment methods 

PayPal Advanced, 155 

PayPal Express Checkout, 158 

PayPal, 153 

PayPal Advanced payment method, 

155 

PayPal Express Checkout payment 

method, 158 

Permissions, 13 

Polls, 57 

Editing, 242 

Managing, 240 

Popular Search Terms, 75 

Popular Tags, 41, 238 price 

layered navigation, 86 

Prices, 99 

Rules, 194 

Pricing 

Tier, 208 product 

data exporting, 124 

import, 124 

Product Image Placeholders, 73 

Product List Banners, 46 

Product Reviews, 109 

Product Tags, 109 

Product Types, 96 

Product Wizard, 120 

Products 

Alerts, 72 

Attributes, 88 

Catalog Tab, 83 

Categories, 107 

Changing, 121 

Compared, 73 

Comparing, 42 

Creating, 96 

Cross-sell, 48 

Cross-sells, 189, 193 

Editing, 120 
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Images, 100 

Inventory, 106 

Managing, 95 

Meta Info, 100 

New, 96 

Pages, 49 

Prices, 99 

Ratings, 67 

Recently Viewed, 73 

Related, 48, 189, 192 

Reviews, 67, 72 

Searching, 42 

SKU, 98 

Sorting, 44 

Tax Class, 98, 132 

Tax Classes, 132 

Taxes, 129 

Up-sell, 47 

Up-sells, 189, 190 

Variations, 121 

Weight, 98 

Wizard, 97 

Promotional Information, 45 

Promotional Pages, 46 

Promotions, 189, 203 Purchasing 

Functionality, 52 

R 

Rates, 134 

Ratings, 56, 67 

Customizing, 236 

Managing, 235 

Recently Viewed, 45 Redirects, 

246 refreshing statistics, 244 

Refund 

Email, 233 Refunding, 232 

reindexing, 263 Related 

Products, 48, 189, 192 

Reports, 243 

Customer, 226 

Generating, 67, 243 

Requirements, 9 

Reviews, 56, 67 

Approving, 237 

Managing, 235 rewrites 

URL, 265 rolling back a 

backup, 250 

Rules 

Catalog Price, 194 

Price, 194 Shopping Cart 

Price, 199 

S 

Sales Order, 228 sales reports 

refreshing statistics, 244 

Search Engine, 74 

Search Redirects, 246 
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Search Synonyms, 246 

Search Terms, 75 

Searching, 42 

Shipment, 66, 228 

Email, 231 

Rates, 147 

Settings, 32 

Tracking Number, 231 shipping 

additional modules, 151 flat rate, 

147 free, 150 online rates, 149 

Shipping Rates, 147 

Shipping Settings, 147 SHOP 

BY Panel, 79 shopping cart 

clearing, 53, 231 Shopping 

Cart 

Rules, 199 

Appendix: VAT ID Validation 

Simple Associated Product, 119 

Site Map, 74 

Skins, 8 SKU, 98 social 

networking buttons, 

179 

Sorting 

Products, 44 

Special Prices, 206 

Staging 

Environment, 253 

store 

creating, 127 

store hierarchy, 

127 store view 

creating, 127 

Supervising Web Store Activities, 

61 

Support, 1 

Synonyms, 246 

system backup, 

250 System 

Requirements, 

9 

T 

Tags 

Adding, 239 

Approving, 239 

Definition, 41 

Managing, 238 

Tax Class, 98, 132 

Customer, 133 

Tax Zones, 134 

Taxation 

Settings, 129 

taxes 
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compound, 144 

eco tax, 137 fixed 

product tax, 137 

management 

rules, 135 

Value Added Tax (VAT), 142 

WEEE tax, 137 

Taxes, 129 

Testing Environment, 253 

Theme, 170 

Tier Pricing, 208 

Appendix: VAT ID Validation

tracking coupon code usage, 206 

Tracking Number, 231 

U 

Updating Magento CE, 254 

Uploading 

To the Server, 12 

Up-sell Products, 47, 189, 190 

URL 

Product, 99 

URL rewrites, 265 

V 

Value Added Tax (VAT), 142 

Value-Added Tax (VAT), 279 

ID validation, 279 

W 

website creating, 127 

WEEE tax, 137 

Weight, 98 

Wish List, 51 
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