
Audacity Tutorial
______________________________________________________________________________________________________________________________

This tutorial covers these topics:

Opening audio files
Connecting a Microphone to your computer
Connecting a keyboard to your computer
Connecting a guitar to your computer
Connecting a Mixer
Audacity Settings for Recording
Making a Test Recording
Recording and Editing
Mixing a Narration With Background Music
Recording with USB turntables or USB cassette decks
Splitting a recording into separate tracks
Burning music files to a CD
Recording audio playing on the computer
Recording Computer Playback on Windows
Recording Computer Playback on Mac
Recording Computer Playback on Linux
How to import CDs
Digital Audio
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Opening audio files: 
Either drag the files into the current project window, or choose File > Import > Audio.... 

Files can be opened into a new project window with File > Open.... 

The main formats Audacity plays as shipped are AIFF, AU, FLAC, MP2, MP3, OGG Vorbis  and 
WAV. On Mac OS X, Audacity as shipped can also import Apple formats like M4A (AAC)  and 
MOV. 

For most other cases (including audio from video files), you can install the optional FFmpeg 
library to import your file, as long as the file is not protected by Digital Rights Management 
(DRM).
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Connecting Up

Identifying the sound ports on your computer 
First of all you need to know the sound input capabilities of your computer. 

PCs - Windows and Linux
Most desktop PCs (Windows and Linux) will have sound ports on the back of the computer 
similar to these illustrations. 

        

        The rear of a typical PC  The color-coded jacks on the sound
card  

The pink port is normally the microphone input, and is usually mono but might be stereo. The 
light blue port is normally the line input port and is usually stereo. The green port is normally the 
headphone output port, also usually stereo. Check your computer manual to be sure. 

PC laptops vary widely in the types of sound input and output ports they provide, where they are
on the laptop, and how they are labeled. Many modern laptops do not have a line input at all. 
Again, check your computer manual to be sure of the capabilities of your laptop, where the ports
are and how they are labeled. 

Mic In 

Generally the Mic In port on a computer is only meant to have a small computer microphone 
plugged into it. If you have a microphone with an 1/8" (3.5mm) 3-conductor jack plug, it will 
probably work if plugged into this port. 

Line In 

The Line In port is the highest quality input available on most sound cards (like the one pictured 
above). It expects to have a Line level signal plugged into it, this is the same level used by most 
consumer-oriented audio equipment. Equipment such as tape decks, record players, MiniDisc 
players, Video Game Systems and so on should be plugged into this port. 
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Macs
Macs do not generally have a microphone input port. 

        

        Audio connections on a
PowerBook  

Audio connections on an iMac  

In these illustrations of sound ports on Macs, the round port with the headphone symbol is the 
Line Output port. The round port beside the headphone port is the line input port. 

Other Macs (Mini, Mac Pro, MacBook and MacBook Pro) are similarly equipped. Check your 
manual for the locations and labeling of these ports. 

USB devices
For better audio quality, many people use an USB audio device. If you have such a device, 
attach your microphone and speakers to that device, and plug the device into your computer's 
USB port. 

USB Cable and Plug
USB Ports
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Testing your input connection 
Before you fire up Audacity you should use your computer's sound control panel or the 
custom mixer application for your specific sound card, select the input device you want to 
use and verify that you are getting sound into the computer from that device. 

Once you have verified that you are getting sound into the computer you can move on to 
getting that sound into Audacity. 
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Connecting a Microphone to your computer 

If your computer has a microphone input port 
You're all set. Just plug a compatible microphone into the microphone input port on your 
computer. 

What do we mean by compatible? Any microphone with a permanently attached cord that ends 
in a mini-plug should work. Note that many sound cards provide battery voltage for mono 
electret microphones on the ring of a stereo mini-plug. Check your computer manual to be sure 
if this feature is provided. If it is, be sure to use a microphone that is designed to accommodate 
this. 

        

        A mono mini-plug  A stereo mini-plug  

A computer headset-mic combination is pretty much guaranteed to work. These microphones 
are not the highest quality, but can be had fairly inexpensively. If you're just getting started and 
want to experiment without spending a lot of money, one of these would be a good choice. Just 
don't be surprised if your recorded voice sounds a bit tinny or flat. 

Desktop-standing microphones can be had for at little as $10 or as much as $500. Choosing a 
microphone is beyond the scope of this tutorial. Try searching the web for "computer 
microphones", visit your local computer store, talk to your friends, or ask questions on the 
Audacity Forum. 

Unless you are prepared to spend extra money for a microphone pre-amp or standalone mixer 
do not buy a microphone with an XLR connector: 

        

        An XLR plug  
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If your computer does not have a microphone input p ort 
Do not plug a microphone into the line input port on your computer. The volume will be way too 
low (the line input port does not apply the needed amplification to boost the very quiet signal 
from the microphone). You won't break anything, but you will be very frustrated with the results. 

Option 1 - Buy a microphone to USB adapter  

These devices plug into a USB port on your computer, and have a microphone input jack 
(usually 1/8"). 

Some options are the Griffin iMic and the Roland Duo capture UA-11 UA-1G. 

You will still need a compatible microphone. Be sure to carefully read the specifications of any 
adapter you are considering and make sure you get a microphone that will work with that 
interface. 

Option 2 - Buy a USB microphone  

These microphones are becoming more common. They combine a microphone and the USB 
adapter all in one package. 

Models are available by Logitech, Samson, Nady and Audio-technica, among others. 

Option 3 - Buy a mixer  

This may be the most expensive option but provides the most flexibility. 

Any inexpensive DJ mixer should include a microphone input. The electronics in the mixer will 
boost the microphone signal, and the output of the mixer will be connected to the line in port on 
your computer. The DJ mixer will also have inputs for turntables so you can use it record your 
LPs in preparation for converting them to CD. The DJ mixer will most likely have line level inputs
as well, so you could connect a cassette deck or other line level source to the mixer. 

Another option is a small inexpensive microphone and line level mixer. Note that these mixers 
do not usually include inputs for turntables. 

When purchasing a mixer make sure to also buy a microphone that is compatible with the mixer.
Unless you are sure of what you are doing it is probably best to visit your local music store. 
Don't let them sell you a $1000 DJ mixer and $500 microphone - unless you are a professional 
DJ you don't need equipment at that level. 

The advantage of a mixer is that you can connect all your audio sources to the mixer then 
connect the mixer to your computer. No need to be constantly re-plugging things at the back of 
your computer. 

To connect the mixer to your computer you will probably need a dual-RCA to stereo mini-plug 
cable like this one: 
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        Dual-RCA to mini-plug cable  
Plug the RCA plugs into the RCA output jacks on the back of the mixer. Plug the stereo mini-
plug into the line input port on your computer. There are also mixers that can be connected to 
the computer via USB and do not require the stereo mini-plug cable. 

If you do buy a mixer, you will no longer be connecting the microphone directly to your 
computer.
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Connecting an Instrument
Generally speaking you will want to connect these instruments to the line input  port on your 
computer, not the microphone port (which is often mono). Not all computers will have a line input
port. 

• Some PC laptops may have a hardware or software switch to convert the microphone 
port to line-level stereo. 

• Some PC notebooks/netbooks may have a compliant microphone input port which will 
tolerate line level inputs and may provide stereo input. 

Always try line-level input first, and only use a microphone input if you cannot otherwise get 
adequate recording volume. You can buy modestly priced, decent quality USB interfaces with 
line level stereo input if needs be. 

Connecting a keyboard to your computer  
If the keyboard has RCA jacks on the back then the best way to connect it is with a dual RCA to 
stereo mini-plug cable as shown below, plugged from the RCA output jacks on the back of the 
keyboard to the line input port of the computer. 

A Stereo Mini plug to dual RCA
cable  

If the keyboard has two 1/4 inch jacks on the back you will need a 2 x 1/4 inch jack to stereo 
3.5mm jack, or you could use a dual RCA to stereo mini-plug cable, and two RCA to 1/4 inch 
adapters. Plug the RCA plugs into the RCA jacks on the adapters - you now have a dual 1/4 
inch to stereo mini-plug cable. 

1/4 inch jack to stereo 3.5mm jack  An RCA to 1/4 inch adapter  
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If the keyboard has neither of these options, but does have a 1/4 inch or 3.5mm stereo 
headphone jack, the easiest way to connect it is with a cable with a stereo mini-plug on one end 
(for the computer), and an stereo jack plug of appropriate size at the other end for the keyboard 
headphone socket. Plug the headphone output of the keyboard to the line input port of the 
computer. You will lose the ability to listen directly to the keyboard using headphones, and any 
internal speakers will probably be muted. You can get around this using a headphone splitter 
cable, or by enabling Software Playthrough in Audacity, (Software Playthrough will introduce a 
delay between the time you play a note and the time you hear it). This topic is covered in more 
detail in a following section. 

Connecting a guitar to your computer  
This section is about connecting an electric guitar, bass guitar or acoustic guitar with electrical 
pickup to your computer. If you want to record an acoustic guitar with a microphone, or record 
the sound of your guitar amplifier using a microphone, please read the section on connecting a 
microphone to your computer .
If you have a "USB Guitar" then you can skip ahead to testing the input connection for your 
operating system. 

Generally the output level from an electric guitar (or electrical pickup in an acoustic guitar) is 
sufficient to drive the line input port on a computer. Turn the volume control on the guitar all the 
way up. You will need a shielded adapter cable that goes from a 1/4 inch mono plug (to plug into
the guitar) to a mono mini-plug (to plug into the computer line input port). 

You probably have a guitar cable for plugging the guitar into an amplifier, and you may be 
tempted to buy a 1/4 inch to 1/8 inch adapter instead, plug it into the computer line input then 
connect the guitar to the adapter using the cable - don't do this!  This creates a heavy, stiff 
cable hanging off the back of your computer - the slightest tug in the wrong direction could 
damage your sound card! 

If you cannot get a good recording level when connecting to the line input port (explained in a 
following section on setting recording levels in Audacity), you can try the microphone input on 
your computer (if you have one). Beware of overloading the microphone input. You can turn 
down the volume control on your guitar to compensate for the extra amplification in the 
microphone input port, but hum and noise may increase in comparison to using the line input 
port. 

Most effect pedals are designed to deliver about the same volume to the amplifier as the 
unaffected guitar sound (the volume you get when the effect is bypassed). Thus you can 
connect your guitar to a pedal and then connect the pedal to the computer. 

Some guitar amplifiers include a "direct output" for feeding the amplifier sound to recording or 
PA systems. Amplifiers designed for stage use that include this feature will usually have either a 
line-level 1/4 inch mono jack output, or a microphone-level balanced output using an XLR 
connector. Connecting this output to your computer microphone input is beyond the scope of 
this Tutorial - talk to the folks at your local music store. 
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Some USB audio interfaces are specifically designed for connecting a guitar to a computer or 
may have a dedicated input for electric guitar or bass guitar. Talk to the folks at your local music 
store. 
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Connecting a Mixer
To connect a mixer to the line input port on your computer you will need a dual-RCA to mini-plug
(1/8 inch) cable. Plug the RCA plugs into the RCA output jacks on the back of the mixer. Plug 
the stereo mini-plug into the line input port on your computer. 

If you don't have a line input port (many Windows laptops don't), you'll need a line level USB 
audio interface. In that case you will need a cable that connects from the output of the mixer to 
the input of the USB interface. In the illustration below a dual-RCA cable is connected from the 
output of the mixer (out of frame) to a USB interface. The USB interface then plugs into the USB
port on the laptop. 
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Audacity Settings for Recording
Now that you know you're getting sound into the computer, it's time to launch Audacity and 
make some basic settings to enable recording. 

Project Sample Rate

The sample rate in Hz defines the number of digital audio samples per second taken from a 
continuous analog signal. 

44100 Hz is standard for creating files that can be burned to Audio CD or for high-quality MP3 
files. 

Project Sample Format
The Project Sample Format (also known as Bit Depth or Word Size) is the number of computer 
bits present in each audio sample. It determines the dynamic range of the audio. Audacity's 
default is set to 32-bit float . This is good for editing and processing audio. You can easily 
downsample to 16-bit (the standard for creating WAV files that can be burned to audio CD) 
when exporting later. 

If you need to change your sample format this can only be done in the Quality section of 
Preferences. However it is strongly recommended that you retain the default setting. 

Temporary Files
Most users have only one hard disk. However, if you have multiple hard disks, you will want to 
make sure that Audacity uses your largest or fastest hard disk to store audio. Open the 
Preferences (in the Edit menu, or the Audacity menu on Mac OS X) and click on the Directories 
tab. Make sure that the directory listed is on your preferred hard disk. 

Software Playthrough
Now click on the Transport menu  and, if you are recording from a microphone, make sure that 
"Software Playthrough " is not  checked - Software Playthrough will cause undesirable 
feedback from the computer speakers to the microphone. If you are recording a guitar or 
keyboard and want to hear the instrument through the computer speakers, make sure that 
"Software Playthrough " is  checked. 

Using Software Playthrough will cause a slight delay between time you play a note and the time 
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you hear it. The amount of delay will vary between computers and operating systems. There is 
no way to avoid this delay. If you find it bothersome, the best solution is to play the guitar or 
keyboard through a mixer and plug headphones into the mixer.

Overdub
Now click on the Transport menu  again and make sure that "Overdub " is not  checked. When 
this option is enabled Audacity will play other existing tracks while recording a new one. You can
decide which tracks will play according to their mute/solo buttons on the Track Control Panel. 

It is unlikely you will need overdub for your first recording. If you do want to overdub by (for 
example) singing over a recorded instrumental track, you should be aware of the Latency 
correction preference. 

Latency correction
On most computer systems there will be a delay known as latency between singing or hitting 
your note and it being laid down in the recording. When Transport > Overdub (on / off) is set to 
"on" and you record with another track already present, Audacity will push the recorded track 
backwards by 130 milliseconds to compensate for the delay. If your latency is constant, you can 
adjust the Latency correction value so that your recorded tracks should end up properly 
synchronized with the other tracks after correction. To set a custom latency value for your 
system, see the Latency Test page. 

Sound Activated Recording
Also on the Transport menu , make sure that "Sound Activated Recording " is not  checked. 

When this is enabled, recording will automatically start or resume when the input volume rises 
above the chosen threshold level, and pause when the level falls below that threshold. You 
cannot pause Sound Activated recordings manually using the Pause button or corresponding 
menu item or shortcut. 

Audacity Preferences
If you prefer, you can make the above settings in your Audacity Preferences. To access this, use 
Edit > Preferences 

The image below shows the Recording section of Preferences: 

15



Audacity Tutorial
______________________________________________________________________________________________________________________________

 

There are many other settings that can be made in your Preferences do take some time to 
explore and understand these. 

For example Sample Rate and Sample Format can be changed from the Quality tab of 
Preferences. 
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Selecting Your Input

Now that you know you're getting sound into the computer and you've made your Audacity 
settings, it's time to set up your input device for recording. 

Setting up the audio host and playback device
Device Toolbar is displayed by default in a new installation of Audacity. If Device Toolbar is not 
visible, click on View > Toolbars > Device Toolbar. 

You may want to expand the size of the Device toolbar by dragging right on the drag handle. 

Choose your preferred audio host and output device from the drop-down menus. Selects the 
particular interface with which Audacity communicates with your chosen playback and recording 
devices. 

The "audio host" is the interface between Audacity and the sound device. On Windows , the 
choice is between the following audio interfaces. 

• MME: This is the Audacity default and the most compatible with all audio devices. 
• Windows DirectSound: This is more recent than MME with potentially less latency. 

• Windows WASAPI: should not be selected because these inputs are only "loopback" 
inputs for recording computer playback on Windows Vista and later. 

On Mac OS X the only choice is Core Audio. 

On Linux  there is often only one option: ALSA. Other options could be OSS and/or Jack Audio 
Connection Kit (also known as "Jack" or "Jackd"). 

• On Windows XP or earlier  (given a recent computer), DirectSound's much shorter path 
to the hardware should produce much lower latency than MME. 

• On Windows Vista, Windows 7 and Windows 8 : 
• Windows DirectSound may by default have only slightly lower latency than MME. 
• Selecting Windows DirectSound or Windows WASAPI and enabling both 

"Exclusive Mode" boxes in Windows     Sound allows Audacity to request audio direct 
from the device without resampling. 

• For output device, choose the named sound device your headphones or speakers are 
connected to (not a device like Microsoft Sound Mapper that uses the system default 
device). If you are using a USB-connected guitar, microphone or keyboard on Windows, 
you may also need to reset the default system playback device to your computer sound device in
order to hear audio in other programs. 
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Click on Generate > Tone, accept the default values in the dialog then click OK: a 30-second 
tone will be generated into a new track. Press SPACE to begin playback - you should hear a 
loud tone coming from your computer speakers. You can use the output slider on the Mixer 
Toolbar to control the volume at which you listen to your Audacity project. 

Note that the playback meters in the Meter Toolbar do not change as you adjust the output slider:
these meters always indicate the volume of the mix of your Audacity project. 

Setting up the recording device
Now that you know that you can hear what Audacity is playing you can continue setting up for 
recording. 

Choose your preferred input device from the Input Device drop-down menu in the Device Toolbar.

In the Input Channels drop-down menu choose whether you want to record in mono (1 channel) 
or stereo (2 channels). In general if you are recording a microphone or guitar you will want to 
record in mono. If you are recording a keyboard and the keyboard has stereo outputs you will 
want to record in stereo. 

Audacity Preferences
If you prefer, you can make the above settings in the Audacity's Preferences. To access this, use 
Edit > Preferences 

The image below shows the Devices section of Preferences: 
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There are many other settings that can be made in your Preferences do take some time to 
explore and understand these. 
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Making a Test Recording

Step 1: Turn on monitoring
Click on the downward pointing arrow beside the microphone symbol under the recording VU 
meters and select "Start Monitoring ". 

Step 2: Start the recording
Talk or play at a normal volume and watch the red recording VU meter. 

Try to aim for a maximum peak of around –6 dB (or 0.5 if you have your meters set to linear 
rather than dB). You can always boost the level later after you have completed your editing. 

Step 3: Adjust the level
Adjust the recording volume with the right-hand Input Volume Slider (by the microphone 
symbol). 

You want the meter to get close to the right-hand edge without hitting it during the loudest parts 
(-6 dB is a good target). 

Note that if you are using a USB microphone or USB adapter the recording volume control may 
have no effect or may be greyed out and set to maximum. If you cannot get a "good" reading on 
the recording meter (doesn't get close to the right edge - too quiet; or goes all the way to the 
right edge - too loud), go back to your system sound control panel and adjust the volume there. 
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Step 4: Test recording
You are now ready to do a test recording. 

Get everything ready (microphone in place, guitar in hand) and click the Record button  in 
Transport Toolbar. Record for few seconds while talking or playing, then click the Stop button .

Have a look at the recorded waveform - there should be no clipping visible. Clipping is bad - 
this is when the volume of the source that was sent to Audacity is louder than Audacity can 
record. The result is that the tops and bottoms of the recorded wave are chopped off ("clipped"). 
The illustrations below show a properly-recorded waveform and a clipped waveform. Note that 
these images from Audacity show the waveform when zoomed in - the total time displayed is 
about 0.004 seconds! 

A properly recorded waveform  

A clipped waveform  

You can also check for clipping by clicking on View > Show Clipping. Audacity will display vertical
red bars in the waveform wherever it detects clipping. 

Click on Edit > Undo Record to remove the test recording. 

If clipping occurred turn down the recording level a bit and try again. If no clipping occurred you 
are ready for the real thing!
As stated above, try to aim for a maximum peak of around –6 dB (or 0.5 if you have your meters
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set to linear rather than dB).

Tip:  Enlarging the Meter Toolbar by clicking and dragging on the toolbar helps considerably with
this task. 
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Recording and Editing

Step 1: Record for real this time 
Click the red Record  in Transport Toolbar then begin talking or playing. Continue for as
long as you want. When you feel you've recorded enough, click the Stop button . 

Try to aim for a maximum peak of around –6 dB (see: dB) or 0.5 if you have your meters set to 
linear rather than dB.

Tip:  Enlarging the Meter Toolbar by clicking and dragging on the toolbar helps considerably with

Step 2: Remove any DC offset 
DC offset can occur at the recording stage so that the recorded waveform is not centered on the
horizontal line at 0.0 amplitude. This can be caused if you have a faulty sound card. If this is 
the case with your recordings, see the Normalize page for how to use Normalize to remove DC 
offset and how to check if your Windows sound device can perform this correction automatically.

Step 3: Edit Recording 
You now have a good recording, but there are likely some bits at the beginning and end that you
don't need - between the time you clicked the Record button and the time you starting talking or 
playing, and between the time you stopped talking or playing and the time you clicked the Stop 
button. 

• Click the Skip to Start  in Transport Toolbar 
• Repeatedly click the Zoom In button  until the displayed waveform expands so you can

see from the beginning of the recording to the time you started talking or playing 
• With the Selection tool , click just before the point where you started talking or playing 
• Choose Edit > Select Track Start to Cursor 

• The region from the beginning of the track to the beginning of your performance is 
selected 

• Choose Edit > Remove Audio or Labels > Delete 
• The selected audio is removed from the track, and the rest of the audio moves left 

to fill the space left after the delete. 

Similarly, you can delete the extra bit from the end of your recording. 

• Click the Skip to End  in Transport Toolbar 
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• Repeatedly click the Zoom In button  button until the displayed waveform expands so 

•

• Choose Edit > Select > Cursor to Track End 
• The region from the end of your performance to the end of the track is selected 

• Choose Edit > Remove Audio or Labels > Delete 
• The selected audio is removed from the track 

If you've made any mistakes in your performance you could edit them out. Use the Selection 
Tool to select each mistake and press the delete key. Listen back to each edit to make sure it 
sounds natural. If not, choose Edit > Undo Delete and try again. 

Step 4: Amplitude adjustment
Since you were careful not to record too loud it is likely that your recording is not as loud as 
possible. To correct this you can use the Normalize effect. 

• Choose Edit > Select > All (or use CTRL + A) to select all of the track. 
• With default Tracks Preferences, you may not need this step - all the audio in the 

project is selected if you choose an effect without first selecting any audio. 
• Choose Effect > Normalize.... 

• Accept (for now) the default choices in the Normalize dialog and click the OK 
button 

• The volume is normalized to -1 dB, so leaving a little headroom below the 
maximum possible 0 dB level. 

Note that Normalize defaults to retaining the existing balance between stereo channels. 
However basic consumer-level equipment can often record with channels unbalanced. To 
correct unwanted volume differences between left and right, check "Normalize stereo channels 
independently". 

Extraneous noises in the recording can cause Normalize to create unwanted changes in the 
stereo balance, or prevent recordings being made as loud as they can be. Extraneous noises 
should be edited with Click Removal, Repair or Amplify before the Normalize step. Also see our 
tips for reducing noise in the recording chain.

Step 5: Save and Export 
Choose File > Save Project, then choose a name for your project and a place to save it. 

You have now saved an Audacity Project to disk. The project file (ending in .aup) can only be 
opened by Audacity. You can come back to the project and make changes to it later. For 
example you could do more editing, record more audio, or apply other effects. 

To listen to your performance in other audio software (such as iTunes or Windows Media 
Player), or to burn it to CD, choose File > Export.... 
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Mixing a Narration With Background Music
The methods below are suitable for producing a podcast of the very common type where you 
talk over a music background or have talk interspersed with music.

This tutorial assumes that you have figured out how to connect your microphone to your 
computer and get the sound from the microphone into Audacity.

Introduction 
The objective in this tutorial is to record a simple narration, add some background music, cut the
narration to fit the music, lower the volume of the music during the narration, and finally mix and 
export the final product. 

Give yourself an hour or so to complete this tutorial. 

On your first attempt: 

• don't try to create a masterpiece 
• don't work on something critical. 

You are learning and experimenting, exploring the many tools Audacity offers you. Don't expect 
to get it perfect the first time. 

It really doesn't matter what your narration is about, and whether you read it or ad lib. It also 
doesn't matter what the music is, but an instrumental track is preferable. 

Step 1: Record the narration 
Consider where your microphone is going to be in relation to everything else in the room. Try to 
place it so that it picks up a minimum of computer noise (hard drives, fan). When speaking into 
the microphone, point the microphone at your mouth but don't point your mouth at the 
microphone. If you can, place the microphone so that you are talking past it - think David 
Letterman and that microphone he has on his desk: he's always talking over it. Setting up the 
microphone so that it is level with your mouth but a little off to the side also works. This avoids 
"popped p's" and other breath effects from ruining your recording. Finally, try to set up the 
microphone so that it is 4 to 6 inches away from your mouth. 

While you are talking, try to keep looking in one direction - moving your head left or right, up or 
down, while you're talking will change the tonal quality of your voice, and may be distracting to 
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your listeners. Speak in a normal, conversational tone of voice, but also speak clearly and 
enunciate carefully. Your listeners can't see you so don't have the visual cues they would have if
your were speaking to them in person. 

So let us begin ...  

Start Audacity: a new untitled project window opens. Click on File > Save Project As... and name
your project. 

You are now ready to record the narration. Don't worry about mistakes, pauses, coughs and 
similar - we can edit those out later. In fact you may want to make a few deliberate mistakes so 
you can practice editing them out later. When you stop to make a correction, go back to the start
of a natural break - sentence or phrase - and start again in a normal voice: once you've tried to 
edit out your mistakes you will realize the importance of this. 

Click the Record button  in the Transport Toolbar. Record your narration. 

Step 2: Edit the narration 

Cutting out the mistakes
Don't edit too tightly - the final result should sound natural. Use Audacity's Cut Preview feature 
to hear how each edit will sound before you make the edit. Then listen back to each edit - undo 
and try again if it doesn't sound natural. 

The image below shows a situation where the speaker paused, cleared his throat and continued
with the next sentence. We want to take out the throat-clearing plus enough space around it to 
make it sound natural. 

As you can see, the portion to be removed is selected. Press the  C  key to hear two seconds of 
audio before, and one second of audio after the selection - this lets you hear what it will sound 
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like after the selection is deleted. This is called "Cut Preview". Adjust the length of the selection 
until the edit sounds natural. Various ways to adjust a selection were discussed in the Editing an
Existing File tutorial. When you are happy with the selection, press the Delete key, choose Edit 
> Remove Audio or Labels > Delete or press CTRL + K to delete the selection. 

If you want to hear more than two seconds before or one second after the selection choose Edit 
> Preferences (on Mac it's Audacity > Preferences), select the Playback  section, and in the Cut
Preview section set the "Preview Before Cut Region " and "Preview After Cut Region " times 
to your liking. 

Continue in this manner correcting the mistakes until you are satisfied with the end result. 

Save your work. 

Leveling out the volume
Unless you are professional narrator or voice-over specialist there are probably level (volume) 
variations during your narration. Remember, your listeners can't see you, so having a consistent
volume for your narration is important so they'll be able to hear and understand everything 
you're saying. 

You could go through and manually adjust the volume throughout your narration track using the 
Envelope Tool, but there's an easier way - use Audacity's built-in Compressor effect. Click on the
Track Control Panel of your narration track to select the entire track then choose Effect > 
Compressor. The Compressor is a complex but very useful effect, so let's take a moment to see 
how it works. 

The Compressor effect works by making the loud parts quieter, then amplifying everything, 
which ends up making the quiet parts louder. 

• Check  Make-up gain for 0dB after compressing and  Compress based on Peaks. 
• The former means that Compressor will maximize the volume of the track after it 

does its work. The latter means that Compressor will look at the peaks of the 
waveform rather than its average value. 

• The "Threshold " control is the "tipping point" - the point where Compressor decides if 
something is "loud" (and should be made quieter) or "quiet" (in which case it leaves it 
alone). 

• For our first pass we'll set "Threshold " to "-12 dB". 
• The "Noise Floor " control tells Compressor that anything below that level is noise and it 

shouldn't make it any louder. 
• For now we'll set that control to "-80 dB". 

• The "Ratio " control tells Compressor how much quieter it should make the loud parts. 
• Set it to "6:1". 

• Set the "Attack Time " to "0.5 secs" 
• Set the "Decay Time " to "1.0 secs". 

• These two controls tell Compressor how fast it should respond to changes in 
volume. 

Click the OK button and let Compressor do its work. Listen back to the result. 
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• Are the quiet parts still too quiet? Choose Edit > Undo Compressor and try again with a 
Threshold setting of -18 dB. 

• Does your voice sound unnaturally squashed? Undo and try again with a Threshold 
setting of -6 dB. 

Note that once you've gone through setting everything up the first time, on subsequent tries you 
just change the Threshold. This make it easy to home in on the setting that works. 

When you have your narration edited to your liking, be sure to save your project. Now it's time to
add the music. 

Step 3: Import the background music file 
Choose File > Import > Audio and open the background music file you've chosen for the project. 
Audacity imports the music file into your project and puts it in its own stereo track. 

Click the Skip to Start button  on the Transport Toolbar, then click the Play button . Note that
Audacity automatically mixes the music and narration for you. Click the Stop  when 
you've heard enough. 

Look at the Track Control Panel at the left of each track. Note the "Mute " and "Solo " buttons. 
You can use these to control which tracks you hear when you click the Play button. Clicking the 
"Mute " button will turn that track off - it will not be included in the mix when you press the Play 
button. Clicking the "Solo " button will cause only that track to be heard when you press the Play
button. The exact behavior of the Solo button can be set in the Tracks Preferences panel. 

Step 4: Time-shift the tracks 
The Audacity Tracks and Clips page describes how to use the Time Shift Tool to slide clips 
around. 

Cutting the Narration Track
Start by clicking the "Solo " button on the narration track - we don't want to listen to the music 
track while we're doing this work on the narration track. 

For the purposes of this tutorial we will assume that we want to cut the narration into three 
separate segments. Each of these segments will begin when the music makes a dramatic 
change. 

Find the spot between the first and second portions of the narration. Using the Selection Tool 
click at this point. Choose Edit > Clip Boundaries > Split - a split line appears. There are now 
two clips on the narration track. Similarly, put a split point between the second and third portions
of the narration. The narration track will now look something like this: 
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Marking the places in the background music track wh ere you want the 
narration clips to start
Remember, our goal is to cut the narration to fit the music. So our next step is to pick the spots 
in the background music track where we want the three narration clips to start 

Click the "Solo " button on the narration track to turn off the Solo function on that track. Click the 
"Solo " button on the background music track so you will only hear that track. 

Identify the point in the background music track where you want the narration to begin. Click at 
that point with the Selection Tool. Choose Tracks > Add Label at Selection. Type a name for the 
label, for example "First Narration". 

Similarly, identify the points in the background music track where you want the second and third 
narration clips to begin, and create labels at those points. Your project window should look 
something like this: 
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Moving the clips to work with the music
Click the Solo button on the background music track to turn off the Solo function on that track, 
so we can hear both the narration and music tracks. 

Using the Time Shift Tool drag the third narration clip so that the start of the clip lines up with 
the third label. Audacity will help you line this up perfectly - when the start of the clip lines up 
with the third label a yellow Boundary Snap Guide will light up. Similarly, drag the second 
narration clip to line up with the second label, and drag the first narration clip to line up with the 
first label. Your project window should now look something like this: 
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Step 5: Adjust relative volume levels 
You now have the narration clips where you want them. It's now time to adjust the volume of the 
background music so your listeners can hear what you're saying. There are at least two ways to 
do this: manually with the Envelope Tool, or automatically with the Auto Duck effect. 

Using the Envelope Tool
Details on how to use the Envelope Tool are here. You may want to read that page before 
continuing. 

Zoom in on the first narration clip. A quick way to do this is: double-click on the first narration 

before the first narration clip begins. Click to create a second control point just as the narration 
starts. Drag the second control point down to reduce the volume of the music track. Click in the 
Timeline a few seconds before the start of the first narration clip to hear the effect. Press SPACE
to stop playback. Adjust the first and second control points to get the length and depth of the 
fade you want. In a similar manner create the fade up at the end of the first narration clip. 
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You could continue in this manner doing the fades on the music track for each clip in the 
narration track. Or you could try using the Auto Duck effect. The advantage of using the 
Envelope tool is that you can always go back and change the fades. Auto Duck, being an effect, 
permanently alters the music track. 

Step 6: Smooth fade of the background music 
Unless you're very lucky (or have planned very, very well), the music probably goes on for some
time after the narration is finished. In this case you'll want to fade out the music. Decide how 
long you want the music to continue a full volume after the narration has finished, and how long 
you want it to take to fade out. 

Using the Selection Tool, click in the music track at the point where you want the music to be 
completely faded out. Choose Edit > Select > Cursor to Track End. Press the Delete key. Now 
click at the point where you want the music to begin fading out. Again choose Edit > Select > 
Cursor to Track End, then Choose Effect > Fade Out. 

Step 7: Check your mix 
If you maximized the volume of your narration track back in Step 2 there is a good chance that 
when you mix it with the music track the resulting mix will be too loud and cause clipping - this is
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a bad thing. Remember, we maximized the volume and leveled out the loud and soft passages 
so that people would be able to hear you. To check for clipping, play back a short portion of the 
project where there is narration and background music. Watch the playback level meters - if 
clipping occurs the red "clip bars" will appear at the right-hand end of the playback meters. If this
happens, use the Track Gain Slider to turn down the volume of both the narration and music 
tracks to -2 dB. Listen to the short section again and look for the red clip bars on the Playback 
Meters. If clipping still occurs, turn down the volume of the narration and music tracks to -4 dB 
each. 

Step 8: Save and Export 
The "File > Save " command just saves the Audacity project. You need to export  your project in 
order to use it with other audio programs. When you export your project, Audacity automatically 
mixes it, so the exported file sounds just like what you hear when you click the Play button. 

Make sure there are no unwanted bits of audio far along the time line or your exported file will 

be unexpectedly long! Click on the Fit Project  in the Edit Toolbar. If the expected 
length of your final mix is displayed in the window, all is fine. If the displayed time line is much 
longer than your actual production, look for the unwanted bits of audio and delete them. You 
may need to click just past the real end of your narration/music and delete everything from there
to the end of the track(s). 

Audacity can export in a variety of formats. The two most commonly used are MP3 (for podcasts
and similar) and WAV (for burning to CD). In order to export to MP3 format you must first install 
the optional LAME MP3 encoder. 

Optional - Mix and Render
You may want to Mix and Render your project before you export it. The Mix and Render 
command (in the Tracks menu) will mix your project, and put the resulting mix in a new track 
(this is the "render" portion of the command). This gives you the opportunity to maximize the 
volume of the final mix, and do a final check for clipping. If you would like to try this, follow these
steps: 

• Choose Edit > Select > All 
• Mix and Render only mixes the selected tracks - you want to mix all of them 

• Choose Tracks > Mix and Render 
• your project is mixed into a new stereo track and the previous, separate tracks are 

deleted 
• Choose View > Show Clipping 

• The Show Clipping command will put red vertical bars anywhere clipping has 
occurred in your track. If any red bars appear, choose Edit > Undo Mix and Render
and go back to Step 7. 

If no clipping was detected, proceed: 
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• Click in the Track Control Panel of the newly-created track 
• Choose Effect > Normalize 

• accept the default values and click the OK button. 
• the volume of your final mix is maximized. 

You exported a project in a previous tutorial. If you need a refresher on how the File > Export 
command works, that information is on the File Export Dialog page. 

Congratulations, your narration over background music is now ready to share with the world. 

Publishing your Podcast
Publish your Audacity-created podcast on the internet is in some ways the most important stage 
of all. Unless you podcast purely to entertain yourself, you want others to hear what you have to 
say.
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Recording with USB turntables or USB cassette decks

Audacity is often included with USB turntables, USB cassette decks or USB sound cards, and is
suitable for recording from any USB audio device using the instructions on this page.

USB audio devices connect to the computer's USB port and are used to transfer records, or 
tapes, to digital audio files (from which audio CDs can be burnt). This is very useful if your 
computer doesn't have the necessary line-in port for digitizing LPs or cassettes with a 
conventional turntable or tape deck. USB turntables often include a line input to which standard 
tape decks or similar sources can be connected for transfer to the computer.

Much of the information on this page, and the pages linked to below, also apply to recording with
USB tape cassette decks and audio devices connected with external USB sound cards. 

Please see the Audacity Wiki page on USB Turntables for a fuller discussion of the operation of 
these devices. 

Some users with extensive experience of digitizing LPs and tapes believe that connecting a 
good quality conventional turntable or tape deck to an external USB interface or sound card is 
an ideal solution. USB sound cards usually do not suffer from the transmission problems of USB
turntables or tape decks, and are also free from the random clicky noise that can afflict sound 
devices built into computer motherboards. Moreover their analogue-to-digital converter (ADC) 
may be superior to that provided with a USB turntable 

Ensure the Audacity software is up to date 
Make sure you have the current version of Audacity as the software provided on the device 
manufacturer's CD can be out-of-date. Note that neither the version number of the CD nor that 
of any guides produced by the manufacturers necessarily relates to the Audacity version 
number. To check your current version of Audacity, choose Help > About in the menu (or 
Audacity > About Audacity on OS X). Then go to the Audacity download site and, if needed, 
download the latest Audacity for your operating system. 

Manufacturer's guides 
The guides provided with the devices might be confusing, they are written by the device 
manufacturer rather than by Audacity. Sometimes the guides supplied with the devices are out-
of-date or have errors. Here are some errors that you may come across: 

• Many manuals state that you should "select stereo mix for your input". This is not the 
case, rather you should be setting the USB device as your input . 

• Audacity Preferences are not under the File menu , as many manuals state, except in 
the legacy 1.0.0 version of Audacity which is only appropriate for Mac OS 9 and Windows
95. Preferences are under the Edit menu, or under the Audacity menu on OS X. 
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• You do not need to select Monitor Input each time y ou launch Audacity , as some 
manuals urge you to. Monitoring the input is optional and allows you to hear the device 
through the computer speakers just like an ordinary turntable, or cassette deck, whenever
it's playing, without having to record. If you want to select Monitor Input, you need to have
the Meter Toolbar enabled (note: NOT the Mixer Toolbar that some guides state). 
Instructions on this are below. 

Set up Audacity to record from the USB audio device  
Connect the USB cable of the device to the computer. Connect to an empty USB port on the 
computer, not to a USB hub (a device that allows multiple USB devices to be connected to one 
of your computer's USB ports). Then launch Audacity. If Audacity was already running when you
connected the cable, restart Audacity or choose Transport > Rescan Audio Devices. 

• Set the Audacity Project Rate in Selection Toolbar at the bottom left of the Audacity 
screen to 44100 Hz: 

• Use Device Toolbar to set the input (recording) and output (playback) devices and set the
channels to "2 (Stereo) Input Channels": 

In the above example on Windows 7 
• the output is set to the named speakers of the built-in computer sound device, 
• the input is set to the USB device (usually called or including the phrase "USB 

Audio CODEC") 
• recording channels are set to stereo. 

Windows Vista and later call most USB external devices "microphones" but Windows XP 
and earlier do not. Some higher-end USB recording interfaces may appear as their 
explicit manufacturer's name.

Operating System Specifics:  

• On Windows Vista/Windows 7/Windows 8 : 
1. By the system clock, right-click over the Speaker icon > Recording Devices then 

right-click over USB Audio Codec > "Properties". 
2. On the "Advanced" tab, in the "Default Format" section, make sure the drop-down 

menu is set to "2 channel 16 bit 44100 Hz" .
• On Mac OS X:  

1. From Apple Menu > System Preferences select "Sound" and click on the "Input" 
tab 

2. Select "USB Audio CODEC" or similar as the input device and verify the meter 
shows input. If not, from the Finder, select Go > Utilities >, and open Audio MIDI 
Setup  click the Audio Devices tab, then select your USB device in the "Default 
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Input " and "Properties for " drop-downs. Choose "44100.0 Hz"  and "2ch-16bit" .

• From the Transport Menu check "Software Playthrough"  to be "on" to hear the turntable
through the computer speakers; this setting can be toggled on/off easily from the 
Transport Menu. 
These settings will be stored in your Audacity Preferences under the Devices and 
Recording sections and will be remembered when you next relaunch Audacity. 

• Set your recording level:  
• Turn monitoring on by clicking once on the microphone icon in the Meter Toolbar. 

• Go to the Mixer Toolbar and turn up the left-hand output volume slider (by the 
speaker icon). 

• The right-hand input volume slider (by the microphone icon) can often be used to 
vary the loudness of the recording, but it may not function with all turntables. If it 
does not, try adjusting the input level on the turntable (often, there is a gain control 
under the chassis). Alternatively, you may be able to set this in the operating 
system mixer (right-click over the speaker icon by the system clock). 

• Try to aim for a maximum peak of around –6 dB, which corresponds to around 0.5 
on the waveform. You can always boost the level later with Effect > Amplify... or 
Effect > Normalize... after you have completed editing. 

Possible solutions for excessive output volume if t here is no gain control on the USB 
audio device:  

• If the device has RCA leads  for connecting to speakers and your computer has a line-in 
port (blue), plug the RCA leads into an RCA stereo > 1/8 inch stereo TRS adapter 
(obtainable from most electronics retailers), then connect the adapter to the line-in. Set 
Audacity to record from line-in then you can use the Audacity input slider to control the 
level. 

• If you have no line-in, do not use the microphone (pink) input unless there is a way
to switch it to line-level stereo or unless it offers line-level stereo compatibility. 

• If the cartridge is replaceable , take it to a hi-fi shop and see if you can get a lower 
output cartridge. If the cartridge is ceramic (cheap USB turntables often use these) it will 
have a high output. Replacing this with a magnetic cartridge will give lower output and 
better quality. 

• Then, ignoring any instructions in the manufacturer's guide to select "stereo mix", simply 
press the red Record button  in Transport Toolbar to start recording from the turntable. 

Recording, editing and exporting 
• make and edit your recording 
• export it to an audio file 
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• import it to iTunes or Windows Media Player 
• burn it to CD 
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Splitting a recording into separate tracks

Introduction
The following tutorial demonstrates one method  for dividing a recording into separate songs for 
export in preparation for burning those tracks to an audio CD. Others may recommend slightly 
different methods. It is worth going through this tutorial as it introduces the basic concepts of 
identifying and marking the boundaries between songs, and using labels to identify songs in 
support of the Export Multiple command. 

Live recordings versus studio recordings  

Sometimes songs on live recordings flow together. If you want to split a live recording into songs
but want to maintain an uninterrupted flow from song to song on the CD you need to have 
burning software that is capable of burning a CD in "disk-at-once" (DAO) mode, and is capable 
of setting the "gap" or "pause" between tracks to 0 seconds. 

Step 1 - Remove unwanted audio from the recording 
1.  
2.
3. Zoom in until you can see from the start of the track to the start of the music 
4. Click and drag from the start of the music to the start of the track 
5. Click on Edit > Remove Audio or Labels > Delete 

Similarly, remove unwanted audio from the end of the recording and from the middle (between 
sides 1 and 2 of the LP or cassette). Note that later in this tutorial we will be using the Analyse > 
Find Silences command to identify spaces between the songs, so when you are editing the 
transition between side 1 and side 2 be sure to leave 2 or 3 seconds of silence, similar to what 
you would find between songs. 

Save your work!  Click on File > Save Project. 

Step 2 - Label the Songs 
Mark the first song  

1.  
2. Click on Tracks > Add Label at Selection, or use shortcut CTRL + B

A new label is created in a new label track underneath the audio track. The contents of 
the label are selected and ready for editing. If you need to play the track to decide where 
to place the split points, you can use "Add Label at Playback Position" instead (directly 
underneath "Add Label at Selection", or use shortcut CTRL + M (on Macintosh it is 
Command + .)).

3. Type the title of the first song 
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• On Windows, do not use:   \   /   :   *   ?   "   <   >   | 
• On Mac, do not use  /   :  
• On Linux, do not use   /  

Mark the rest of the songs  

1.
2.

song 
3. Click as closely as possible to the start of the song 
4. Click on Tracks > Add Label at Selection, or use shortcut CTRL + B 
5. Type the name of the song into the label 

6.  until you can see the start of the third song 
7. Continue in this manner adding a label to mark the start of each song 

You can save time by using Analyze > Silence Finder to automatically add labels in the silences,
or Analyze > Sound Finder to label the regions to be exported for the songs. The Sound Finder 
method thus lets you exclude some or all of the areas between songs.

Both these effects depend on correctly detecting the "silences" between tracks and this depends
on setting their parameters appropriately for your track. See this example of adjusting Silence 
Finder parameters in order to place labels correctly between the songs.

Step 3 - Maximize the volume of the recording 
If you did the original recording properly and avoided clipping, the recording is probably not at 
the maximum possible volume. In order for the CD to be burned at maximum volume and thus 
match other CDs in your collection we need to fix this. 

1. Click on Edit > Select > All, or use shortcut CTRL + A 
2. Click on Effect > Normalize... 

The default choice in this dialog is to amplify to a maximum of -1.0 dB. The maximum setting is 
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0 dB, but the default setting of -1.0 dB provides a little headroom as some players can have 
playback problems with audio at 0 dB. 

Some consumer-level turntables, tape decks and/or amplifiers may well record stereo channels 
with a stronger signal in one channel than the other, which you will probably want to correct. In 
that case, check the box that says "Normalize stereo channels independently".

One problem when copying records is that a loud click in one channel can cause Normalize to 
create an unwanted change in the stereo balance. In that case you should consider removing 
the click before the Normalize step, using Click Removal. 

Step 4 - Export
Congratulations, you are now ready to export the tracks. 

1. Click on File > Export Multiple.... 
2. Choose the Export Format  from the pop-up menu: 

• for CD burning choose 16-bit WAV if using Windows or Linux or AIFF if you're 
using a Mac 

• for loading into an MP3 player, choose MP3 
• for loading into iTunes/iPod you can export as WAV and use iTunes to convert the 

WAVs to AAC or MP3. 
3. Click the Choose... button and pick the place where your exported tracks will be saved. 
4. Under Split Files Based On: 

•  Labels should be checked 
•  Include audio before first label should be unchecked, as there is no audio before

the first label 
5. Under Name Files: 

•  Using Label/Track Name should be checked. 
6. Click the Export button. 
7. Metadata Editor will appear for the first song. The Track Title and Track Number will be 

pre-filled from the labels, but you can enter any additional information for that song that 
you wish (for example, Artist Name and Album Title). 

8. Click the OK button in the Metatdata Editor (not  the Save button). 
9. Metadata Editor will appear for the next and the subsequent songs; as before, enter any 

additional information and click "OK" for each window. When you click "OK" on the 
window for the last song, all the files will export. 

Metadata in this context refers to information "tags" stored in the audio file such as Artist, Album 
and Song Title. 

• Often you may have an album where most tags (such as Artist Name) are common to all 
tracks. If you choose File > Edit Metadata... before exporting and add the common tags 
there, Audacity will pre-fill these when the metadata window for each song appears. 

• If all your tags are common to each song (except of course for each song's Track Title 
and Track Number), you can enter the common tags before export as above but export 
silently without the metadata window appearing. To do this, choose Preferences, then the
Import / Export tab, and uncheck Show Metadata Editor prior to export step . 

• Hiding Metadata Editor at the export step can also be useful if you mainly export WAV 
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files for which many audio players don't recognize tag information. Use AIFF (in iTunes or
VLC) or FLAC if you want full metadata in lossless files. 

A progress dialog might appear if the process takes more than a second or two. When the 
process is finished a confirmation dialog will appear listing the files that were created. 

The tracks are now ready to import into the CD burning software of your choice. 

If you burn a CD with a gap of zero seconds between tracks (if your burning software supports 
this), you will end up with an exact replica of the LP or cassette. If, when burning the CD, you 
add the standard 2-second gap between each track you will be adding an additional 2 seconds 
to the existing silence between tracks, and the vinyl surface noise or cassette hiss will suddenly 
disappear which some listeners may find annoying. See Refinements , below, for ways of 
dealing with this.

Refinements

Remove the "silence" between songs
Of course, the space between songs is not really "silent" - it contains vinyl surface noise or 
cassette hiss. Using standard editing techniques you can select and delete these portions of the
recording, then insert whatever gap (silent portion) you want when burning the CD. 

If you will be listening to the songs primarily on a computer or MP3 player you may prefer to 
have some silence at the end of each song. In this case select the silent portion then click on 
Edit > Silence Audio. Now you can edit the length of the silent portion to your taste. Alternatively 
you can delete the silent portion, then click on Generate > Silence and specify exactly how 
much silence you want. 

Avoiding a sudden cut-off of vinyl surface noise or  cassette hiss
Both of the above techniques will result in the vinyl surface noise or cassette hiss suddenly 
stopping, which some listeners may find annoying. You can avoid this by using Effect > Fade 
Out at the end of each song. You can do the fade-out after the music ends (in effect fading out 
the noise). 

Alternatively you can fade out the last second or so of the song if that works with the music. If 
fading the last seconds of the music you may prefer to use Effect > Studio Fade Out as that 
should give you a smoother and more "musical" sounding fade out. 

Experiment and listen to the results to decide what works for you and for the music you are 
working on. 
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Burning music files to a CD
This page provides an overview of how to burn an audio CD.

Audacity does not burn CDs directly but audio files created with Audacity can be used with a CD
burning program to create an audio CD.

Audio CDs
There are two main types of CDs that you can create with CD burning software: audio CDs  and 
data CDs . 

• To ensure that you create a CD that will play anywhere it is important to choose the 
option to burn an "Audio CD" or "Music CD" and not a "Data CD". A data CD containing 
for example MP3 or WAV files will play happily on your computer but is unlikely to play in 
a standalone CD player or in-car CD player (note that some modern CD players will play 
data CDs). An audio CD will play on any standalone or in-car CD player and in your 
computer and in modern DVD players. 

Audio CDs don't have files or a file system like data CDs and other computer storage media, but
consist essentially of a stream of bits on the disk in a single spiral "track" with a TOC (Table of 
Contents) index.

• Audio CDs are generally limited to 74 minutes playing time on a 650 MB disc ("Red Book 
Standard") or 80 minutes on a 700 MB disc. 

• When buying blank CDs for burning, it is strongly recommended that you purchase good 
quality CD-Rs (that can be burnt just once) and not the rewritable CD-RWs. 

Audacity setup
Audio CDs always contain uncompressed PCM stereo audio at 44100 Hz sample rate, 16-bit 
sample format. So to burn an audio CD, export the file(s) you want to burn as a 44100 Hz 16-
bit stereo WAV or AIFF file. 

To configure Audacity for this: 

1. At the bottom left of the Audacity window, set the Project Rate to 44100 Hz. 
2. Some CD burning software require you to have a stereo track. If your Project does not 

already contain a stereo track, click Tracks > Add New > Stereo Track. It does not matter 
that this track is empty, its purpose is just to make Audacity export your recording as a 
stereo file. This step is not needed if you are burning to CD with iTunes or Toast. 

3. Click File > Export and choose "WAV (Microsoft) signed 16 bit PCM" in the "Save as type"
box. 

It may be possible to use other formats if your CD-burning software supports them, but they may
not give the best quality or they may not be playable on all CD players. 
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If you experience clicks at the start or end in the resulting CD tracks, this may because your CD 
burning drive or software does not correct for track splits made outside CD frame boundaries. To
enable splits at CD frames, right-click or use the context key when over any of the three fields in
Selection Toolbar, then choose one of the selection formats for CDDA frames . This may also be
required if burning gapless CDs.

Multiple songs
If you are exporting a long Audacity track that contains multiple songs, please see "Splitting a 
recording into separate tracks" for how to export multiple files for each of the songs by using 
labels to identify songs for the Export Multiple command to operate on. 

An alternative method is to use Cue Sheets to define individual songs. 

Burning software
In order to burn an audio CD you will need a CD burning program. Most computers already 
come with media player software that can burn CDs. For example, you can use Windows 
Media Player  built into Windows or iTunes  built into Macs. In either of these programs, drag the
files you want to burn from the location you exported them to into a "playlist" ready for burning. 

Ensure in either Windows Media Player  or iTunes  that you select the option for burning a 
"Music CD" and not a "Data CD" as mentioned above. 

You can also use a standalone Windows burning program like CDBurnerXP, Deep Burner or 
Nero  (or Burn or Toast  for Mac OS X) to burn your exported files. Most Linux distributions 
include Brasero  or K3B  for CD burning. When using standalone burning programs, open the 
files from within that software, do not drag and drop them from your file manager. Once again 
don't forget to select the setting to burn an "Audio CD" or "Music CD" as explained above. 

Common Pitfalls  

• Wrong sample rate: Most CD burning software expects all files to be at 44100 Hz. 
• Unsupported formats: Some CD burning software does not support compressed formats 

such as MP3, Ogg, or M4A/AAC. 
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Gapless burning
By default, many CD burning programs add a two-second gap between CD tracks as part of the 
standard for audio CDs. So be aware of CD track gaps when placing labels between album 
tracks for Export Multiple and consider deleting excess silences between tracks. 

However most CD burning programs have an option to burn the CD with no gaps between 
tracks. This is useful for recordings such as live concerts, allowing the CD to play continuously if
the player supports gapless playback while still permitting skipping to individual CD tracks. If 
burning a gapless CD, you will need to place the Audacity labels exactly where you intend the 
burner to mark the track splits. Some CD burning programs (for example, older versions of 
Windows Media Player) have no option to burn without gaps. Gapless burning is also only 
available if the optical drive supports Disc-At-Once (DAO). 

Additionally, make sure you don't export MP3 files for burning to your gapless CD, even if you're
burning a "data CD", because MP3s have inherent silence padding due to a restriction of the 
MP3 format. 

Note you may still hear the most momentary gaps between tracks even on DAO burned CDs, 
unless the CD player supports true gapless playback. Many CD players do not support gapless 
playback properly because the hardware simply doesn't buffer the audio data properly. However
quite a few computer-based media players can use DSP effects when playing back audio to 
give proper gapless playback, even of CDs not burned with DAO. An example of such a player 
is Apple's iTunes. 

Cue Sheets
An alternative solution is to not split the track up at all in Audacity. The best way to get 
apparently gapless playback of a live concert recording or live album is to burn as one WAV file 
with with DAO and a "cue sheet" that marks the starting times of each CD track. Cue sheets can
be created as simple plain text files. 

Each track in a Cue Sheet is of this format: 

• TRACK (number) AUDIO 
• TITLE "(name)" 
• PERFORMER "(name)" 
• INDEX 01 (start time) in the format minutes:seconds:frames with the first track always 

being 00:00:00 

Audacity cannot currently export Cue Sheets but it is possible to use the File > Export Labels 
command to export a text file representing the label positions, then on Windows and Linux use 
label2cue to convert the minutes and seconds data in the text file to minutes, seconds and 
frames data laid out in cue sheet format. 

You can read more about cue sheets on Wikipedia here.
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Burning longer recordings to disc
As stated above audio CDs are generally limited to either 74 or 80 minutes, however it is 
sometimes possible to achive longer times by using Overburning. Alternatively, for longer 
recordings, you may be able to use data discs provided your player will support and play these. 
(A data CD will not normally play on older standalone CD players. It will play on computers, 
most DVD players and in MP3 CD players). 
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Recording audio playing on the computer
This tutorial outlines solutions for recording audio playing on the computer, (for example, audio 
being streamed from an internet web site). How or if you can do this depends on your computer 
operating system, your sound card and its drivers.

Generally, it is better to extract or import audio from CDs, DVDs or existing video or 
audio files than record them as they play.  Recording from an analog sound card is relatively 
inexact and lossy because the digital source is converted to analog to play it, then back to digital
to record it. The resulting quality will depend (amongst other things) on the quality of your sound
card's digital to analog and analog to digital converters. 

• To extract audio CD tracks to your computer, see Audio CDs. 
• To import additional types of audio file or extract audio from video files, download and 

install FFmpeg, then import the file. FFmpeg can also extract audio from the individual 
VOB files stored on unencrypted DVDs. 

Step 1: Set up devices to capture computer playback
This is often the hardest part of the overall task, being dependent on your computer operating 
system and sound card. Many manufacturers are making it increasingly difficult to record 
streaming audio by deliberately removing or hiding this functionality due to copyright concerns. 
Sometimes, older sound card drivers can be found on the web site of the sound card or 
motherboard manufacturer that still allow recording of computer playback. 

This section of the tutorial shows how to find a suitable sound card input for recording computer 
playback, with workarounds if such an input is not available.
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Recording Computer Playback on Windows

To record computer playback, Audacity relies on your sound device making an input available 
that can record playback. This is often the case on older Windows machines, so only requires 
selecting the correct input in Audacity. 

Due to copyright concerns, newer computers often lack an input for recording computer 
playback, or it must be specially enabled outside Audacity. 

This Tutorial therefore presents many options for recording computer playback. Please always 
respect the copyright of others when recording.

Choosing the input in Audacity
Choose the input intended for recording computer playback in the third (Input Device) box of 
Device Toolbar. The Input Device box is selected (blue) in the image below: 

You can also choose this input device at Recording Device in Devices Preferences. 

• If the computer's sound device provides an input for recording computer playback, 
choose its name. It could be called "Stereo Mix", "Wave Out", "Sum", "What U Hear", 
"Loopback" or other names. The exact name and whether such an input is available 
depends entirely on the drivers of your sound device. 

• On Windows Vista, Windows 7 or Windows 8 only  you can choose the Windows 
WASAPI  host (in the first box in Device Toolbar) and then the (loopback) input in the 
Input Device box. Choose the loopback input for the computer sound device you will be 
listening to (for example, "Speakers (loopback)" ). The loopback input records computer 
playback even if your sound device lacks its own stereo mix or similar input.

Note that on many devices the Mixer Toolbar input volume slider will be grayed out when 
selecting the Windows WASAPI host, and even if not grayed out, the device may not 
support Audacity or the system input slider adjusting its volume. So to control the 
recording level, adjust the output level of the audio. This is best done in the application 
that is playing the audio, for example the video or audio player on the web site you are 
recording from. Even if the Audacity output slider is able to control the volume of the 
audio you hear while recording, it will not affect the level you record at.

You must play the audio you want to record using the same sound card that has the stereo mix 
or similar input. You cannot play audio through a USB headset or USB speakers device then 
record that playback using the stereo mix input of the built-in sound device.

Exit Audacity and continue reading below if you do not see an input for recording computer 
playback. 
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Windows Control Panel for sounds
Windows Vista, Windows 7 and Windows 8 computers al most always only have 
microphone inputs enabled by default.  Earlier Windows systems may also need the input for 
recording computer playback to be made visible before Audacity can use it. To show or enable 
inputs, launch the sound device control panel from the Windows Control Panel or from the 
system tray (by the clock). 

• Windows Vista, Windows 7 and Windows 8  

1. Right-click over the Speaker icon by the system clock then choose Recording Devices to 
open the Recording tab of "Sound". 

2. Right-click anywhere inside the Recording tab and choose "Show disabled devices"  
then right-click again and choose "Show Disconnected Devices" . 

3. Right-click specifically over the input device you want to record with (in this case "Stereo 
Mix" or whatever alternative you have), and if visible, choose "Enable" . 

4. Sometimes it helps to right-click over the "stereo mix" or similar device again and choose 
"Set as Default Device". 

5. If you need more help, see these Wiki instructions for Windows Vista, Windows 7 and 
Windows 8. 

• Windows XP or earlier  

1. Right-click over the Speaker icon by the system clock then choose Adjust Audio 
Properties. 

2. In "Sounds and Audio Devices Properties" or similar, click on the Audio tab, then in the 
Sound recording panel, select the "Default device" you are trying to record from (this will 
probably be the name of your built-in sound device). 

3. Click the Volume button. 
4. If you can see a stereo mix or similar option, try clicking in its box to select it. 
5. Otherwise, choose Options then Properties. 
6. In the window that appears, click the "Recording" radio button, then in "Show the 

following volume controls", click in the box for stereo mix or similar, then "OK". 
7. If you need more help, see these Wiki instructions for Windows XP. 

RealTek and other sound card control panels
If you still have no stereo mix input in Windows, sometimes this input can be enabled in the 
sound card's own control panel, especially with older RealTek devices. The sound card's own 
control panel can be found in the Windows Control Panel. Hints for RealTek control panels: 

• Some panels "select" an input by muting all but one, so in this case, mute everything 
except Stereo Mix 

• If you don't see Stereo Mix, click the wrench or spanner icon and enable Stereo Mix in 
the dialog that appears 

• In some panels the option to choose is "Enabled recording multi-streaming" 
• You should now see a volume control for Stereo Mix; make sure it is selected or 

unmuted. 
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Updating sound device drivers
If there is still no suitable input, try updating the sound device drivers for your sound card. This 
can sometimes produce an additional input for recording computer playback, and may fix other 
problems such as poor quality or skipping. 

Loopback cable
An alternative method of recording audio playing on the computer is to buy a cable with 1/8 inch 
(3.5 mm) stereo connectors at each end. Suitable cables are available from almost any audio 
retailer. Connect one end of the cable to the computer's audio output (green) and the other end 
to the line-in input (blue). Then choose the line-in as input device in Audacity. 

To hear what is playing while you record it, buy a single stereo to double stereo adaptor 
to plug into the audio output. This gives you a spare jack to plug the speakers or 
headphones into.

Alternative programs for recording computer playbac k
You can use other programs to record computer playback that do not rely on the computer 
sound device having this ability. These programs will make an audio file which can then be 
imported into Audacity for editing. 

All the options below grab the audio digitally from the application producing the sound. This has 
advantages over stereo mix recording. Lossy digital-analog-digital conversions are avoided and 
also unwanted system beeps and alerts are not captured. 

• SoundLeech is a free program running from the system tray. It records to lossless WAV 
format only. 

• TotalRecorder is a low cost recording package. Internet streams can optionally be 
captured at faster than real time rates (monitoring is not available in that mode). 

External sound cards
A further alternative is an external USB sound card with a "Stereo Mix" type of option. An 
example known to work on all versions of Windows is "Trust Sound Expert External". Not all 
USB sound cards offer a Stereo Mix option, so read the specifications carefully before 
purchasing. 
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Recording Computer Playback on Mac

Mac computers have no ability to record streaming audio as it plays on the built-in sound device;
you will have to either employ a loopback cable or use some alternative software for the audio 
capture, in this case the resulting file should be capable of being imported into Audacity for 
further processing.

Use Soundflower
Soundflower is a free open source system add-on for Macintosh that allows you to route what is 
playing on the computer digitally back to the input without using a cable. 

You need to set Soundflower as your output  device. In Audacity, you then set Soundflower as 
your input  device. 

1. Download and install Soundflower from the Soundflower web site. As of May 2013 
clicking the "free download" link on the Soundflower site will take you to the Google code 
hosting page. On the left there is a panel with the heading "Downloads", then a 
"Featured" heading, then links for Soundflower 1.5.2 and 1.6.6. Unless you have an Intel 
Mac running 10.5.8 or later, click the "Show All" link, then choose the version of 
Soundflower for your Mac and version of OS X. 

2. Choose Apple Menu > System Preferences and select the Sound  preferences panel. 
3. In the Sound preferences panel, click on the Output tab, then select "Soundflower (2ch)" 

from the "Choose a device for sound output" list. 
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• At this point you will no longer be able to hear what is playing on the computer. 
The sound output of the computer is being sent to Soundflower. 

4. Click on the "Sound Effects" tab, and from the "Play sound effects through" drop-down 
menu choose "Line Out", "Headphones" or "Internal Speakers" (whichever is appropriate 
for your system). 

• This will route some  system alert sounds (such as Mail alert sounds) to the Line 
Out or Internal Speakers and not to Soundflower. Thus these sounds will not be 
recorded by Audacity. 

Some Macintosh applications are better behaved than others when it comes to alert 
sounds. Tests on a recent iMac running 10.7.2 show that Mail and TextEdit alert 
sounds will not be recorded with the above setup, but iCal and Yahoo Messenger 
alert sounds will  be recorded. To be safe you should disable the sound on any iCal 
alerts that may occur while you are recording, and quit any other program that may 
make an alert sound. 

5. Close the System Preferences window. 
6. Start Audacity. 
7. In Audacity's Device toolbar select Soundflower (2ch)  as your chosen Input Device

8. Click on the Transport menu and make sure that "Software Playthrough" is checked. 
9. Go to the application that will be playing the sound you want to record. For example, start

Safari and go to a web site that plays sound clips. Start some audio playing. 
10.Click on the input level meters (above the microphone symbol) to begin monitoring: 

You should now be able to hear the sound playing on  your computer.

You are now ready to record anything playing on your computer. 

To set things back to "normal" so you can hear audi o playing on your 
computer without running Audacity
1) Click on Apple Menu > System Preferences then the Sound panel, and select the Output 
pane. Select "Line Out", "Internal Speakers" or "Headphones" in the output device list. See step 
3 above for an illustration. 

2) In Audacity, if you want to record from a different source (such as the Line Input or an 
external USB device), click on Audacity > Preferences then the Devices section and select the 
input you want to record from in the Recording section. See step 7 above for an illustration. 
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To hear what is playing on the computer while using  Soundflower
When you install Soundflower, a new folder will be installed in your Applications folder called 
"Soundflower". Inside the folder is a program called "Soundflowerbed". Launch Soundflowerbed:
it will install a "flower" menu at right of your menu bar. 

The choices below the "Soundflower (2ch)" and "Soundflower (16ch)" menu items determine 
how the output of Soundflower will be monitored. "None (OFF)" means that you will not hear 
anything from your computer speakers. Selecting "Built-in Audio" will allow you to hear (monitor)
the sound that is passing through Soundflower. 

If you are using Soundflowerbed to monitor the sound, you will want to uncheck "Software 
Playthrough" in Audacity's Transport menu. 

Use a loopback cable
This is a simple and effective method of recording what is playing on the computer. It has the 
disadvantage that the audio signal is converted from digital to analog, then from analog to 
digital, instead of staying in the digital domain. This may result in some slight increase in noise 
and distortion. 

1. Using a cable with a stereo mini-plug (1/8") at each end, connect the headphone output 
port to the line input port. 

• At this point you will no longer be able to hear what is playing on the computer. As 
a workaround, you could attach a single to double stereo connector to the output 
port provide an extra jack for speakers or headphones. 

2. Choose Apple Menu > System Preferences and select the Sound preferences panel. 
3. In the Sound preferences panel: 

• Click on the Output tab, then select "Line Out" from the "Choose a device for 
sound output" list. 

• Click on the Input tab, then select "Line Input" from the "Choose a device for sound
input" list. 
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• Leaving the Sound preferences panel open, start sound audio playing on the 
computer (this could be from iTunes, or streaming audio, or some other source). 

• Adjust the Input volume slider so that the top 3 bars of the Input level meter do not 
light up on the loudest passages, but the rest of the bars do light up. 

• Close the System Preferences window.
4. In Audacity's Device toolbar select Built-in Audio: Line in   as your chosen Input Device:

 
5. Click on the Transport menu and make sure that "Software Playthrough" is not  checked. 

Audio Hijack Pro
This is a commercial program sold by Rogue Amoeba. It can "hijack" the sound output of any 
program and record that audio to disk in a number of formats. Once you have captured the 
audio with Audio Hijack Pro you can import the file into Audacity for editing. Since Audio Hijack 
Pro records the sound output of a particular program there is no danger of recording system 
alert sounds. 

If you need help editing the audio captured by Audio Hijack Pro, have a look at our tutorial on 
editing an existing file. 
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Recording Computer Playback on Linux

On Linux there are in general two different sound systems that provide drivers to your sound 
device, OSS and the more recent ALSA. Additionally, advanced sound servers such as 
PulseAudio and JACK can use ALSA to provide professional audio features such as routing of 
inputs and outputs, high quality mixing and resampling, aggregation of devices or sound cards 
and (in the case of JACK) very low latencies. 

PulseAudio 
PulseAudio is a sound server providing professional audio features such as mixing and 
input/output routing. It is the default audio device on many Linux distributions including Ubuntu, 
Open Suse and many Debian/Ubuntu based distributions. PulseAudio operates as a proxy 
between sound applications and the audio hardware (usually via ALSA). The PulseAudio 
Volume Control may be configured so that Audacity receives audio input from the output of other
applications such as Firefox or Rhythmbox. 

• If not already installed, add PulseAudio Volume Control (pavucontrol) to your system. 
This is usually available in the distribution repository. 

• Ensure that PulseAudio is running and in the Device Toolbar set the Host to ALSA  and 
the recording input to pulse . 

• On systems where PulseAudio is the default sound system the recording input may 
be set to default . 

• The output may be set to pulse  or may be set to output directly to any available 
sound card as shown below: 

• Ensure that "Software Playthrough" is not enabled in the Transport Menu. 
• Launch the application that you wish to record. 
• Left-click on the recording meter to turn monitoring on. 
• Open the PulseAudio Volume Control and open the "Recording" tab. 
• Click on the "Capture from" button and select the "Monitor" option of the sound card that 

you are using for playback as shown below: 
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• Begin playback in the application that you wish to record and set the recording level in 
Audacity. 

• Note that the playback level of the application being recorded will affect the level of 
the recording. 

For a detailed description using Ubuntu 10, see Stereo Mix with Ubuntu 10 on the Audacity wiki. 

JACK
Jack Audio System is commonly used in Linux distributions that specialise in media creation 
such as Ubuntu Studio and Studio 64. 

To use Audacity with Jack it is useful or in some cases essential to have a few additional 
packages installed. This documentation assumes that you have Jack Audio System working on 
your machine. For help with setting up Jack, please consult the documentation for your Linux 
distribution. 

Recording sounds playing from other applications is rather easy with Jack. Jack may be started 
using QjackCtl or from the command line. If Audacity is launched after Jack is started then "Jack
Audio Connection Kit" will be an available host option in the Device Toolbar. If Jack is started 
after Audacity has been launched then it will be necessary to Transport > Rescan Audio Devices
for new audio devices before jack is available to Audacity. 

Any Jack compatible applications that are running before Audacity is launched will have their 
ports available in the Device Toolbar. To make an application available to Audacity that is 
launched after Audacity it is necessary to rescan audio devices again. After rescanning audio 
devices, input and output ports from other applications will be available in the Record and 
Playback settings of the Device Toolbar. 

In this image the output of Hydrogen drum machine is being selected as the recording source. 
This will enable Audacity to record directly from the audio output from Hydrogen. If "System" is 
selected as the recording source then Audacity will record from the physical sound card input. 
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Applications that do not directly support Jack may also be used with Jack on a system that uses 
PulseAudio (such as Ubuntu and Debian based distributions) by installing "pulseaudio-module-
jack". This provides the modules "Jack Source" and "Jack Sink" that allow PulseAudio to use 
Jack. For example, to record sounds playing through Firefox, PulseAudio Volume Control 
(pavucontrol) can be used to direct the output from Firefox to Jack Sink. The recording input for 
Audacity can then be set to record from "PulseAudio Jack Sink" and the sound will be recorded. 

ALSA

Alsamixer
For systems that have ALSA but do not have PulseAudio or Jack Audio System, it may still be 
possible to record sounds playing on the computer. Alsamixer is a command line tool with "view"
options to represent the sound device graphically. It is installed by default in most desktop 
distributions. To view the alsamixer manual, open a terminal window and enter man alsamixer  
or view the manual online. 

To start alsamixer, type alsamixer  in a terminal window. If a Mix  device is shown as a capture 
device, set this as the active device to enable recording sounds that are playing on the 
computer. 

OSS
OSS was the standard audio API in Linux up through the 2.4 series of official (kernel.org) Linux 
kernels. ALSA was added starting with 2.5, in those versions, Linux kernel authors marked OSS 
as deprecated. 

Development of OSS was continued by 4Front Technology, initially as proprietary software but 
later released as partially open source. Possible solutions to recording audio playing on a 
computer using OSS are described here. 
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Other Methods

Alternative programs for recording computer playbac k
An alternative to recording streaming audio from the Internet is to download the data directly to 
disk, either by using command line tools such as streamripper or mplayer, or with a web browser
plug-in (many available for Firefox), or writing the stream to disk from a media player such as 
VLC or xmms, or using a graphical down-loader such as streamtuner. 

Using the ALSA PCM file
It is not necessary to use Audacity to record sounds playing on the computer. You can capture 
the sound from the application producing it before it reaches the sound device, which avoids 
capturing unwanted system sounds. This solution can be used even if there is no sound device. 
Note:  this solution may not work on a system using PulseAudio but you can use PulseAudio 
Volume Control instead. 

First you need to create (or if it already exists, add to the end of the file) ~/.asoundrc file. Do it 
with your favorite plain text editor. Note:  ~ is your home directory so change that to /home/john 
or whatever if you are not working in a Linux shell. 

See also this topic on the Audacity Forum

pcm.teeraw {
   type empty
   slave.pcm "tee:default,'/tmp/out.raw',raw"
   # 48000 S16_LE 2ch (aplay -t raw -f dat)
}

Now tell the application from which you are trying to record to use the "teeraw" ALSA device for 
playback - read the application's manual for help. Although there is no interface to do this for 
Adobe Flash, it can be achieved by setting the FLASH_ALSA_DEVICE environment variable to 
the name of the sound device to use, for example: 

FLASH_ALSA_DEVICE=teeraw firefox

Thanks to wensley.org for this tip. 

Run the application. Stop the application. Now /tmp/out.raw should contain your sound with 
perfect quality. If you change "default" to "null" in the above text, you will not hear anything but 
sound will still go to the file. If "empty" does not work with your ALSA library try with "copy". 

If you want to record all sounds played through the computer, you'll need to set the teeraw 
device as your default device with something like: 

pcm.!default{
   type empty
   slave.pcm "teeraw"
}
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In this case though, you will need to change "tee:default,'/tmp/out.raw',raw" to 
"tee:null,'/tmp/out.raw',raw" or something else because otherwise you create a loop. In many 
cases changing "null" to "dmix" should do the trick - you record any application audio and still 
hear it through your speakers. Note that you'll pick up random sounds from other applications 
such as system "dings" and the raw file could get corrupted or overwritten. Unless your ALSA 
install allows you a setup like below you must absolutely make sure that only the desired 
application is producing sound while you are recording this way. 

With newer ALSA versions you can try these parameters for convenience (also you can adapt to
use a different encoder than lame): 

pcm.teewav {
   type copy
   slave.pcm "tee:default,'/tmp/out.raw',wav"
}
pcm.teemp3 {
    type file
    format "raw"
    slave.pcm "default"
    file '|/usr/local/bin/lame -S -r -s %r --bitwidth %b -m j - /tmp/asound-$$.mp3'
}

Use a loopback cable
This is a simple and effective method of recording what is playing on the computer. It has the 
disadvantage that the audio signal is converted from digital to analog, then from analog to 
digital, instead of staying in the digital domain. This may result in some slight increase in noise 
and distortion. 

Plug your line-out or headphones-out to the line-in using a cable with a stereo mini-plug at each 
end, then record from line-in. To hear the sound while recording, use a single to double stereo 
connector to give you a jack for the speakers or headphones. 

If you have only mic-in and no line-in is selectable through alsamixer, you can build an 
attenuator to reduce the line level output to a level suitable for mic-in. But probably this will only 
provide mono recording, because mic-in is mono in most cases. As well, the quality may be 
questionable. 
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Step 2: Turn Software Playthrough off 
Software Playthrough must be turned off when recording computer playback. If playthrough is 
on, the sound card will try to play what it is recording then re-record it, creating an increasingly 
loud series of echoes that may damage your equipment. 

To turn off Software Playthrough, use the Recording page of Audacity Preferences: 

You can also choose Transport > Software Playthrough (on/off) to conveniently toggle 
playthrough off and on as required. 

Step 3: Monitor and set initial sound levels
Before recording for real, try to set sound levels by playing similar material from your intended 
source and monitoring it in Audacity, so that the input level will be neither too soft nor so loud as 
to risk clipping. 

There are two ways to turn monitoring on and off in Meter Toolbar: 

• Left-click in the right-hand recording meter to turn monitoring on. Click again to turn it off. 
• Use the context menu by either left-clicking the downward-pointing arrow beside the 

microphone symbol or right-clicking over the recording meter. Choose "Start Monitoring" 
or "Stop Monitoring" as appropriate. 
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The aim is to adjust levels so that the long red bars in Meter Toolbar don't exceed about -9.0 to 
–6.0 dB (or 0.5 if the meters are set to linear rather than dB). You can always amplify the 
recorded signal later if necessary. 

See Meter Toolbar for a detailed description of what the meter display shows. 

Both the output level of the audio you are recording and the level it's being recorded at will 
determine the achieved input level of the recording. Thus to achieve the correct input level you 
should use both the input and output level sliders on Mixer Toolbar: 

and probably the volume control on the web site or player software as well. It may be best to 
check that the Audacity output slider and the web site or player slider are turned up by about the
same amount, rather than having one output slider way down and the other way up. 

In most cases you can't turn down the output volume (for example, if you want to work) 
and still record computer playback. If you need to do this, unplug the speakers or on 
Windows XP or earlier, turn down the "Speaker" slider (not the "Wave" slider") in "Sounds
and Audio Devices" in the Windows Control Panel. 

Step 4: Make a test recording
Make a test recording to refine levels if necessary. 

. 
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Have a look at the recorded waveform - there should be no clipping visible. Clipping is bad - 
this is when the volume of the source sent to Audacity is louder than Audacity can record. The 
result is that the tops and bottoms of the recorded wave are chopped off ("clipped"). The 
illustrations below show about 0.004 seconds of a properly recorded waveform then a clipped 
waveform. You'll need to zoom in to inspect the waveform as closely as this, but extended 
lengths of clipping will also be visible at lower zoom levels. 

A properly recorded waveform  

A clipped waveform  

You can also check for clipping by choosing View > Show Clipping from the menu. Audacity will 
display vertical red lines in the waveform wherever it detects any clipped samples.

• Show Clipping may detect clipping when Meter Toolbar does not, because Meter Toolbar 
detects only runs of four or more clipped samples. Any clipping of three samples or less is
unlikely to be audible in most recording circumstances, but it's still a good idea to turn the
output or input level down if you can. 

• On slower machines it's best to turn Show Clipping off when recording for real. 

If clipping occurred, turn the recording or output level down a little and try again. 

If no clipping occurred you can now Edit > Undo Record from the menu to remove the test 
recording(s) then make the real recording. 
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Step 5: Make the real recording
Click the Record button  in the Transport Toolbar then start the audio playing on the computer.
Continue recording for as long as you want, but keep an eye on the "disk space remaining" 
message (in the Status Bar at bottom left of the Project Window) and on the recording meter (to 
ensure that you are maintaining a good level without clipping). 

When you have finished recording, click the Stop button . 

Step 6: Backup the capture
It is strongly recommended that you Export a safety copy of the raw recording in uncompressed 
WAV or AIFF format. This is particularly important if the recording is a one-off and cannot be 
repeated. The backup can always be returned to should you make a mess of your subsequent 
editing. For extra safety or convenience you could also copy the backup to an external drive or a
CD - either a data CD for playing on the computer or an audio or "music" CD for a CD player. 
Find out more at Burning music files to a CD. 

At this stage you will probably want to use File > Save Project before proceeding with any 
editing. This is useful if you want to come back to editing later on. 

Step 7: Editing
If you have not been able to make a test recording and find that you have some clipping in the 
real recording then, provided that the clipping is not too severe, you may be able to repair the 
clipping with Audacity's Effect > Clip Fix .... You should use the Clip Fix effect to repair any 
clipping immediately after recording and prior to undertaking any further editing. 
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How to import CDs
Audacity does not contain any function for importing (ripping) audio from CDs. This can, 
however, be achieved by using other programs to extract the data into a file format 
Audacity does support. 

Audacity does not contain any function for importing (ripping) audio from CDs. This can, 
however, be achieved by using other programs to extract the data into a file format Audacity 
does support. 

Users new to audio editing are often surprised to find that they cannot import the audio from 
CDs into Audacity with the File > Import > Audio command. In fact, most operating systems 
don't actually allow the import of data from the CD tracks into applications, because audio CDs 
don't have files or a file system like computer media, but consist essentially of a stream of bits 
on the disk. That is why when you look at an audio CD in a file manager like Windows Explorer, 
each CD track will appear only as a small .cda "file" 44 bytes in size, which is merely header 
information for the stream. 

In order to import tracks from an audio CD, you must first usually extract (or "rip") the tracks to a
WAV or AIFF audio file using CD extraction software. Then you can import that WAV or AIFF into
Audacity with the usual File > Import > Audio command. 

Windows
For users on Windows, CDex is a fully featured CD extraction program which can extract to the 
WAV format you need for editing the audio in Audacity. 

In the CDex window, simply select the CD tracks you want to extract to WAV and press F8 or 
Convert > Extract CD track(s) to WAV file. Normally, every CD track will be extracted to its own 
audio file, but CDex also has a nice feature that lets you extract any range of audio (including all
of it) to a single file. So if you want to extract a sample of two CD tracks that starts in the middle 
of one track and ends in the middle of another, you can. To do this, select Convert > Extract a 
section of the CD or press F10. 

Make sure you know where to look for the exported WAV files when you import them into 
Audacity. By default CDex saves the WAV to one of your Documents and Settings folders for 
whatever account you are logged into at the time. Choose Options > Settings or shortcut F4 
then click on General > Directories & files . Look in the second text box from the top (marked 
".WAV -> MP3") and you will see the location where it saves its output files from CD extraction 
or file conversion. 
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You can also extract audio CDs to WAV with Windows Media Player 11 (click Tools > Options >
Rip Music and choose "WAV (Lossless)" in the Format drop-down in "Rip Settings"). Earlier 
versions of Windows Media Player are not appropriate for extracting CD audio for editing in 
Audacity, because they are unable to extract to WAV. 

Alternatively you can use the Windows version of iTunes  to extract audio CDs to WAV or AIFF. 

OS X
OS X users have a quick way to import CDs, because when a CD is put in the drive, the CDA 
tracks are mounted as AIFF files in the Finder. It's thus possible to either drag the AIFF files 
from the Finder into Audacity, or use the File > Import > Audio command, instead of extracting 
the audio. 

Another possibility is to use Max, a free software CD ripping and encoding application. It has full
support for encoding into the FLAC lossless audio format. Click here for help adding FLAC 
support to iTunes. 

Linux
On Linux or other Unix-like systems you can use K3b  for the KDE desktop or RipperX  or 
Sound Juicer  for GNOME. Or use any built-in CD extraction utility that comes with the 
distribution. 
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Digital Audio

Digital audio brings analog sounds into a form where they can be stored and manipulated on a 
computer. Audacity is a software program for editing, mixing, and applying effects to digital 
audio recordings. 

Digital Sampling 
All sounds we hear with our ears are pressure waves in air. Starting with Thomas Edison's 
demonstration of the first phonograph in 1877, it has been possible to capture these pressure 
waves onto a physical medium and then reproduce them later by regenerating the same 
pressure waves. Audio pressure waves, or waveforms, look something like this: 

Analog recording media such as a phonograph records and cassette tapes represent the shape 
of the waveform directly, using the depth of the groove for a record or the amount of 
magnetization for a tape. Analog recording can reproduce an impressive array of sounds, but it 
also suffers from problems of noise. Notably, each time an analog recording is copied, more 
noise is introduced, decreasing the fidelity. This noise can be minimized but not completely 
eliminated. 

Digital recording works differently: it samples the waveform at evenly-spaced timepoints, 
representing each sample as a precise number. Digital recordings, whether stored on a compact
disc (CD), digital audio tape (DAT), or on a personal computer, do not degrade over time and 
can be copied perfectly without introducing any additional noise. The following image illustrates 
a sampled audio waveform: 
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Digital audio can be edited and mixed without introducing any additional noise. In addition, many
digital effects can be applied to digitized audio recordings, for example, to simulate 
reverberation, enhance certain frequencies, or change the pitch. 

Audacity's ability to play or record audio directly from your computer depends on your specific 
computer hardware. Most desktop computers come with a sound card with 1/8" jacks for you to 
plug in a microphone or other source for recording, and speakers or headphones for listening. 
Many laptop computers have speakers and a microphone built-in. The sound card that comes 
with most computers is not particularly high quality, in this case you may want to consider using 
an external USB soundcard.

Digital Audio Quality 
The quality of a digital audio recording depends heavily on two factors: the sample rate and the 
sample format or bit depth. Increasing the sample rate or the number of bits in each sample 
increases the quality of the recording, but also increases the amount of space used by audio 
files on a computer or disk. 

Sample rates
Sample rates are measured in hertz (Hz), or cycles per second. This value simply represents 
the number of samples captured per second in order to represent the waveform; the more 
samples per second, the higher the resolution, and thus the more precise the measurement is of
the waveform. The human ear is sensitive to sound patterns with frequencies between 
approximately 20 Hz and 20000 Hz. Sounds outside that range are essentially inaudible, 
although Rupert Neve has subjectively proven the existence of pysychoacoustic fidelity that can 
be heard above this supposed limit of 20000 Hz. 

Capturing a sound at a particular frequency requires a sampling rate of at least twice that 
frequency (known as the Nyquist frequency). Therefore a sample rate of 40000 Hz is the 
absolute minimum necessary to reproduce sounds within the range of human hearing, though 
higher rates (called oversampling) may increase quality even further by avoiding any aliasing 
artifacts around the Nyquist frequency. The sample rate used by audio CDs is 44100 Hz. 
Human speech is intelligible even if frequencies above 4000 Hz are eliminated; in fact 
telephones only transmit frequencies between 200 Hz and 4000 Hz. Therefore a common 
sample rate for audio recordings is 8000 Hz, which is sometimes called speech quality. Note 
that very steep filtering (called an anti-aliasing filter) is required above the Nyquist frequency in 
order to prohibit signal above this cut-off point from being folded back into the audible range by 
the digital converter, and creating the distorting artifacts of aliasing noise. 

The most common sample rates measured in Hz are 8000, 16000, 22050, 44100, 48000, 96000
and 192000. Sample rates can also be referred to in kHz or units of 1000 Hz. So in units of kHz 
the most common rates are expressed as 8 kHz, 16 kHz, 22.05 kHz, 44.1 kHz, 48 kHz, 96 kHz 
and 192 kHz. 

Audacity supports any of these sample rates, however most computer sound cards are limited 
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to no more than 48000 Hz, 96000 Hz or sometimes 192000Hz. Again, the most common sample
rate by far is 44100 Hz and many cards will thus default to this rate, whatever other rates they 
support. 

In the image below, the left half has a low sample rate, and the right half has a high sample rate 
(ie. high resolution): 

Sample formats 
The other measure of audio quality is the sample format (or bit depth), which is usually 
measured by the number of computer bits used to represent each sample. The more bits that 
are used, the more precise the representation of each sample. Increasing the number of bits 
also increases the maximum dynamic range of the audio recording, in other words the 
difference in volume between the loudest and softest possible sounds that can be represented. 

Dynamic range is measured in decibels (dB). The human ear can perceive sounds with a 
dynamic range of at least 90 dB. However, whenever possible it is a good idea to record digital 
audio with a dynamic range of far more than 90 dB, in part so that sounds that are too soft can 
be amplified for maximum fidelity. Note that although signals recorded at generally low levels 
can be raised (that is, normalized) to take advantage of the available dynamic range, the 
recording of low level signals will not use all of the available bit depth. This loss of resolution 
cannot be re-captured simply by normalizing the overall level of the digital waveform. 

Common sample formats, and their respective dynamic range include: 

• 8-bit integer: 48 dB 
• 16-bit integer: 96 dB 
• 24-bit integer: 145 dB 
• 32-bit floating point: near-infinite dB 

Note that there are practical limitations on dynamic range due to the capabilities of the hardware
and input and output converters. These make the practical limit more like 90 dB for 16-bit. 

Other sample formats such as ADPCM approximate 16-bit audio with compressed 4-bit 
samples. Audacity can import many of these formats, but they are rarely used because of much 
better newer compression methods. 

Audio CDs and most computer audio file formats use 16-bit integers. Audacity uses 32-bit 
floating-point samples internally and, if required, converts the sample bit depth when the final 
mix is exported. Audacity's default sample format during recording can be configured in the 
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Quality Preferences or set individually for each track in the Track Drop-Down Menu. During 
playback, the audio in any tracks that have a different sample format from the project will be 
resampled on the fly using the Real-time Conversion settings in the Quality Preferences. The 
High-quality Conversion settings are used when processing, mixing or exporting. 

In the image below, the left half has a sample format with few bits, and the right half has a 
sample format with more bits. If you think of the sample rate as the spacing between vertical 
gridlines, the sample format is the spacing between horizontal gridlines. 

Size of audio files 
Audio files are very large, probably much larger than most files you work with (unless you work 
with video files). To determine the size of an uncompressed audio file, multiply the sample rate 
(for example 44100 Hz) by the sample format bit rate (for example 16-bit) by the number of 
channels (2 for stereo) by the number of seconds. A completely full 74-minute stereo audio CD 
takes up over 6 billion bits. Divide this by 8 to get the number of bytes; an audio CD is a little 
less than 800 megabytes (MB). See compressed audio below. 

Clipping 
One limitation of digital audio is that for most purposes it cannot deal with sound pressure 
waves that exceed the maximum levels it is designed to deal with. When a signal is recorded 
that exceeds the maximum level of +/-1.0 linear or 0 dB, samples outside the range are clipped 
to the maximum value, like this: 

A sound recorded with clipping will sound distorted and harsh. While there are some 
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techniques that can eliminate a small amount of noise due to clipping, it is always preferable to 
avoid clipping while recording. Change the volume on your input source (microphone, cassette 
player, record player) and set Audacity's input volume control (in Mixer Toolbar) such that the 
waveform is as large as possible (for maximum fidelity) without clipping. 

Note that at Audacity's default 32-bit float sample format, legitimately captured sample values in 
excess of the maximum can be stored but even if preserved in an exported 32-bit float file they 
will probably still distort on any conventional reproducing equipment. If Audacity encounters 
legitimate samples above the limit, the Amplify effect will show a negative default "Amplification 
(dB)" value and you may click OK at this setting to reduce the peak amplification to the 
maximum 0 dB without loss of the original peaks of the waveform. 

Compressed Audio 
Because digital audio files are so large, reduced sample rates were typically used whenever 
possible. In 1991, the MP3 (MPEG I, layer 3) standard changed everything. MP3 is a lossy 
compression technique that can dramatically reduce the file size of a digital audio file with 
surprisingly little effect on the quality. One second of CD-quality audio takes up 1.4 megabits, 
while a common bit rate for MP3 files is 128 kbps, which is a compression factor of more than 
10x! MP3 works by cleverly "throwing away" details about the audio waveform that humans are 
not very sensitive to, based on a psychoacoustic model of how our ears and brains process 
sounds. All MP3 files are not created alike; different psychoacoustic models will lead to different 
amounts of perceived distortion in the audio file. 

Audacity as shipped can import MP3 files but please add the optional LAME MP3 encoding 
library to your computer in order to export MP3 files from Audacity. 

With good speakers, most people can hear the difference between a 128 kbps MP3 and an 
uncompressed audio file from a CD. 192 kbps and 256 kbps MP3 files are more popular among 
audiophiles who prefer higher quality. 

There are many other lossy compressed audio file formats. Audacity fully supports the Ogg 
Vorbis format, which is similar to MP3 but is a completely open, patent-free standard. Over time 
the quality of Ogg Vorbis files has come to surpass the quality of MP3, and its format is more 
extensible so more improvements are possible. Ogg Vorbis is a great choice for your own audio,
however the reality is that many more devices such as iPods and other portable audio players 
support MP3 but not Ogg Vorbis yet. 

Other well-known compression methods include ATRAC, used by Sony MiniDisc recorders, 
Windows Media Audio (WMA), and AAC. Audacity supports more formats by adding the optional
FFmpeg library. 
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